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Introduction

This chapter provides you with general information about
Autodesk MapGuide® as well as an introduction to the

new features in this release. This chapter also includes an
overview of how the Autodesk MapGuide products work
together, suggestions for using this guide in the most effi-

cient way, and where to go for more information.

This chapter may be helpful to:

m  All Autodesk MapGuide users
m  New Autodesk MapGuide users

M

[

In this chapter

Overview

Key features of Autodesk
MapGuide

What's new in Release 67
System requirements

What's the fastest way
through this book?

Where to get more
information



Overview

Autodesk MapGuide is a suite of products that enable the distribution of
geographic information systems, digital design data, and related applications
over a network. Autodesk MapGuide allows you to deploy applications that
create, modify, and display information, including maps, drawings, designs,
schematics, and associated attribute data, over the Internet, an intranet, or
an extranet.

Autodesk MapGuide® Author users integrate data to define the appearance
and functions of maps, and Autodesk MapGuide® Viewer users access the
data when they view and interact with maps from a Web browser. Autodesk
MapGuide® Server responds to information requests generated by users as
they interact with the application.

Key Features of Autodesk MapGuide
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Autodesk MapGuide Author Key Features

Ability to open maps and save maps in XML format

Map and resource security control

Thematic map settings and symbology

Complete layer setup and definition, including support for layer groups
Multiple Document Interface (MDI) support

Global property settings, including projection information and map
extents

m Interactive Map Explorer for creating and updating maps, drawings,
designs, and schematics

m Full zoom/unzoom/pan functionality, including zooming to specific
features

Point feature posting
Intelligent map caching

Support for multi-server connection

Arbitrary X,Y coordinate system support for CAD designs, drawings, or
schematics

m Support for both vector and raster data types, overlaid, georeferenced, or
not georeferenced

Chapter | Introduction



Ability to link map features to Web applications
Control over map width/scale

Autodesk MapGuide Server Key Features

Integrates easily with existing Web sites
Easy to configure and manage
Scalable, multi-threaded architecture

Standard CGI interface for Netscape® Internet servers and Microsoft®
Internet Information Server

Custom NSAPI interface for Netscape Internet servers

Custom ISAPI interface for Microsoft Internet Information Server
GUI-based Server administration and monitoring utility
Comprehensive access, trace, error, and tracking logs

Built-in security access restriction controls

Support for data providers, allowing direct access to Oracle® Spatial, SHP,
and Autodesk® GIS Design Server databases

Serves interactive maps and drawings to users who have installed
Autodesk MapGuide Viewer

Serves maps and drawings with limited interactivity, without requiring
installation of Autodesk MapGuide Viewer (requires Autodesk MapGuide®
LiteView)

Autodesk MapGuide Viewer Key Features

m Access to dynamic, secure vector and raster data

m Versions available for Microsoft Windows®, Apple® Macintosh®, and

Sun™ SPARCstation™

m Familiar browser interface

Full zooming and panning functionality, including zooming to specific
map features

Ability to measure distances between indicated points on a map
Style display by scale

Multiple feature selection by list/radius/polygon

Map bookmarking

Buffer zone creation

Ability to copy to Windows Clipboard

Print capability

Key Features of Autodesk MapGuide | 11



Note This guide does not include instructions for using Autodesk MapGuide
Viewer. For information about using Autodesk MapGuide Viewer, refer to the
Autodesk MapGuide Viewer Help included with the Viewer and available from the
Autodesk MapGuide documentation page at the following Web site:
http://www.autodesk.com/mapguidedocs

What’s New in Release 6?
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Autodesk MapGuide includes the new features described in the following
sections. In addition to the changes listed here, this release includes
enhancements to the Autodesk MapGuide Viewer API. For details, refer to the
Autodesk MapGuide Viewer API Help.

Warning After you open and save a map in Autodesk MapGuide Author
Release 6, you cannot open the map in earlier releases of the program. To view
maps created in Autodesk MapGuide Author Release 6, users can easily upgrade
to Autodesk MapGuide Viewer Release 6 by downloading the new Viewer from
the following Web site:

http://www.autodesk.com/mapguideviewerdownload

Dynamic Authoring Toolkit

The Dynamic Authoring Toolkit (DAT) is a new product offered within the
Autodesk MapGuide product suite and designed to significantly increase the
flexibility of Autodesk MapGuide application development. This toolkit is
used for supporting applications that incorporate dynamic map authoring,
including the programmatic generation and composition of new maps or the
modification of existing maps and their properties. The Dynamic Authoring
Toolkit enables programmatic creation or modification of MWF files quickly,
without requiring the use of Autodesk MapGuide Author.

The Dynamic Authoring Toolkit serves as a conversion component, allowing
for translation between binary map file formats, MWF (Map Window Files)
and MLF (Map Layer Files), and its XML mabp file format, MWX (Map
Window XML File). The Dynamic Authoring Toolkit cannot modify MWE,
MLE, or MWX files. You will need to use a third-party XML tool to programat-
ically alter and validate XML files. Autodesk MapGuide Author can now open
and save MWX files.

Chapter | Introduction



Using a variety of XML parsing tools and development techniques, you can
dynamically generate new maps as well as modify existing maps and their
properties that were initially set using Autodesk MapGuide Author—all
during application run-time. For example, using the MSXML DOM object,
you could reset map layer definition properties by modifying the MWX file
directly. Alternatively, you could generate a new map (MWX) from scratch
by simply generating XML files or by combining XML elements from several
maps stored as MWX files.

The Dynamic Authoring Toolkit is implemented as an in-process COM DLL,
named MGDAT.dII, and can be used in any development environment that
supports COM automation.

For complete information about the Dynamic Authoring Toolkit, refer to the
Dynamic Authoring Toolkit Developer’s Guide.

Symbol Manager

Now, you can create your own symbol (SMB) files that include many
different file formats, including bitmap and DIB graphics, and TrueType
fonts. You can set up libraries of symbol files based on a theme or on the
frequency with which you use certain symbols.

Support for Autodesk DWG

This release of Autodesk MapGuide includes the capability to serve design or
map data stored in Autodesk drawing (DWG) format. Autodesk DWG design
file format is a worldwide standard across vertical industries, such as archi-
tectural design, and facilities planning and maintenance. In the previous
release, a data extension supported Autodesk DWG. This release incorporates
all the features of the DWG data extension into Autodesk MapGuide and
includes additional features for layer filtering, creating MapTips and reports,
hyperlinking features on DWG layers to Web sites, and accessing data both
in an Autodesk Map object data table and an external database using an
Autodesk Map database link table.

What’s New in Release 6? 13
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What'’s New in Autodesk MapGuide Author?

XML Support

Autodesk MapGuide now supports a new XML representation of an MWF
file: Map Window XML Files (MWXs), significantly increasing application
development flexibility. In Autodesk MapGuide Author, you can open and
modify maps saved in MWX format. With the Dynamic Authoring Toolkit,
you can convert files between MWE, MLF, and MWX formats. You use third-
party XML tools to modify the MWX files. See “Dynamic Authoring Toolkit”
on page 12 for an overview of the Dynamic Authoring Toolkit.

Enhanced Symbol and Symbol Library Support

Now, you can incorporate numerous file formats, including bitmaps and
TrueType fonts, into map layers. Using Autodesk MapGuide Author, you can
modify the transparency of symbols you apply to both point layers and
redline layers. You can also include both bitmap images and vector graphics
in the same symbol file.

What'’s New in Autodesk MapGuide Server?

Improved Load Balancing

Changes to the MapAgent files improve load balancing between servers. All
MapAgents now distribute requests evenly between the available servers,
even at low load. MapAgents rank the available servers into an ordered list,
starting with the best candidate to process the request. If a server fails to
generate a response either because it is offline, or because it doesn’t under-
stand the request, the MapAgent tries the next server in the list until it gets
a successful response, or until there are no more servers to try. In previous
Autodesk MapGuide Server releases, MapAgents returned an error as soon as
they encountered it.

Improved MapAgent Error Messaging

When working with multiple servers, Autodesk MapAgent now tells you
which server is unable to process a client request without revealing the
server’s IP address but by displaying its order number in the list of servers in
the registry file.

Chapter | Introduction



Support for ECW and MrSID Raster File Formats

Autodesk MapGuide Server enables you to access Enhanced Compressed
Wavelet (ECW) images and Multi-Resolution Seamless Image Database
(MsSID) version 1.6 images.

ECW and MrSID images already contain georeferencing information so you
don’t need to use Raster Workshop when working with them.

What’s New in Autodesk MapGuide Viewer 6?

Support for Map Redraw Operations

New API methods enable developers to control how frequently and under
what conditions a map displayed in Autodesk MapGuide Viewer redraws.
Also, new map redrawing functionality removes the flash that was visible
when a map displayed in Autodesk MapGuide Viewer redraws.

System Requirements

Following are the system requirements for using Autodesk MapGuide
Author, Autodesk MapGuide Server, and Autodesk MapGuide Viewers.

Autodesk MapGuide Author Requirements

Autodesk MapGuide Author requires the following:

m Microsoft Windows 98 Second Edition, Windows NT 4.0 with Service Pack
4 or later, or Windows 2000 Professional

Pentium-based PC

32 MB of RAM

16 MB of free hard disk space

Super VGA or better video display

Mouse or compatible pointing device

System Requirements | 15
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Autodesk MapGuide Server Requirements

Autodesk MapGuide Server requires the following:

Chapter |

Microsoft Windows NT® 4.0 Server with Service Pack 4 or later, with one
of the following Web servers:

m Microsoft Internet Information Server 4.0

m Netscape Enterprise Server 3.6 with Service Pack 3

m iPlanet Web Server Enterprise 4.1 with Service Pack 8

Windows 2000 Server with Service Pack 2 or later, running Microsoft
Internet Information Server 5.0

Microsoft Data Access Components (MDAC):

m MDAC 2.5 with Service Pack 1
MDAC 2.5 is included on the Autodesk MapGuide product CD in the
following location: \MDAC2.5\MDAC_TYP.EXE

m MDAC 2.6 RTM with Microsoft Jet 4.0 with Service Pack 5

Pentium-based PC

128 MB of memory

85 MB of free disk space (plus additional space for your data)
VGA or higher resolution video adapter

Mouse or compatible pointing device

OLE DB providers required for access to relational data sources that con-
tain map data. For a list of supported OLE DB providers, choose

Help » Contents, click the Index tab, and look up “data sources, about
OLE DB.”

TCP/IP network protocol installed on the Windows NT/2000 computer
(TCP/IP provided on the Windows NT/2000 installation CD)

Introduction



Autodesk MapGuide Viewer Requirements

The three versions of Autodesk MapGuide Viewer (ActiveX Control, Plug-In,
and Java"" Edition) each require different configurations.

Autodesk MapGuide ActiveX Control Viewer
Requirements

m Microsoft Windows 98 Second Edition, Windows NT 4.0 with Service Pack
4 or later, or Windows 2000 Professional

m 486 or Pentium-based PC with 16 MB of memory (24 MB required if using
Windows NT 4.0)

m Mouse or compatible pointing device

m Web browser: Microsoft Internet Explorer 5.x

Autodesk MapGuide Plug-In Viewer Requirements

m Microsoft Windows 98 Second Edition, Windows NT 4.0 with Service Pack
4 or later, or Windows 2000 Professional

m 486 or Pentium-based PC with 16 MB of memory (24 MB required if using
Windows NT 4.0)

m Mouse or compatible pointing device

m Web browser: Netscape Navigator® 4.x

Autodesk MapGuide Viewer, Java Edition Requirements

m Microsoft Windows 98 Second Edition, Windows NT 4.0 with Service Pack
4 or later, or Windows 2000 Professional

m 486 or Pentium-based PC with 16 MB of memory (24 MB required if
using Windows NT 4.0 and Microsoft Internet Explorer)

m Mouse or compatible pointing device
m Web browser: Netscape Navigator 4.7, or Microsoft Internet
Explorer 5.x
m Mac® 059.1

m Apple Macintosh computer with 32 MB of memory (64 MB or more
recommended)

m Mouse or compatible pointing device
m Web browser: Microsoft Internet Explorer 5.x with Java VM MR]J 2.2.4.

System Requirements | 17



m Sun Solaris” 2.6 or 2.8
m Sun SPARCstation with 64 MB of memory
m Mouse or compatible pointing device

m Web browser: Netscape Navigator 4.7

What’s the Fastest Way Through This Book?
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This guide is designed for all the different stages of Autodesk MapGuide
development and for different kinds of Autodesk MapGuide users. To deter-
mine which parts of this guide you should read, review the following
information.

I’m just getting started with Autodesk MapGuide.

Read the rest of this chapter to determine the types of people you will need
to work on your project and the skills they will need, and where to go for
more information. Then, follow the steps in “Overall Strategy” on page 43
for information about how to set up Autodesk MapGuide and develop appli-
cations that interact with it. Depending on your role in Autodesk MapGuide
projects, you can then decide which chapters to read.

| already have Autodesk MapGuide up and running.

If you already have data that you are using, read Chapter 5, “Working with
Data in Autodesk MapGuide,” for information about how to optimize your
data to improve performance. If you want to evaluate how well you have set
up your project, whether to use multiple servers instead of a single server,
and other system design considerations, read Chapter 3, “Designing Your
System.” Finally, read “Where to Get More Information” on page 22 for
information that is beyond the scope of this guide.

| just want to know what tasks to do for my job.

Depending on your role, you will need to perform different tasks from other
people working on the project with you. The scope of implementing
Autodesk MapGuide can vary widely. In some cases, one or two people can
create and post a map. In others, several contributors work together to create
an Autodesk MapGuide Web site. The following list explains the possible
roles involved in an Autodesk MapGuide implementation and describes the
tasks and skills required of each role.

Chapter | Introduction



Note that one person might perform more than one of these roles, or you
might divide the responsibilities of a single role among several people. If you
are a project manager trying to determine whom you need to hire, or a devel-
oper trying to determine what training you need, information in this section
can help you plan for your next Autodesk MapGuide implementation.

Data Engineer

The data engineer is responsible for gathering and managing all spatial data
resources, such as vector mapping data and raster images, as well as attribute
data, such as tables of population and other demographic information that
is linked to the spatial data. If you will not be using a data provider to directly
access Autodesk GIS Design Server, Oracle Spatial, or SHP data, the data engi-
neer converts vector data from other formats into Spatial Data (SDF) files,
uses Raster Workshop to work with raster images, and then provides those
files to the server administrator. The data engineer might use Autodesk Map
to create spatial data, or use SDF Loader to convert spatial data from other
sources. Data engineers need to work with map authors to determine what
spatial data is needed for the maps, and then either create or acquire that
data.

Data engineers will find information they need in Chapter 5, “Working with
Data in Autodesk MapGuide,” and Chapter 6, “Planning and Designing
Maps.”

Map Author

The map author uses the resources provided by the data engineer to create
maps in Autodesk MapGuide Author. Map authors need to be familiar with
coordinate systems, and with GIS or CAD in general. They should have a
good understanding of what information to show in the map and how to
display information cartographically. They will work closely with the data
engineer to get the data that they need. They will also work with the server
administrator to make sure they are given authoring privileges and have
access to the data through the server.

Map authors need to decide the type of maps to deliver:

m Maps and drawings with limited interactivity that do not require an
Autodesk MapGuide Viewer installation (requires LiteView)
m Highly interactive maps and drawings requiring a Viewer installation

m A combination of both types of maps and drawings, offering limited
maps initially, with the opportunity to install a Viewer for increased
interactivity

Map authors will find information they need in Chapters 5 through 9.

What's the Fastest Way Through This Book? | 19
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Server Administrator

The server administrator oversees Autodesk MapGuide Server and the
Windows NT Server or Windows 2000 Server computer on which it runs. This
person is responsible for setting up the server architecture, security (password
access and access keys), network connections, database access, and search
paths for data sources and image files. The server administrator also installs
the Web server, Autodesk MapGuide Server, and MapAgent software, as well
as OLE DB providers, geocoding data and, in some cases, Macromedia
ColdFusion® and/or Active Server Pages™ (ASP). Server administrators need
to maintain Autodesk MapGuide Server using Autodesk MapGuide Server
Admin.

Server administrators will find information they need in Chapters 2, 3, and 4.

Webmaster

The Webmaster is responsible for all Web site content, including HTML-
embedded maps. Webmasters need to be able to build and maintain a Web
site. The Webmaster will work with the application developer when creating
a map-enabled Web site that extends the functionality of Autodesk
MapGuide Viewer. Webmasters will find information they need in
“Publishing a Map” on page 151.

Application Developer

The application developer uses programming skills to build custom Autodesk
MapGuide Viewer applications and server-side scripts and reports. Applica-
tion developers need to be able to perform the following tasks:

m Create HTML pages with embedded Java™, JavaScript, JScript, or VBScript
code that accesses the objects of the Autodesk MapGuide Viewer API. For
example, you might create an HTML form containing a button that turns
a layer on and off, or a drop-down list that selects map features.

m Create custom reports with ColdFusion, Active Server Pages, or another
third-party application.

m In some cases, create server-side applications with the SDF Component
Toolkit. A server-side application created with the SDF Component Tool-
kit can dynamically update SDFs posted on an Autodesk MapGuide Server.
For example, you could create an application that lets users add polygon
lot lines to a map from their local browser.

Application developers should be very familiar with Autodesk MapGuide and
will find information they need in Chapter 2, “Understanding Autodesk
MapGuide,” Chapter 3, “Designing Your System,” (with particular attention
to “Choosing a Viewer/Browser Environment” on page 63).
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Help Index

maps

Conventions Used in This Manual

The following table describes conventions used in this manual:

This word or phrase...

Indicates this...

Choose Edit » Properties

Click the Edit menu, and then choose Properties from
the Edit menu. If three levels of menus are shown, it
means that there is a secondary or submenu.

For example, the text:
Click Start » Settings » Control Panel
indicates that when you click the Settings menu item in

the Start menu, a submenu appears, from which you
choose Control Panel.

the <Netscape home>
\ <Computer name>\ config
directory

Text in italics indicates directories, file names, and keys
in the Windows Registry.

Click Press and release the left or primary mouse button.
Right-click Press and release the right or secondary mouse button.
Drag Hold down the mouse button while you move the

mouse.

Note When you see text in the left margin of this guide with the heading “Help
Index” as shown to the left of this paragraph, this indicates that there is addi-
tional, related information in the Autodesk MapGuide Help, which is available
when you choose Help » Contents and click the Index tab in either Autodesk
MapGuide Author or Autodesk MapGuide Server Admin.
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In addition to this guide, there are a number of helpful resources, both
printed and online. To download any of these documents, go to
http://www.autodesk.com/mapguidedocs. Most of the user documentation
from the Autodesk Web site is in Portable Document Format (PDF).

Viewing PDFs

To view guides in PDF format, you need to install Adobe Acrobat Reader,
which is available on the Autodesk MapGuide product CD in the following
location:

\AcrobatReader\ar500enu.exe

Reusing PDF Text

You can copy text from this PDF file and paste it into another application.
For example, you may want to copy code samples for use in your own work.

To copy text from a PDF file

1 Click the Text Select tool on the Acrobat Reader toolbar.
2 Drag to select the text you want to copy.

3 Right-click and choose Copy from the shortcut menu.
The text is copied to the Clipboard.

Autodesk MapGuide User Documentation

Following is a list of all of the guides and Help systems available for Autodesk
MapGuide users.

Autodesk MapGuide Help

This Help system provided with Autodesk MapGuide Author and Autodesk
MapGuide Server includes general information about using Autodesk
MapGuide products, specific step-by-step procedures, and reference informa-
tion. You can access the Help by choosing Help » Contents, by clicking the
Help button on the toolbar, or by clicking the Help button in any Autodesk
MapGuide Author or Autodesk MapGuide Server Admin dialog box.
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Autodesk MapGuide User’s Guide

This printed guide is included in the Autodesk MapGuide product package.
You can also install this guide in Adobe Acrobat (PDF) format from the
Autodesk MapGuide Documentation installer on the Autodesk MapGuide
CD. You can access this guide from the Start menu by choosing Products »
Autodesk MapGuide Release 6 » Documentation » Autodesk MapGuide
User’s Guide.

Symbol Manager Help

This Help system is included in the Autodesk MapGuide Help and includes
general information about working with symbols and symbol (SMB) files. To
access the Symbol Manager Help, choose Help » Contents » Creating and
Publishing Maps » Using Symbol Manager, or click the Help button in any
Symbol Manager dialog box.

Autodesk MapGuide Viewer Help

This Help system is provided with Autodesk MapGuide Viewer. It includes
information about using Autodesk MapGuide Viewer but does not include
information for developers. You can access this Help file from the Autodesk
MapGuide Viewer popup menu by choosing Help » Contents » or by
clicking the Help button on the main toolbar.

SDF Loader Help

This Help system documents the SDF Loader command-line utility. It
contains conceptual and reference information about SDFs, including
parameters for converting from specific formats. You can access this Help
system from the Start menu by choosing Products » Autodesk MapGuide
Release 6 » Documentation » SDF Loader Help.

Raster Workshop Help

This Help system is provided with Raster Workshop. It provides overall infor-
mation as well as detailed descriptions of how to use Raster Workshop to
convert images to TIFF and tiled TIFF format, create raster image catalogs,
and more. To access this Help, click Help on either tab of the Raster Work-
shop main window.
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LiteView Servlet Administrator’s Guide

This guide, which is installed with the Autodesk MapGuide LiteView servlet,
contains information to help server administrators set up and maintain the
LiteView servlet environment. You can access this guide from the Start menu
by choosing Programs » Autodesk MapGuide Release 6 » LiteView » Servlet
Administrator’s Guide.

Provider for SHP Guide

This guide is installed with the Autodesk MapGuide Provider for SHP and is
written both for system administrators who need to configure the product
and for users who need to work with it. You can access this guide from the
Start menu by choosing Programs » Autodesk MapGuide Release 6 » Docu-
mentation » Provider for SHP Guide.

Provider for Oracle Spatial

This guide is installed with the Autodesk MapGuide Provider for Oracle
Spatial and is written both for system administrators who need to configure
the product and for users who need to work with it. You can access this guide
from the Start menu by choosing Programs » Autodesk MapGuide Release 6
» Documentation » Provider for Oracle Spatial Guide.

Autodesk MapGuide ReadMe File

The ReadMe file for all of the Autodesk MapGuide products includes a list of
known issues or late-breaking information that was not included in other
guides or Help files. You can access this file by going to

\\Program Files\Autodesk\MapGuideDocumentation6

and opening MGReadme.htm.
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Autodesk MapGuide Developer Documentation

Following is a list of the guides and Help systems available for Autodesk
MapGuide developers.

Autodesk MapGuide Developer’s Guide

This printed guide includes information about developing Autodesk
MapGuide applications and is included in the Autodesk MapGuide product
package. You can also install this guide in Adobe Acrobat (PDF) format from
the Autodesk MapGuide Documentation installer on the Autodesk
MapGuide CD. You can access this guide from the Start menu by choosing
Programs » Autodesk MapGuide Release 6 » Documentation » Autodesk
MapGuide Developer’s Guide.

Autodesk MapGuide Viewer APl Help

This Help system is a complete reference to the Autodesk MapGuide Viewer
API objects, properties, methods, and events. You install this Help system
from the Autodesk MapGuide Documentation installer on the Autodesk
MapGuide CD. You can access this Help system from the Start menu by
choosing Programs » Autodesk MapGuide Release 6 » Documentation »
Autodesk MapGuide Viewer API Help.

Dynamic Authoring Toolkit Developer’s Guide

This guide, which is installed with the Dynamic Authoring Toolkit, includes
information about working programatically with maps using eXtensible
Markup Language (XML) format. You can access this guide from the Start
menu by choosing Programs » Autodesk MapGuide Release 6 » Documen-
tation » Dynamic Authoring Toolkit Developer’s Guide.

Dynamic Authoring Toolkit Help

This Help file, which is installed with the Dynamic Authoring Toolkit,
provides context-sensitive Help for Dynamic Authoring Toolkit objects when
you develop applications in Visual Basic or in another visual environment.
You can access this Help system from the Start menu by choosing Products
» Autodesk MapGuide Release 6 » Documentation » Dynamic Authoring
Toolkit Help.
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Dynamic Authoring Toolkit Sample Application Help

These HTML files, which are installed with the Dynamic Authoring Toolkit,
describe four sample applications that demonstrate the functionality of the
Dynamic Authoring ToolKkit.

SDF Component Toolkit Help

This Help system is provided with the SDF Component Toolkit. The SDF
Component Object Model is of interest to advanced application developers,
who will want to refer to the list of objects, properties, and methods. You can
access this Help file from the Start menu by choosing Programs » Autodesk
MapGuide Release 6 » Documentation » SDF Component Toolkit Help.

LiteView Developer’s Guide

This guide, which is installed with Autodesk MapGuide LiteView,

includes information about developing applications for Autodesk MapGuide
LiteView. You can access this guide from the Start menu by choosing
Programs » Autodesk MapGuide Release 6 » LiteView » Developer’s Guide.

LiteView Sample Application Help

These HTML files, which are included with Autodesk MapGuide LiteView,
demonstrate the functionality of LiteView.

Third-Party Documentation

Many excellent third-party books are available. Your tastes may vary, but here
are some that we found useful:

m ColdFusion Web Application Construction Kit, by Ben Forta et al. (Que
Corporation)

m Programming Active Server Pages, by Scot Hillier and Daniel Mezick
(Microsoft Press)

m HTML Sourcebook, 4th Edition, by Ian S. Graham (John Wiley & Sons, Inc.)

m The Java Class Libraries, Second Edition: Volume 1 and Volume 2, by Patrick
Chan and Rosanna Lee (Addison Wesley Longman, Inc.)

m JavaScript: The Definitive Guide, 3rd Edition, by David Flanagan (O’Reilly
and Associates)

m Java in a Nutshell, 3rd Edition, by David Flanagan (O'Reilly and Associates)
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Additionally, there are many books that discuss GIS, its history, and its appli-
cations. Because these books vary in scope, quality, and price, you should
take the time to browse through them in your bookstore and select the one
that suits your needs. One title you might try is Principles of Geographical
Information Systems by Peter A. Burrough and Rachael A. McDonnell (Oxford
University Press).

Autodesk MapGuide Web Site

To get late-breaking information about the Autodesk MapGuide products, or
for links to technical notes and white papers that discuss various topics, go
to the Autodesk MapGuide Web site: http://www.autodesk.com/mapguide.
There is also a link to the online Autodesk MapGuide demos, which walk you
through the process of using sample applications. Many of the demos use
JavaScript to access the Viewer API, and you might find it useful to view the
HTML source used in these examples.

Tip From Autodesk MapGuide Author, you can go directly to the Autodesk
MapGuide Web site by choosing Help » Autodesk MapGuide Web Site.

Online Discussion Groups

The Autodesk online discussion groups, located at
http://www.autodesk.com/discussion, are open forums for Autodesk
customers, partners, or anyone with an interest in Autodesk’s products. You
can post information or questions, answer other members’ questions, or just
browse messages to gather information and learn tips and tricks from other
users. Your questions will be answered by other discussion group members or
Autodesk staff.

For best results when posting a question, please be sure to provide as much
information about the situation as possible. This includes your hardware
configuration (how many servers, how much RAM, etc.), your operating
system, the release number of the specific product, what steps you took
immediately prior to the problem, the exact error message that was
displayed, and any other information that will help us to understand the
issue. Providing this information will improve our ability to answer your
question immediately.
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Autodesk Developer Network

Autodesk Developer Network (ADN) is a developer-support organization that
provides its members with services including the following:

A quarterly CD containing Autodesk products, documentation, and
sample code

Technical training

Direct, comprehensive technical support
Marketing support

Developer consulting services

Access to private newsgroups

ADN membership is open to experienced professional software developers
who develop products and services that interface or integrate with Autodesk
products. For more information about membership requirements and fees,

80

to the Autodesk developers Web site at:

http://www.autodesk.com/developers
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Understanding Autodesk
MapGuide

This chapter includes an overview of the Autodesk
MapGuide® product suite, as well as information about
planning a strategy for using the Autodesk MapGuide

products.

This chapter may be especially helpful to:

m  Server administrators
m  Application developers

m  New Autodesk MapGuide users

M

[

In this chapter

What is Autodesk
MapGuide?

How Autodesk MapGuide
components work together

Map authoring products
Map viewing products
Map serving products

Developing applications
with Autodesk MapGuide

What is Autodesk MapGuide
application development?

Overall strategy

29



What Is Autodesk MapGuide?

Before you use Autodesk MapGuide, you need to understand some basic
concepts, including how to use the Autodesk MapGuide product suite as a
whole, and how to access your Autodesk MapGuide® Server and data
resources.

Autodesk MapGuide is a geographic information system (GIS). Unlike a
typical map or drawing, which shows only spatial data such as roads, cities,
and country borders, a GIS links attribute data, such as population statistics,
to spatial data. This link between the map data and the attribute data makes
a GIS very powerful, because it allows you to use data in a whole new way.

For example, you could create a map of restaurants that allows users to zoom
in to an area of interest, click a restaurant, and then view that restaurant’s
menu, pricing information, phone number, and address. Another example
would be creating a map of all power transformers in an area, so that your
technicians could quickly generate a report of all customers affected by a
particular transformer when it goes out of service. You could also create a
facilities map of your company, including information about personnel in
each office, such as telephone extension, title, department, and so on.

Keep in mind that when you use Autodesk MapGuide, you are not limited to
using geographically projected maps—you can also use drawings, floor plans,
schematics, or others kinds of spatial data.

How Autodesk MapGuide Works

To create an interactive map or drawing, you use Autodesk MapGuide®
Author to combine resource data, such as spatial data (spatial data files and
raster image files) and attribute data (from databases) in a Map Window File
(MWF). The MWF contains the complete specifications of how the map will
look and function.

To publish the map, you copy the MWF file to a location where the Web
server can access it. Web page authors can then embed the file in their Web
pages or create links to it. To view the map, users can install Autodesk
MapGuide Viewer free of charge. When the user opens a Web page that
contains an MWF file or clicks a link to an MWF file, the Web browser auto-
matically loads Autodesk MapGuide® Viewer to display the map.
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The Viewer displays the map according to the MWF settings specified in
Autodesk MapGuide Author.
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A map displayed with Autodesk MapGuide Viewer

When you use either Autodesk MapGuide Author to create a map or
Autodesk MapGuide Viewer to view a map, requests are made to Autodesk
MapGuide Server to provide the required data in that map via the Internet,
an intranet, or an extranet using the services of a Web server and a Web
browser.

How Autodesk MapGuide Products Work
Together

The three core products in the Autodesk MapGuide suite of products are:

m Autodesk MapGuide Author
m Autodesk MapGuide Server
m Autodesk MapGuide Viewer
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Clients

In addition to these products, there are a number of utilities and develop-
ment products. The following diagram provides an overview of how the
Autodesk MapGuide products work together.

Any Browser Autodesk Java Viewer ‘ ActiveX Viewer ‘ ‘ Plug-In Viewer ‘ Autodesk MapGuide
OnSite Client
Browser ‘ Browser ‘ ‘ Browser Author
Autodesk OnSite ‘
Servlet Java Sgrvlet Web Server e —
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GIS Design
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Map Authoring Products

This section describes the programs and data resources used to create a map.

Autodesk MapGuide Author

Autodesk MapGuide Author enables you to create maps by setting up Map
Window Files (MWFs). You can then embed one or more MWF files (or create
a link to them) in a Web page. When a user opens that Web page (or clicks
its link in the Web browser), Autodesk MapGuide Viewer appears and
displays the map.
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Dynamic Authoring Toolkit

You use the Dynamic Authoring Toolkit to open and save MWFs in an XML-
based format called Map Window XML (MWX). With MWX format, you can
modify map layers, layer groups, zoom gotos, reports, and so on, using any

third-party text editor or an application you develop.

You can extend the ability to modify maps to clients by monitoring Viewer
API methods or by enabling users to submit requests using a Web interface.
Based on Viewer activity or user response, you can dynamically modify the
following:

m Zooming, to account for the user’s map center and zoom extents
m Creating themes to display criteria users request
m Finding and modifying internal map settings at user requests

For example, users can submit the changes they want to apply to an MWF
using a ColdFusion or Active Server Page. You can create an application that
invokes the Dynamic Authoring Toolkit conversion component to convert
the MWF to MWX and apply the user’s changes. Using the Dynamic
Authoring Toolkit conversion component, you can then convert the MWX
back to MWF and send the modified map to the user’s Viewer.

Symbol Manager

Symbol Manager enables you to create and modify symbol (SMB) files so that
the symbols in the SMB files are based on criteria you define. You can also
modify the properties of symbols within the SMB files.

SDF Loader

SDF Loader is a command-line utility that converts spatial map data from a
variety of formats into Spatial Data Files (SDF), one of the native formats read
by Autodesk MapGuide Server. Specifically, some of the formats that you can
convert are Autodesk Map® DWG and DXF files, MapInfo MID/MIF files,
ESRI Arc/Info Coverage files, Intergraph DGN files, ArcView Shapefile files,
and Atlas BNA files, as well as ASCII comma-delimited CSV files. The SDF
Loader can convert the coordinates from their original coordinate system
into latitude/longitude, but it cannot perform datum shifts—all data must be
based on the same datum.
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The SDF Loader can also generalize your map data if it will be displayed at
smaller scales (zoomed out), which improves performance and reduces
required storage space. The SDF Loader is distributed on the Autodesk
MapGuide CD. For more information, refer to the SDF Loader Help
(SDFLOAD.HLP) located in the SDF Loader folder.

SDF Component Toolkit

The SDF Component Toolkit is a set of COM (Common Object Model)
objects for reading and writing Spatial Data Files (SDF), Spatial Index Files
(SIF), and Key Index Files (KIF), the native spatial data file formats of
Autodesk MapGuide products.

You can access SDF Component Toolkit objects in development languages
and environments such as C++, Visual Basic, VBA, VBScript, Java, JScript,
ASP, CGI, and ColdFusion. Using these languages and environments, you can
do the following:

m Write applications that convert spatial data to SDFs.

m Write applications that modify SDFs generated by Autodesk Map,
Autodesk Wor1d®, or SDF Loader.

m Create server-side applications that read and modify existing SDFs. These
applications can interact with client-side scripts, allowing for dynamic
updates based on user input.

For more information, refer to the SDF Component Toolkit Help
(SDFCOMTK.HLP) located in the \Help folder in the SDF Component Toolkit
folder.

Raster Workshop

The Raster Workshop is a utility that allows you to optimize your raster
images, which improves performance when they are accessed by Autodesk
MapGuide. You can generate TIFF files and tiled TIFF files (tiled TIFF files
improve performance) from standard image formats, create raster image
catalog (RIC) files, and manipulate the images that are referenced by the RIC.
You can then use the TIFF and RIC files with Autodesk MapGuide, or use the
TIFF files with other Autodesk products that support raster images. The Raster
Workshop is distributed on the Autodesk MapGuide CD. For more informa-
tion, refer to the Raster Workshop Help (RASTER.HLP) located in the Raster
Workshop folder.
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Map Viewing Products

This section describes how your Web browser works with Autodesk
MapGuide Viewer to display maps.

Web Browser

A Web browser is a client application that reads hypertext data in the form
of HTML pages containing text, graphic, and programmatic content. Web
pages are usually posted on the Internet, an intranet, or an extranet. An
intranet uses Internet technology, but is used internally by a company or
other organization; information on an intranet is not available to outside
users. An extranet extends an intranet to outside users who have been given
access rights, such as customers who access a site with a password.

In addition to reading and displaying Web pages, a Web browser can also
perform file transfers using file transfer protocol (FIP) and run helper
programs, such as Autodesk MapGuide Viewer.

Autodesk MapGuide Viewer

Autodesk MapGuide Viewer displays a map in your Web browser when you
open a Web page that contains an embedded MWF or when you click a link
to an MWE

Autodesk MapGuide Viewer is available in three versions:

m A Plug-In for use with Netscape® Navigator on Windows systems

m An ActiveX Control for use with Microsoft® Internet Explorer on
Windows systems

m AJava'" Edition for use with Netscape Navigator on Sun'" Solaris systems
and with Microsoft Internet Explorer on Apple® Macintosh® systems. It
can also be used on Windows, but we recommend that you use the Plug-
In or ActiveX Control instead.

All are available for download free of charge from the Autodesk MapGuide
Web site: http://www.autodesk.com/mapguide.

Note If you want to distribute maps without requiring that users install one of
the Viewers, you can do so using Autodesk MapGuide LiteView. For more infor-
mation, see the next section and the LiteView documentation.
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You can also write a stand-alone C++, Visual Basic, or Java application that
hosts Autodesk MapGuide Viewer without a Web browser. For details about
supported platforms, see “Choosing a Viewer/Browser Environment” on
page 63.

LiteView

LiteView serves maps in a raster format, with limited interactivity, so that
users are not required to install Autodesk MapGuide Viewer. For more infor-
mation, refer to the LiteView documentation.

Map Serving Products

Help Index

Web server

36

This section describes the software components that process and serve data
to the map.

Web Server

A Web server is an application that runs on a host computer. In response to
requests from other computers, the Web server software processes and sends
various types of files, such as Web pages and Map Window Files (MWFs).
When a user requests map data, that request is received by the Web server
and passed to Autodesk MapGuide Server. For information about the type of
Web servers Autodesk MapGuide supports, see “Autodesk MapGuide Server
Requirements” on page 16.

Autodesk MapGuide Server

Autodesk MapGuide Server serves map data in response to requests from
Autodesk MapGuide Author and Autodesk MapGuide Viewer when a user is
displaying a map in those programs.

When a request is made, Autodesk MapGuide Server reads the request to
determine which data to provide, and then sends the data from the spatial
data source, raster image file, Autodesk DWG data source, or OLE DB data
source according to the specifications made in the request. Autodesk
MapGuide Server allows you to control access to the data sources by checking
for passwords, user IDs, and other optional settings you specify.

Autodesk MapGuide Server consists of three components: MapAgent, Server
Service, and Autodesk MapGuide Server Admin.
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MapAgent

Autodesk MapGuide® Server Agent (or MapAgent) is an interface between
your Web server and Autodesk MapGuide Server. It receives requests for map
data from Autodesk MapGuide Author or Autodesk MapGuide Viewer via a
Web server. The MapAgent processes the requests as they are received and
passes them to Autodesk MapGuide Server. There are three different
MapAgent files that you can use with Autodesk MapGuide Server; for more
information, see “Which MapAgent to Install” on page 54.

Server Service

Autodesk MapGuide Server Service is a Windows NT/2000 service that
receives and processes the requests for map data distributed by the
MapAgent, formats the data as requested by the map layer, and then sends
the data back through the MapAgent across the Web to Autodesk MapGuide
Author or Autodesk MapGuide Viewer.

Autodesk MapGuide Server Admin

Autodesk MapGuide Server Admin gives you complete operational control
over Autodesk MapGuide Server. You can set security, generate log files,
configure data source directories and database access, and start and stop the
server.

Autodesk MapGuide Data Providers

Autodesk MapGuide data providers enable Autodesk MapGuide to serve
spatial and attribute data directly from a variety of traditional GIS, CAD, or
relational spatial databases. When you use an Autodesk MapGuide data
provider, you do not need to convert data to SDF format to use it with
Autodesk MapGuide. You can purchase Autodesk MapGuide data providers
for Autodesk® GIS Design Server, SHP, and Oracle8i" and Oracle9i" Spatial
data. For information about these data providers, contact your nearest autho-
rized Autodesk reseller. If you are not accessing spatial data through a data
provider, you will need to convert your data into one of the supported
formats.
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Developing Applications with Autodesk
MapGuide

This section describes the products and technologies used to create an
Autodesk MapGuide application.

An Autodesk MapGuide application can be as simple as an HTML page that
displays an embedded Map Window File (MWF), or it can be as complex as a
CGI application, coded in C++, that modifies data files on the server and
refreshes the browsers of everyone viewing the map. Usually it is something
between the two, such as a map embedded in a Web page that has buttons
and other controls on it that interact with the map.

B @K d|® 2 autodesk’

=7 |ncidents

P Closed

P MNew

' Open T
== Rairoads notification:

=
< Water Service

) incidents:
= water- 3tVal vector layers:

o 2
<27 wiater - Point ¢ raster layer:

O

== wiater - Distitn 1)

date: | Show all Z
status) Show all =

<= San Rafael

=2
== Zip Codes

O [

1] [1:4.252 [1.137 & 1,410 )

Example of an Autodesk MapGuide application

Autodesk MapGuide applications can be client-side or server-side. A client-side
application runs in the user’s browser, using the processing power of the
user’s (client) computer. It is typically an HTML page that hosts Autodesk
MapGuide Viewer and contains code to access the objects of the Autodesk
MapGuide Viewer APL. A server-side application runs on the server, and is
typically used for generating custom map reports, generating dynamic HTML
pages, and updating map resources, such as databases, GIS, or CAD files. In
most cases, applications are a combination of both client-side and server-side
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applications, but for the sake of simplicity, the following sections discuss the
components as being one or the other.

Client-Side Application Components

Client-side applications run in the user’s browser. A client-side application is
usually made up of the following components:

m A Web browser and an HTML page that hosts Autodesk MapGuide Viewer

m An MWEF that is read by Autodesk MapGuide Viewer and displayed as a
map

m Web browser scripts that access the APIs for the browser and Autodesk
MapGuide Viewer

HTML Pages

Usually, a client-side application is an instance of Autodesk MapGuide
Viewer that is displayed in an HTML page by means of the <EMBED>,
<OBJECT>, Or <APPLET> tag. (<EMBED> is used for the Netscape Plug-In,
<OBJECT> for the ActiveX Control, and <APPLET> for the Java Edition). The
HTML page might contain form elements (such as buttons and list boxes)
and code that access the Web browser API and the Autodesk MapGuide
Viewer API. You can also display the map full-screen (not embedded in an
HTML page) by using the <A HREF> tag in an HTML page and creating a link
to the MWE. For more information, refer to the Autodesk MapGuide Viewer API
Help.

Web Browser Scripts
Autodesk MapGuide supports the following HTML scripting languages:

m JavaScript—JavaScript is a full-featured scripting language that supports
the Netscape Plug-In on the Windows platform and the Java Edition on
the Windows and Sun Solaris platforms.

m JScript—]JScript is Microsoft’s variant of the JavaScript language. It sup-
ports the ActiveX Control and Java Edition for Internet Explorer on Win-
dows platforms. Throughout this book, we will often refer to JScript and
JavaScript collectively as JavaScript.

m VBScript—VBScript is a Visual Basic-derived language that supports the
ActiveX Control for Internet Explorer on Windows platforms.
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You can use these scripting languages to access the Autodesk MapGuide
Viewer API and the Netscape and Internet Explorer browser APIs. The scripts
can range from a single line to complex client-side map applications. For
more information, see “Choosing a Viewer/Browser Environment,” on page
63, and refer to the Autodesk MapGuide Viewer API Help.

Autodesk MapGuide Viewer API

Autodesk MapGuide Viewer exposes an object-oriented programming inter-
face (API) that gives you programmatic access to Autodesk MapGuide Viewer
functionality. For example, you can create a redlining application that gives
users the ability to digitize features and add notations to a map.

You can access the Autodesk MapGuide Viewer API from a browser script or
from a stand-alone application you create that hosts the Viewer. The API is
available when you install any version of Autodesk MapGuide Viewer. For
more information, refer to the Autodesk MapGuide Viewer API Help.

Web Browser APls

The Netscape and Internet Explorer APIs give you programmatic access to
browser and document functionality. The APIs include a Document Object
Model (DOM) that exposes the elements in an HTML page.

With the browser APIs, you can write a script that creates a new window or
frame and then outputs HTML to it dynamically. You can also create HTML
pages that change dynamically on user interaction. (This is called Dynamic
HTML.)

Note The Document Object Models for Netscape and Internet Explorer vary
somewhat. Therefore, when writing a single script for both browsers, be sure to
test your script carefully in both browsers.

Stand-Alone Applications

You can write a stand-alone C++, Visual Basic, or Java application that hosts
Autodesk MapGuide Viewer without a Web browser. For details about
supported platforms, see “Choosing a Viewer/Browser Environment” on
page 63.
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Server-Side Applications

Server-side applications run on the server (or host), creating or processing
data and serving it to the client machine. A server-side application (also
known as a server app) might be a counter that shows how many times a site
has been visited, or it might be a database that builds and serves HTML pages
dynamically. LiteView, used to display raster maps without a browser, is also
an example of a server-side application.

In Autodesk MapGuide, server-side applications are typically used to
generate and serve reports or to allow a user to update map data on the server
using a browser. Please note that these applications are typically a combina-
tion of client-side and server-side applications, but for the sake of simplicity,
they are discussed here as server-side applications.

Reports

You can design customized reports for your map. A report is an HTML page
generated by a script you create using a third-party tool like ColdFusion by
Macromedia Corporation, or Microsoft Active Server Pages (ASP). Report
scripts combine database queries and HTML tags to dynamically generate
pages on the server. These pages are then sent to the browser as standard
HTML. Because the design of the HTML page is specified as part of the report
script, the author of the report controls the way the page displays in the
browser.

In an Autodesk MapGuide application, the report typically provides informa-
tion about the selected map features or about a point the user specifies,
depending on the settings the map author specified in the MWE. In some
cases, database resources might be queried directly, bypassing the MWF
completely. When a user views the report, Autodesk MapGuide Server sends
the feature or point information to the report script, which extracts the
appropriate content from a database and then displays an HTML page with
the results in the Web browser. Examples of reports might be demographic
data for the specified layers or the latitude/longitude coordinate of the spec-
ified point. For more extensive information about reports, refer to the
Autodesk MapGuide Developer’s Guide.
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User-Updatable Map Resources

You can create server applications that give users the ability to update map
resources from their browsers. These resources can be database map layers,
attribute data associated with a feature, or even the SDFs themselves.
Updating a database from the browser uses the same mechanisms that
reports use.

For example, you could create a “crime watch” application. The application
would include an HTML form where users could add map points repre-
senting crime incidents, as well as attribute data describing details of the inci-
dents. Subsequent users could use the form to add their own comments to
the database. In another example, you could create a redlining tool for
surveyors. Using this tool, workers in the field could add polylines repre-
senting lot lines to the SDFs so that the changes would be visible to anyone
else viewing the map. For more information, refer to the Autodesk MapGuide
Developer’s Guide.

What Is Autodesk MapGuide Application
Development?

The Autodesk MapGuide application development process allows you to add
Autodesk MapGuide functionality to your Web site. The entire process
includes writing the client-side and server-side code, as well as the steps
involved in designing your Autodesk MapGuide project and server layout,
setting up an Autodesk MapGuide Server and a Web server, gathering your
data, and creating your HTML pages.

The following are eight main tasks involved in setting up your Autodesk
MapGuide Web site and developing applications:

1 Familiarize yourself with GIS and the Autodesk MapGuide product
architecture.

2 Design your system, by deciding which Web server to use, whether to use
multiple servers, the directory structure for your project, how you will
implement security, and so on. Determine whether you will require users
to install Autodesk MapGuide Viewer, or whether you want to use Lite-
View to serve maps with limited interactivity.

3 Set up your server. This includes installing and configuring your Web
server, installing Autodesk MapGuide Server, installing a reporting engine,
setting up a development environment, and adding files to the server.
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4 Decide on your data strategy and work with your data. You will need to
determine whether to use a data provider to access data directly or
whether to convert your data. This includes creating spatial data, attribute
data, raster images, symbols, Zoom Goto categories, and reports, and then
adding this data to your map. It also includes optimizing the data you
create and ensuring that you're using the correct coordinate system and
precision.

5 Create your maps using Autodesk MapGuide Author or Dynamic
Authoring Toolkit, and post them on the server.

6 Add the maps to Web pages and develop client-side applications to
interact with the maps.

7 Develop report scripts that either display data for selected features on the
map or dynamically update the databases when the user clicks the map or
enters information.

8 Optionally, use SDF Component Toolkit to develop applications that
allow you to modify your Spatial Data Files (SDF) by editing, deleting, or
adding geographic features from the browser.

Overall Strategy

Setting up Autodesk MapGuide and developing an application is much like
cooking: rather than working on one task at a time, you need to work on
several of them at once, going back and forth between the tasks as needed.
This section uses this approach and outlines the best strategy for setting up
Autodesk MapGuide and developing applications. The process includes three
main phases: installation and testing, planning and design, and
implementation.

The following sections describe these phases. For more information about
the second phase, planning and design, see Chapter 3, “Designing Your
System.”

Phase One: Installation and Testing

This phase involves installing and testing all of the components to make sure
that your system is ready. You can take two approaches to this phase. The
first approach is to read through Chapter 3, “Designing Your System,” to
determine exactly how you want to set up your system before you install the
products.
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The other approach is to do a basic installation to get an idea of how every-
thing works together and make sure it all works properly, and then use that
knowledge in Phase Two when you plan and design your complete Autodesk
MapGuide application. In either case, the data and map layer you create in
this phase should be very basic and for testing purposes only.

To install and test the components

1

10

Install your Web server and Web browser, and then type your Web server
URL in the Web browser to make sure that the browser is communicating
with the Web server.

Create OLE DB data sources for your attribute data (or Autodesk DWG data
sources if working with Autodesk DWG files), and then test them with
Access, Excel, or another database application to make sure that you can
access the data through the data source names you created. If you are not
sure which attribute data you will be using, skip this step for now and
return to it during Phase Three when you create your data.

Install Autodesk MapGuide Server, and then type your Autodesk
MapGuide Server URL in the Web browser to make sure that the browser
is communicating with Autodesk MapGuide Server.

Install Autodesk MapGuide Author, and then open tutorial.mwf to make
sure you can access the Internet through Autodesk MapGuide Author. If
you will be using Autodesk MapGuide on an intranet only, skip this step.

If you are using a data provider to access data directly, install the data pro-
vider as described in the data provider’s documentation. If you are not
using a data provider, install SDF Loader, and then convert one file to SDF
format.

In Autodesk MapGuide Author, create a new layer based on the SDF you
created in the previous step or based on the data you are accessing
through a data provider.

If the layer links to an OLE DB data source or an Autodesk DWG data
source, create the link and then test it by pausing the mouse over features
on the layer to make sure the MapTips are displaying the feature names.
Save the MWF from Autodesk MapGuide Author.

Create an HTML page that references the MWF and post it in the Web
server directory.

Install the version or versions of Autodesk MapGuide Viewer that you will
be supporting, and then in your Web browser, type the URL to the HTML
page you created in the previous step to verify that the map loads in
Autodesk MapGuide Viewer.
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Phase Two: Planning and Design

This is a critical phase, during which you determine how you need your
Autodesk MapGuide application to function, and design it accordingly.

To plan and design your application

1 Determine your performance needs, and whether you should install mul-
tiple servers.

2 Determine which data you will need for the map, including what types of
reports and Zoom Goto categories you will need.

3 Decide how to design the layers. Ask yourself the following questions:
m What name do you want to display in the legend for each layer?

m What name do you want to use for each legend for programmatic
access (that is, access through the Viewer API)?

m Should users be able to select features on this layer?

m Do you want to display more or less data depending on the current
scale? If so, create multiple layers of the same area that turn on and off
at particular display ranges.

m Will the data on this layer be used in any reports? If so, make a note to
add this layer to the Report tab when you set up your reports.

4 Design your Autodesk MapGuide application. This involves determining
the following:

m How will the user interact with Autodesk MapGuide Viewer and the
Web page? For example, will the user have to select features on the
map, or will you add a list box to the Web page that allows the user to
select a map feature from the list?

m Depending on which functionality you want to add to the Web page,
which Autodesk MapGuide functions do you need to use in order to
provide this functionality?

m Do you need to create other applications and scripts, such as CGI
scripts? For example, if you want to allow the user to digitize points on
the map and update the database with the new locations, you need to
write a script to handle this.
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Phase Three: Implementation

In Phase Three, you implement your Autodesk MapGuide application
according to the plan you developed in Phase Two.

To implement your application

1

If you will be installing additional servers, do so now, and test them as you
did in Phase One.

Create a skeleton of your application (without the MWF), creating place-
holders and pseudo-code for your features and functions.

If you are not using a data provider to access data directly, perform data
conversion, and then put the converted files in the necessary locations. If
you create any additional databases, go back to Phase One and create and
test OLE DB data sources for each database you add.

Create the report scripts or applications that Autodesk MapGuide will use
to generate reports.

Create the Zoom Goto data.

Build the map according to your plan. This includes creating the layers,
and then adding the reports and Zoom Goto categories to the Map
Window Properties dialog box.

Add the MWF to the application skeleton, then test all layers, reports,
Zoom Goto categories, and so on.

Build the placeholder functions and test them.
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Designing Your System

This chapter covers topics that you need to take into con- In this chapter

sideration before you set up your Autodesk MapGuide® B Planning your directory
structure

Server, author your map, or develop your Autodesk B Security

B Architecture and

MapGuide® Viewer application. Read this chapter to
performance

decide how you want to design your system, what type of B Choosing a Viewer/browser
environment
security you need, and what type of Viewer and browser

environment you want to support before you install or

configure any software.

This chapter may be especially helpful to:

m  Server administrators

m  Application developers
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Planning Your Directory Structure

The first step in designing your system is planning the structure of the files
and directories you will have on your server. For example, will you have all
of your files under one main directory, or will you split them into project
directories? Will you have all of your data in one directory, to be used by all
projects, or will you have a separate data directory for each project? Part of
planning your directory structure comes from your own understanding of
how many projects and how much data you have, and a major consideration
is setting up the structure so that your files are secure.

Note This chapter assumes you are familiar with Windows NT® Windows®
2000, and Web server administration. If you are not, look up “Windows NT,”
“Windows 2000,” and “Web servers” in the Autodesk MapGuide Help index.

Directory Structure Guidelines

You will need to create a directory structure for any of the file types you use
with Autodesk MapGuide. In some cases you will also have to create virtual
directories that map to physical directories. Your main security strategy is to
keep your data repositories hidden from the Internet. You do this by placing
spatial and attribute data away from the physical directories that are exposed
to your server’s HTTP processing.

Virtual directories provide a mapping between the Web server directory
structure and the physical directory structure in your file system. For
example, when you install Autodesk MapGuide Server, it creates the virtual
directory /MapGuide6/Sample_World/ on your local host, which maps to the
physical installation directory c:\Program Files\AutodeskMapGuideServer6
\Projects\Sample_World\web

The following illustration shows the physical installation directory:

{27 Program Files
=7 Autodesk
& MapGuideduthors
EH:I i apGuideServers
{:I Data Sources

El{:l Projects
El{:l Sample_world
& Database Sample project with
D R azter recommended directory
D SOF structure
-] Web
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This setup is designed for maximum portability and security as well as ease
of maintenance. By setting up your projects in this way, you can easily move
an entire project from one computer to another, as all of the necessary data
is under the project directory. You can also add additional directories and
subdirectories, as needed.

As shown in the illustration on page 48, when you map a virtual directory to
..\ Projects\Sample_World\web, your data directories (..\Database, ..\Raster,
and ..\SDF) are not exposed to the Internet. Clients can only access the
folders and files within the folder to which the virtual directory is mapped.
Using virtual directories enables you to keep the same URL, even if you
change file paths on your system. If you change file paths, just update the
virtual directory mapping. Virtual directories also enable you to grant
Execute permission to directories you create.

Use the following guidelines for setting up your directory structure.

Group files into projects with project directories

After you group files into projects with project directories, map virtual direc-
tories to the ..\<project name>\web directory. For example, if you create two
project folders on the file system of your Autodesk MapGuide Server,
..\Projects\projectl and ..\Projects\project2, map virtual directories to
..\Projects\project1\web and ..\Projects\project2\web but do not put your data
in directories below ..\web.

Place files under a virtual directory

Unlike raw data, you must place all HTML-related files, including MWFs,
under a virtual directory so they are directly accessible to the Internet. For
example:

..\Projects\project] \web\map1.html
(www.<your domain>.com/projectl/map1.html)

..\Projects\project2\web\map2.html
(www.<your domain>.com/project2/map2.html)

Place files in directories that have Execute permission

You need to place your report files and server-side scripts in directories that
have Web server Execute permission. If you are running Microsoft Internet
Information Server (IIS), and you want to assign Execute permissions to a
directory, you must create a virtual directory that maps to it, regardless of
whether that directory is under the Web root or not.
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For instructions on creating a virtual directory, refer to the documentation
that came with your Web server.

Strategically locate MapAgent files

You can locate your MapAgent files anywhere on the file system where they
can be executed by the Web server software. If you are running IIS, we recom-
mend you use the default directory, /MapGuide6/, which the Autodesk
MapGuide Server installation creates for your MapAgent files. This way you
do not need to create a virtual directory for these files. If you choose to place
your MapAgent files elsewhere, you must create a virtual directory that maps
to its physical counterpart and assign Execute permissions with your Web
server software.

Netscape Enterprise Server does not create a default directory. If you use the
NSAPI version of the MapAgent, you must enter a pointer in the Netscape
configuration file that points to the MapAgent_NSAPIL.dII file. Typically, the
MapAgent_NSAPL.dIl directory is:

C:/Program Files/Autodesk/MapGuideServer6/MapAgents

If you are going to use the CGI agent, you must create a CGI directory and
create a mapping to that directory in the Netscape Administrator.

Security

50

Security is an important consideration when setting up any kind of server
application. With Autodesk MapGuide, you can implement security for your
server computer at a number of different levels. There are three main
methods for setting up security:

m Use the Windows NT or Windows 2000 Administrator tools to set security
for files and directories on the server computer.

m Use your Web server to set security for virtual directories. Plan your direc-
tory structure so that files requiring security are not exposed to the Inter-
net, for instance, by physically creating these files hierarchically above
their virtual directories.

m Use Autodesk MapGuide to set up user IDs and passwords, access keys,
passkeys to protect resources (such as SDFs and databases), maps, and map
layers.
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Using Windows NT or Windows 2000 Security

We recommend that you review the security settings for all folders on your
server and adjust them appropriately, depending on the files they contain. If
your Autodesk MapGuide Server directories are on a drive that uses the file
allocation table (FAT) file system, you do not need to set Windows permis-
sions, because all users have access to all files and directories. If these direc-
tories are on a drive that uses a Windows NT File System (NTFS), you must
set the appropriate permissions on these directories for each account
intended to access these directories.

In addition to setting security for individual files and directories, you can also
set security for all directories controlled by your Web server. The next section
discusses this approach.

Using Web Server Security

When you create a Web publishing directory, you can set access permissions
for the defined home directory or virtual directory and all of the directories
below it. The World Wide Web (WWW) service provides the access permis-
sions, which are in addition to the permissions provided by the NTES file
system. Note that ColdFusion template files (.cfm files) interact with the Web
server in a similar manner to a CGI scripting process, so any directory
containing these files must also have Execute access.

The security considerations for your Autodesk MapGuide site are the same as
those for any other Web site that provides data. With that in mind, we
recommend that you create an organized directory structure with permis-
sions that appropriately protect the files on the Web site enabled by
Autodesk MapGuide.

In addition to the Windows NT/Windows 2000 and Web server security
methods just discussed, you can also use a variety of methods in Autodesk
MapGuide Server to set up security.

Using Autodesk MapGuide Security

Autodesk MapGuide Server and Autodesk MapGuide® Author provide you
with the following methods for keeping your data resources and maps secure:

m User IDs and passwords to control access to maps, map layers, and data
sources

m Access keys to control map layer access to data sources and map feature
coordinate values
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m Passkeys to control Viewer API access to layer setup data and map feature
coordinate values

You can use one or more of these methods depending on your security needs.

Controlling Access to Maps

In addition to controlling access to your maps using the standard security
features of your Web server, you can add password protection to your maps
using Autodesk MapGuide Author. Password protection prevents other
Autodesk MapGuide Author users from opening a proprietary Internet-
published map and accessing the information stored in the MWEF. You must
enter the correct password each time you open a password-protected map.

If you have a public site, another way to add security to your MWEs is to store
the MWFs on a server inside of your firewall and have the MapAgent and
HTML files on a server outside of the firewall. For more information, see
“Using a Remote MapAgent” on page 55 and “Firewalls” on page 73.

Controlling Map Layer Access to Data Sources

You can control access to data sources (resources) by assigning access keys to
them using Autodesk MapGuide Server Admin. An access key is a unique
string that can include a start and end date. To use a resource that has an
access key assigned to it, the map author embeds the access key in the layer
or Zoom Goto definition that will access that resource.

Each time a user attempts to access that map layer (such as by panning or
zooming) or Zoom Goto definition, the access key is automatically sent to
the server along with the request for the data. Autodesk MapGuide Server
verifies the key and its start/end dates (if any) against the list of access keys
assigned to that resource before providing the data. If the key is verified,
Autodesk MapGuide Server loads the layer’s data; otherwise, the program
displays a message indicating that access to the data is denied.

When assigning access keys to map layers, you need to coordinate with the
person administering Autodesk MapGuide Server to make sure that the
access key is properly assigned to the specific resource that provides data to
that map layer. For more information, see “Creating and Modifying Access
Keys” on page 84 and “Specifying Security for Layers” on page 173.
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Controlling User Access to Resources

You can control which users can access resources (SDFs, raster image files,
databases, and so on) by assigning user IDs and passwords to resources using
Autodesk MapGuide Server Admin. Whenever Autodesk MapGuide Viewer
or Autodesk MapGuide Author requests data from a resource, the user is
prompted to enter a user ID and password. Autodesk MapGuide Server then
verifies that this user ID and password has been assigned to the resource and
provides the data.

Additionally, you can assign users to the Authors user group using Autodesk
MapGuide Server Admin. When authors create maps, they can browse for
available resources only if they are assigned to the Authors user group. This
provides only a minimal level of security, because authors can still use a
resource by typing its path, but they cannot browse for available resources
without the recognized user ID and password that you specified in Autodesk
MapGuide Server Admin. For more information, see “Creating and Modi-
tying Users and Groups” on page 83.

Note Be sure to run Autodesk MapGuide Server and Autodesk MapGuide Server
Admin under the same account (the System account or a user account). Other-
wise, the resources you see in Autodesk MapGuide Server Admin might not be
the same resources that are available to Autodesk MapGuide Server. See “Config-
uring Autodesk MapGuide Server under a Different Account” on page 75 for
more information.

Accessing Data from the Autodesk MapGuide Viewer API

Map authors can control whether developers can access coordinate values
and map layer setup data using the API getVertices() and getLayerSetup()
methods. You control the security of this data from the Map Layer Properties
dialog box in Autodesk MapGuide Author. If you allow API access, you can
also specify that the application must send a specific passkey first, which the
application developer passes in with the unLock method. The developer can
then use the getVertices() and getLayerSetup() methods to access the coordi-
nate values and layer setup data. For more information, refer to the Autodesk
MapGuide Viewer API Help.

We do not recommend hard coding the passkey in your HTML application
script because users can always view the source code of an HTML page. One
option is to prompt users for their user IDs and passwords when they attempt
to view secured data and then authenticate the user ID and password against
a database on your server.
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Map authors can also control whether developers have access to the
tracking ID using the getTrackingID() and setTrackinglD() methods. You
control the security of this data from the Map Window Properties dialog box
in Autodesk MapGuide Author.

Architecture and Performance
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This section discusses the different server agents and distributed architec-
tures that you can implement for Autodesk MapGuide Server and how they
affect performance. On installation, Autodesk MapGuide Server selects a
MapAgent based on the Web server it detects. You can, however, go back to
the installation program and install a different MapAgent at any time.

Which MapAgent to Install

There are three types of Autodesk MapGuide Server agents (MapAgents) that
you can install:

m CGI—This MapAgent works on any type of Web server and is easy to
install. Therefore, if you are building a Web server for the first time, and
you are not distributing or mirroring your map data across multiple
servers, you might want to install the CGI MapAgent instead of the ISAPI
or NSAPI MapAgents to avoid complications. Note that the CGI
MapAgent is slower than the ISAPI and NSAPI MapAgents because it does
not run as part of the Web server.

m ISAPI—The ISAPI (Internet Server Application Programming Interface)
MapAgent is an ISAPI server extension that can be loaded by Microsoft
Internet Information Server (IIS). Because it runs as part of the Web server
process, it improves performance by eliminating the overhead of commu-
nicating between the Web server and a separate CGI executable. The ISAPI
MapAgent resides on the user’s computer, so it is faster than the CGI
agent. It is also fairly easy to install. However, you can install the ISAPI
agent only on IIS.

m NSAPI—The NSAPI (Netscape Server API) MapAgent is similar to the ISAPI
MapAgent, except it works on the Netscape Enterprise Server. Like ISAPI,
it is faster than a CGI MapAgent, and thus optimizes your server’s
performance.

For more information, see “Understanding Multiple Simultaneous Server
Requests” on page 56.
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Using a Remote MapAgent

The MapAgent uses Distributed Component Object Model (DCOM) built on
the Remote Procedure Calls (RPC) transport. Because DCOM calls can be
made across a network, the MapAgent does not need to reside on the same
computer as Autodesk MapGuide Server. This is useful for enhancing secu-
rity, because it allows you to publish maps from your public server while
keeping your data, Autodesk MapGuide Server, and the communication
between them secure on your private internal LAN.

For example, you could have your Web server, MapAgent, HTML files, and
supporting files for the HTML files (such as bitmaps that appear in the Web
page, not within the map) all on a public server outside of the firewall or
other Internet security mechanism you are using. Inside the firewall, you
would have Autodesk MapGuide Server and your resources (databases, SDFs,
and raster images that appear within the map). With this setup, not only is
all of your data behind the firewall, but all communication between
Autodesk MapGuide Server and your data takes place behind the firewall.
This approach enables anyone to use your maps, but minimizes the possi-
bility of hackers accessing your data files or taking advantage of the commu-
nication between Autodesk MapGuide Server, and your databases. You can
specify exactly which ports you want DCOM to use for communication
between Autodesk MapGuide Server and the MapAgent. The data passed
between them is only useful for display in Autodesk MapGuide Viewer. For
more information, see “Data File Placement” on page 61.

To use a remote MapAgent, you need to make sure the MapAgent can
communicate with your Autodesk MapGuide Server through the firewall. For
more information, see “Setting Up the MapAgent” on page 71.

Standardizing on UDP or TCP

Different versions of Windows use either UDP ports or TCP ports for DCOM
communication by default. When you use the MapAgent on a different
computer from the Autodesk MapGuide Server, be sure that the computers
are using compatible operating systems. Otherwise, if the MapAgent
computer attempts to communicate with the Autodesk MapGuide Server
computer using a different protocol, there will be a 30-45 second delay. At
the end of the delay, an attempt will be made to connect with the alternate
protocol. This delay will occur unless the last working protocol type (UDP or
TCP) is cached by the operating system on the MapAgent computer.
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Using Multiple Servers

Autodesk MapGuide Server is scalable, meaning that it has mechanisms built
in to take advantage of multiple servers, which improves performance.
Autodesk MapGuide Server can process multiple requests simultaneously,
balance the load of requests across the available servers, and use data that is
distributed across different servers. This section discusses how Autodesk
MapGuide Server takes advantage of multiple servers and helps you deter-
mine which is the best strategy for you.

Understanding Multiple Simultaneous Server Requests

Autodesk MapGuide Server is a multi-threaded application, meaning that it
can process multiple requests for data in parallel, as opposed to serially
processing each request one after another.

MapGuide clients can send multiple simultaneous requests to several
MapAgents at once and simultaneously receive the responses from those
requests. This means that instead of using one server to process a large
request, or sending smaller requests one at a time, multiple servers can
process all smaller requests at the same time. You do this by setting up your
map layers to use data from different Autodesk MapGuide Servers. Autodesk
MapGuide Viewer will then send off requests for data for all of those layers
in parallel, where they are all processed at the same time. Therefore, if you
have three servers, processing time could be up to three times faster than
using one server.

For example, in the following illustration, there are requests coming from
layers 1 through 6. In this example, layers 1 and 3 make the requests to server
A, layers 2 and 4 send the requests to server B, and layers 5 and 6 send the
requests to server C. All the requests to these servers go out at the same time,
so the servers process the requests simultaneously. Each server then sends its
processed data back to the Autodesk MapGuide Viewer. The Autodesk
MapGuide Viewer always draws layer 1 first, and then draws all of the other
layers simultaneously once it has received all of the data.
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Simultaneous request model
MapAgents and Server Ranking

When the ISAPI, NSAPI, or CGI MapAgents receive a request from a
MapGuide client, they rank the available servers and select one to which they
dispatch the request. If the chosen server is offline or invalid, the MapAgent
tries the next server in the rank.

CGI MapAgent

Each Autodesk MapGuide client request invokes a separate instance of the
CGI MapAgent that lasts only the duration of the request. Because of this, the
CGI MapAgent cannot track the number of requests dispatched to each
server. It randomly selects an available server for each request and then ranks
all other servers based on their proximity to this server in the list that appears
in the Window'’s registry. The CGI MapAgent distributes requests evenly
among all available servers regardless of their current workload.

Architecture and Performance | 57



58

NSAPI and ISAPI MapAgent

Once loaded by the Web server, the ISAPI or NSAPI MapAgents remain in
memory until the Web server service is shut down. Since they persist
between requests, they are able to use a more sophisticated system of load
balancing by ranking all servers into one of the following groups:

m Available—This server is online and ready to process requests. From this
group, the MapAgent will dispatch the client request to the server that is
currently processing the fewest requests.

m Offline—This server has been taken offline and will not be polled again
until the MapAgent receives 50 more client requests.

m Invalid/Unavailable—This machine is physically shut off or discon-
nected from the network and will not be polled again until the MapAgent
receives 100 more client requests.

Distributed Data vs. Mirrored Systems

There are two approaches to using multiple servers: distributed data and
mirrored systems. In the distributed data model, the servers contain different
resource files so that the map data is distributed across the servers. In the
mirrored model, you have multiple servers with identical setups and data
so that the additional servers act as backups if the first server is busy or
unavailable.

The distributed data model requires less maintenance than the mirrored
systems model. However, this approach is not fault tolerant—if one Autodesk
MapGuide Server goes down, Autodesk MapGuide Viewers cannot access the
data on that server. The mirrored systems model is safer than the distributed
data model because it does have fault tolerance, which provides a backup
server so that the data is still available. However, mirrored systems can
require more maintenance than distributed data systems if you need to
update the servers.

The following diagrams illustrate the two different multiple server architec-
tures.
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In the first diagram, notice that there are three Web server computers, each
with its own Autodesk MapGuide Server. Each contains different data. In this
case, requests are distributed among the servers based solely on which data is
requested; if repeated requests are made for the same data, only the server
containing that data will process the requests. To make this model work, you
must plan the placement of your data carefully so that requests are distrib-
uted equally among the servers.

|| raster data

—"
...more ...still more
spatial data... spatial data

Attribute Data

Example of distributed data
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In the next diagram, a Web server has a MapAgent that points to several
Autodesk MapGuide Servers, each of which has exactly the same data as the
others. In this case, requests made to this server will be distributed among the
Autodesk MapGuide Servers based on their availability, so if one of the
Autodesk MapGuide Servers is busy processing another request, the request
will go to the next server.

Map
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MapGuide
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MapGuide
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spatial
data

spatial
data

attribute
data
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Example of mirrored data

For maximum benefit, you can use a combination of the two approaches. For
example, in the mirrored data illustration, Web Server 2 might be one of
several Web servers that is used only when requests are made for its particular
data. However, when requests are made to Web Server 2, all requests it
receives are distributed for processing among three Autodesk MapGuide
Servers, each of which contains exactly the same data. Thus, in this example
using a combination of methods, several Web servers use the distributed data
model, and one of the distributed Web servers also uses the mirrored data
model to handle its individual requests.

Setting Up Multiple Servers

If you choose to have multiple Autodesk MapGuide Servers on your network,
you must configure their TCP/IP settings to operate correctly through your
Internet connection configuration. Also, to maximize performance, be sure
to set up your MapAgent for load balancing between the servers.
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Data File Placement

When using remote and/or multiple servers, it is important to know where
to store your data so that the server(s) can access it. The following table
describes whether each type of data needs to be available to the Autodesk
MapGuide Server(s) or the Web server. Note that the MapAgent does not
need access to data files, as it simply relays whatever data is sent to it from
the Autodesk MapGuide Server.

This type of Must be available = Comments

data... to...

Map source data All Autodesk The Autodesk MapGuide Server(s) pro-
(SDFs, data MapGuide Server cesses the data, then sends it to the
accessed using a installations MapAgent to be relayed to Autodesk
data provider, MapGuide Author or Viewer.

raster images,

OLE DB data

sources)

Raster images in Web server The Web server processes these files
Web page (out- because they are outside of the map.
side of map) Therefore, the Autodesk MapGuide

Server(s) does not need access to them.

MWFs, MWXs, Web server The Web server processes these files;
and MLFs the Autodesk MapGuide Server(s) does
not need access to them.

Additional Performance Considerations

In addition to using multiple servers, there are several ways in which you can
improve performance. Keep the following tips in mind when setting up your
site, authoring your maps, and preparing your data.

Site Configuration

m Bandwidth is a critical factor. This includes internal and external band-
width, as well as network traffic (particularly at peak hours on the
Internet).

m Your hardware has many factors that affect performance, including
processor speed, memory, and disk space.
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Map Authoring

m Show only the layers that users really need. You can make the layers avail-
able but not visible when the user first displays the map, reducing the
amount of data that needs to be processed when the map is first loaded.

m Create static layers for small, frequently accessed data that does not need
to be kept secure. Static layers are loaded only once, and zooming in and
out on the layer does not send requests to the server. For larger data sets,
data that changes frequently, and data that needs to be kept secure, use
dynamic layers instead.

m Use the Display Ranges option and pyramid the data. This involves creat-
ing multiple layers that show the same data but at different resolutions.
You might have one layer that displays very detailed data and appears
only when the user is zoomed in close, a second layer that displays less
detail and appears only when the user is zoomed out farther, and a third
layer that shows very generalized data and displays only when the user is
zoomed out quite far.

Data Preparation

m For point and text layers, rather than creating an SDF for the points and
linking it to a SQL table for the attribute data, consider storing the points
in the SQL table as well and using that table as the source for the layer.
Whenever you link an SDF to a SQL table, it takes longer to process than
alayer based on just an SDF or a SQL table. This is not true of themes, how-
ever. When setting up a theme, it doesn’t matter whether the data source
and theme source are the same SQL table, or the data source is an SDF and
the theme source is a SQL table—performance will be the same in both
cases.

m If there are multiple theme categories for a layer, consider using separate
layers that reference separate SDFs. If possible, you could also export the
information in a SQL table to a comma-separated (CSV) file and import it
into its own SDF, rather than including it as a theme category of a layer
based on another SDFE.

m Generalize data as much as possible. This involves reducing the resolution
of the data so that there is less data to process. You can generalize SDFs
using SDF Loader or SDF Component Toolkit; you can subsample raster
images using Raster Workshop. Note that generalization reduces the
amount of detail you will see when you zoom in, so you might want to
create multiple layers of the same area using different resolutions for dif-
ferent display ranges. Also, data with complex shapes, such as parcel data,
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might not generalize well, because their boundaries might not line up
properly afterwards.

Trim feature names if they are not used. You can use the /NULLNAME
switch in SDF Loader to do this. Also, use the /LINK switch to specify the
URL column(s) only if you plan to use the URLs.

For raster images, use Raster Workshop to create uncompressed,
subsampled, tiled TIFF files.

Choosing a Viewer/Browser Environment

As you plan your Autodesk MapGuide application, there are four major
components you need to consider:

Operating system—Will your users be running Windows, Mac OS, or
Solaris to view maps?

Web browser—Will your users be running Netscape Navigator or
Microsoft Internet Explorer? Or do you want to create a stand-alone appli-
cation to run the Viewer, so that a browser is not necessary?

Autodesk MapGuide Viewer/LiteView—Depending on which operating
system and browser your users have, they will use the Autodesk MapGuide
Viewer ActiveX Control, Autodesk MapGuide Viewer Plug-In, or Autodesk
MapGuide Viewer, Java"" Edition. If all of your users are running the same
operating system and browser (such as on a corporate intranet), you can
develop your application for one version of Autodesk MapGuide Viewer.
However, if your users all have different setups and thus use all versions of
the Autodesk MapGuide Viewer, you will need to develop your applica-
tion to handle all three. If you do not need the full interactivity of
Autodesk MapGuide Viewer and you need complete cross-platform sup-
port, you can consider using LiteView to deliver raster-based maps with
limited interactivity.

Scripting language—Which language will you use to develop your appli-
cation? Each version of Autodesk MapGuide Viewer is accessible from one
or more specific languages.
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The following table is designed to help you consider each of these factors:

Components for Choosing a Viewer/Browser Environment

Operating Browser Viewer Language
System
Windows Internet Explorer Autodesk HTML, VBScript,
MapGuide Viewer Jscript, JavaScript
ActiveX Control
Internet Explorer Autodesk HTML, JScript,
MapGuide Viewer,  JavaScript, Java
Java Edition
Netscape Autodesk HTML, JavaScript
Navigator MapGuide Viewer
Plug-In
Netscape Autodesk HTML, JavaScript,
Navigator MapGuide Viewer,  Java
Java Edition
Any browser that LiteView ColdFusion (CF),
supports PNG file Active Server Pages
format (ASP), Java Server
Pages (JSP), or Perl
none Autodesk Visual Basic
(stand-alone MapGuide Viewer
application) ActiveX Control
Mac OS Internet Explorer Autodesk HTML, Java
MapGuide Viewer,
Java Edition
Any browser that LiteView ColdFusion (CF),
supports PNG file Active Server Pages
format (ASP), Java Server
Pages (JSP), or Perl
none Autodesk Java
(stand-alone MapGuide Viewer,
application) Java Edition
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Components for Choosing a Viewer/Browser Environment (continued)

Operating Browser Viewer Language
System
Solaris Netscape Autodesk HTML, JavaScript,
Navigator MapGuide Viewer,  Java
Java Edition
Any browser that LiteView ColdFusion (CF),
supports PNG file Active Server Pages
format (ASP), Java Server

Pages (JSP), or Perl

none Autodesk Java
(stand-alone MapGuide Viewer,
application) Java Edition

Autodesk MapGuide Viewer ActiveX Control for Internet Explorer

The Autodesk MapGuide Viewer ActiveX Control exposes an API that is
accessible from VBScript, JScript (Microsoft’s implementation of JavaScript),
and Java. The ActiveX Control API is exposed through ActiveX/COM/Auto-
mation technology. If you develop an application only for the ActiveX
Control version of the Viewer, users can access that application with Internet
Explorer only; if someone tries to view your application with Netscape, it will
fail. You can also write stand-alone applications for the ActiveX Control with
Visual Basic or C++. In this case, no browser is required, as your stand-alone
application takes the place of a browser. For platform information, see
“Autodesk MapGuide ActiveX Control Viewer Requirements” on page 17.

Autodesk MapGuide Viewer Plug-In for Netscape

The Autodesk MapGuide Viewer Plug-In exposes an API that is accessible
from JavaScript and Java. The Plug-In API objects are exposed via Netscape
LiveConnect technology.

If you develop an application only for the Plug-In version of the Viewer, users
can access that application with Netscape only; if someone tries to view your
application with Internet Explorer, it will fail. For platform information, see
“Autodesk MapGuide Plug-In Viewer Requirements” on page 17.
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Autodesk MapGuide Viewer, Java Edition

The Autodesk MapGuide Viewer Java Edition works with certain combina-
tions of both browsers on Windows, Mac OS, and Solaris (see previous table).
It is accessible from JScript, JavaScript, and Java. Internet Explorer exposes
the Java Edition API through a combination of the Java bean and
ActiveX/COM/Automation technology. Netscape Communicator exposes
the Java Edition API through a combination of Java introspection and Live-
Connect technology. The API classes are defined in the com.autodesk.mgjava
package, which is typically contained in the mgjava.jar tile. All configurations
expose the Java Edition API to other Java code if it has been compiled to
directly instantiate MGMapApplet or MGMapComponent. For platform infor-
mation, see “Autodesk MapGuide Viewer, Java Edition Requirements” on
page 17. For implementation information, see the Autodesk MapGuide Devel-
oper’s Guide and the Autodesk MapGuide Viewer API Help.

LiteView

LiteView is a Java program that runs on the server side (as a servlet). It
converts an MWEF file into a PNG image and returns it as an HTTP response
to a request. It extends the capabilities of Autodesk MapGuide to quickly
display maps as raster images in Netscape Navigator, Internet Explorer, or
any other browser that supports the PNG image format. Application users do
not have to download a plug-in to display the maps.

Third-party integrators can create a custom LiteView viewer, using the
sample application provided with the servlet as an example. For more infor-
mation, refer to the LiteView Developer’s Guide.

Chapter 3 Designing Your System



Assembling and Administering
Your Server

This chapter includes information about setting up and
administering your server. Before you begin, please read
Chapter 3, “Designing Your System,” to help you decide

how to set up your server security and architecture.

This chapter may be especially helpful to:

m  Server administrators

m  Application developers

M

[

In this chapter

Setting up your servers

Autodesk MapGuide Server
Admin overview

Starting and stopping the
server

Setting general server
properties

Setting up your data sources
Managing server security
Tracking server requests

Adding geocoding data
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To enable your computer to serve maps over the Web, you must install and
configure Autodesk MapGuide® Server and your Web server software.

Before You Install Autodesk MapGuide Server

Before installing Autodesk MapGuide Server, be sure to do the following:

Log On with Administrative Rights

Before you install Autodesk MapGuide Server, log on to Windows as an
administrator or as a user who has administrative privileges.

Verify Your System Requirements

Be sure that your system meets the criteria listed in “Autodesk MapGuide
Server Requirements” on page 16.

The Autodesk MapGuide Server installation program requires that you have
Microsoft® Windows® Installer (MSI) on your computer. MSI is included
with Microsoft Windows 2000. If you do not have MSI on your computer,
the Autodesk MapGuide Server installation program will install the MSI soft-
ware for you. You will then need to restart your computer and manually
restart the Autodesk MapGuide Server installation.

Warning If Autodesk Mapguide Server Release 5 is installed on your machine,

you must ensure that you have also installed patch release 5.0.8.x. before you can
install Autodesk MapGuide Server Release 6. You can download this patch from
the Autodesk product support Web site. If you did not install the 5.0.8.x patch

release, you must uninstall Autodesk Mapguide Server Release 5 before installing
Autodesk MapGuide Server Release 6.

Chapter 4 Assembling and Administering Your Server



Remove Autodesk MapGuide Server 4.1 for VISION*

If you have Autodesk MapGuide Server for VISION* installed on your
computer, follow these steps before installing Autodesk MapGuide Server.

1 Use Autodesk MapGuide Server Admin to stop Autodesk MapGuide Server
Service.

2 Close Autodesk MapGuide Server Admin.

3 Using the Add/Remove Programs Control Panel, uninstall Autodesk
MapGuide Server for VISION*.

Install Your Web Server Software

Install and configure the Web server software, as described in “Installing
Microsoft Internet Information Server” on page 70 and “Installing Netscape
Web Server” on page 70.

During the Autodesk MapGuide Server installation, you will be asked to
select one or more MapAgents to install (see “Which MapAgent to Install” on
page 54). If, during the installation, you select a MapAgent for which you
have not yet installed a Web server, you will need to perform the following
steps after you finish installing Autodesk MapGuide Server:

1 Copy each MapAgent listed in the MapAgents Not Supported screen of the
Autodesk MapGuide Server installation from the <installation directory>
\MapAgent directory to a virtual directory for the Web server.

2 Enable Scripting and Execute permissions for the virtual directory.

3 If using a server other than Microsoft Internet Information Server or
Netscape Enterprise Web Server, you must manually configure the follow-
ing MIME types after Autodesk MapGuide Server Service is installed:

File Type MIME Type File Extension
Map Data File application/x-mdf .mdf

Map Window File application/x-mwf .mwf

Map Layer File application.x-mlf .mif

Map Window XML File application/x-mwx .mwx
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Note that you may need to omit the period (.) that precedes the file exten-
sion. For more information about manually configuring MIME types, refer
to your Web server documentation.

Installing Microsoft Internet Information Server

If you plan to run Microsoft Internet Information Server (IIS) on Windows
NT, you need to install the Windows NT Option Pack 4.0. This is not neces-
sary with Windows 2000 because IIS is included with Windows 2000.

To install the Option Pack

1 Install Microsoft Internet Explorer 5.0.

2 Install Option Pack 4.0. When you install the Option Pack, select the
Upgrade Plus option and be sure to select Internet Information Service as
a component to install.

Installing Netscape Web Server

Before installing a Netscape Web server, you must first have the following:
m A system that meets the criteria listed in “Autodesk MapGuide Server
Requirements” on page 16.

m Netscape Navigator installed on your machine. Either install Netscape
Navigator from the Netscape Developer’s CD or download it from:
http://www.netscape.com

m An entry in a DNS server. Make sure that the administrator of the DNS
server in your network enters the computer on which you are installing
Autodesk MapGuide Server into the domain.

m A user account set up on the computer.

After you have met all of these criteria, you are ready to install the Netscape
Enterprise Server software from the Netscape CD.

To install Netscape Enterprise Server
1 Insert the Netscape CD, and then follow the instructions on the screen to
start the installation.

2 The installation program prompts you to specify whether or not you want
to use Lightweight Directory Access Protocol (LDAP). Because you do not
need LDAP, leave the box unchecked and go on to the next dialog box.

3 When prompted for user information, enter the name and password of
the user you created in the User Manager.
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4 The installer generates numbers for the administrator and Web server
ports. Accept these defaults and write them down for future use.

5 Optionally, specify the default home directory for your Web documents
instead of using the default content directory.

You should now be able to access the index.html file. If you cannot, refer
to the Netscape Server documentation for troubleshooting tips.

Testing Your Web Server

You can test your Web server by locally by opening a Web browser and
typing the reserved loop-back address; for example, http://127.0.0.1 or
http://localhost. If you have problems, refer to your Web server documenta-
tion for troubleshooting tips.

Setting Up the MapAgent

Typically, to set up the MapAgent, you first decide which MapAgent you
want to use (see “Which MapAgent to Install” on page 54) and then select
that MapAgent during the Autodesk MapGuide Server installation process.
However, if you want to use the MapAgent on a different computer from
Autodesk MapGuide Server, or if you want to take advantage of load
balancing for multiple servers, read the following sections for configuration
information.

Setting Up a Remote MapAgent

The MapAgent uses a Distributed Component Object Model (DCOM) to
forward client requests for map data to the Autodesk MapGuide Server.
DCOM is built upon the Remote Procedure Calls (RPC) transport. Because
DCOM calls can be made across a network, the MapAgent does not need to
reside on the same computer as Autodesk MapGuide Server.

To configure the MapAgent to use a remote server
1 Run the Autodesk MapGuide Server Setup program on the machine where
you want to install the MapAgent.

2 In the Select Components panel, deselect the Server Service item, and
verify that the correct MapAgent is selected.

You will be prompted to enter the IP address for the Autodesk MapGuide
Server machine. When the installation is complete, the MapAgent is ready
to route requests to the remote Autodesk MapGuide Server.
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If necessary, you can move the MapAgent executable file to a different CGI
script directory after you finish the installation. You can also change the
remote Autodesk MapGuide Server’s IP address by manually editing the
REG_MULTI_SZ registry, as described in the following procedure.

Warning Whenever you edit your registry, be sure to use great caution. We
recommend that you make a backup of your registry before you proceed.

To edit a remote server’s IP address

1 Runthe Windows NT REGEDT32.EXE tool. You can do this by clicking the
Start button, choosing Run, and then entering REGEDT32 in the Open
box.

We do not advise that you use the Windows NT tool REGEDIT.EXE,
because currently it does not have a friendly interface for editing registry
values.

2 In the Registry Editor, navigate to the key HKEY_LOCAL_MACHINE\
SOFTWARENAutodesk\MapGuide Server Agent\6.0, and then double-click
the Mapserver_IP value.

3 By default, the value is blank, which directs the MapAgent to the local
computer. To direct the MapAgent to Autodesk MapGuide Server on a
remote computer, enter that computer’s IP address. If your Autodesk
MapGuide Server IP address is assigned via DHCP, the IP will vary over
time; in this case, enter the DNS host name of the Autodesk MapGuide
Server instead of the IP address.

While you are editing the value for this key, you can also set up Autodesk
MapGuide to take advantage of load balancing.

Configuring for Load Balancing

You can specify multiple Autodesk MapGuide Servers by entering each IP, or
DNS host name, on a separate line in the REG_SZ value Mapserver_IP. The
MapAgent will balance the processing requirements by distributing the map
requests among the Autodesk MapGuide Servers specified in this value. Note
that when you add IP addresses or DNS host names to this value, the local
computer is no longer included by default, so you must also enter the IP or
DNS host name of the local computer if you want the MapAgent to continue
to use it along with the other servers specified.
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When installed, the MapAgent reads the MapServer_IP value from the
registry and gets all the MapGuide Server IPs that can handle requests. The
ISAPI and NSAPI MapAgents keep track of the number of requests each
Autodesk MapGuide Server is currently handling. The CGI MapAgent cannot
keep track of the number of requests each Autodesk MapGuide Server is
handling. When a new request comes in, the ISAPI and NSAPI MapAgents
assigns the new request to the Autodesk MapGuide Server that is currently
handling the fewest requests.

If you are using the ISAPI or NSAPI version of the MapAgent, the requests are
distributed to the servers in a rotating manner. If you are using the CGI
version of the MapAgent, it has no persistent memory between requests, so
it distributes the requests randomly among the servers. For more informa-
tion, see “Understanding Multiple Simultaneous Server Requests” on

page 56.

You may also want to consider purchasing a third-party load-balancing
solution such as Microsoft Windows NT Load Balancing Service (WLBS), the
F5 Networks 3DNS Controller, or the RADWARE Web Server Director (WSD)
products.

Firewalls

When you use a remote MapAgent, you need to configure your firewall to
permit DCOM penetration from the outside to the inside. First, you must
limit the DCOM port range on the Autodesk MapGuide Server computer. By
default, a DCOM server uses port 135 for handshaking and uses any port in
the range of 1,024 through 65,535 to service the DCOM call. To limit the
range of DCOM, you must use REGEDT32.EXE.

Add the following three values to the key HKEY_LOCAL_MACHINE\
SOFTWARE\Microsoft\Rpc\Internet (the Internet key does not exist by default,
so you might need to create it):

Autodesk MapGuide Server RPC Values

Value Name Data Type Text
PortsinternetAvailable REG_SZ Y
UselnternetPorts REG_SZ Y

Ports REG_MULTI 6600-6610
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The value in “Ports” specifies the valid range of ports on the server for use by
RPC. (The value “6600-6610” is simply an example.) You can specify
multiple ranges for availability by entering each range on a separate line. You
will need to restart Windows for the changes to take effect.

After you have specified which ports are available for use by RPC (port 135
and the ports you specified in the “Ports” value), you must configure your
firewall to allow the MapAgent computer to establish a connection with the
Autodesk MapGuide Server computer on these ports.

The following diagram provides a basic overview of how the MapAgent and
Autodesk MapGuide Server communicate over the firewall.

Web Server
Firewall and MapAgent
RPC Handshake Requesting RPC Handshake Requesting
RPC Working Port RPC Working Port
Random
Port #
Between
RPC Handshake Reply RPC Handshake Reply 1K & 64K
Specifies Server Working Port # Specifies Server Working Port #
RPC Function Call Requesting RPC Function Call Requesting
Map Data Map Data Random
Port #
Between
] 1K & 64K
RPC Function Return Map RPC Function Return Map
Data to Send to MG Client Data to Send to MG Client

RPC communication over a firewall

Help Index

data source properties

For information about the configuration of your particular firewall, please
consult the firewall’s documentation or your network administrator.

Warning This section does not address any security concerns regarding the con-
figuration of your firewall. As with all changes to your firewall’s configuration,
your network administrator should assess the risks that a change may bring.

If you set up more than one MapAgent (see “Using Multiple Servers” on
page 56), be sure to specify the correct MapAgent when you set up the map
layers. You do this on the Data Sources tab of the Map Layer Properties dialog
box in Autodesk MapGuide Author.
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Installing a Report Engine

If you will include reports in your maps, you need to install a reporting
engine, such as ColdFusion or Active Server Pages. You can install ColdFu-
sion Application Server from the Autodesk MapGuide CD. If your Web server
is on the computer where developers are going to work, install ColdFusion
Studio there as well. For details about installing ColdFusion, refer to the
ColdFusion documentation.

Configuring Autodesk MapGuide Server under a
Different Account

Autodesk MapGuide Server Service runs under the default System account.
However, if you have data sources on another computer that you want to
serve from Autodesk MapGuide Server, you need to run them under a user
account that has access to that computer. Follow these steps after installing
Autodesk MapGuide Server.

To change the account for Autodesk MapGuide Server Service

1 Do one of the following:
m In Windows NT, choose Start » Settings » Control Panel, and double-
click the Services icon.
m In Windows 2000, choose Start » Settings » Control Panel » Admin-
istrative Services.
2 In the Services dialog box, select Autodesk MapGuide Server Service, and
click Startup.
3 Inthe Log On As area, select This Account, and then specify a user account
and password that has access to the data sources on the remote computer.

4 Click OK, and then close the Services window.

Autodesk MapGuide Server Admin Overview

You use Autodesk MapGuide Server Admin to do the following tasks:

Start and stop the server

Set general server properties

Set up and manage data sources

Manage server security

Track server requests and generate log files
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To start Autodesk MapGuide Server Admin

m From the Windows Start menu, choose Programs » Autodesk MapGuide
Release 6 » Autodesk MapGuide Server Admin.

The Autodesk MapGuide Server Admin window is displayed.

Click to set = Idle - Autodesk MapGuide Server Admin Release 6 [_ (O] %] I
File Edit Service “iew FReportz Help

properties for Click for Autodesk

|
the server. el 2l MapGuide Help.
B
Click to start
the server.
Click to stop
the server.

[

] B

v

The complete, step-by-step procedures for using Autodesk MapGuide Server
Admin are included in the online Help. Choose Help » Contents, then refer
to the topics listed under “Administering Your Autodesk MapGuide Server.”

Starting and Stopping the Server

Help Index You can start and stop the server using Autodesk MapGuide Server Admin.
server Starting the server brings it online so that it is ready to accept and process
starting and stopping requests. Stopping the server takes it offline so that it cannot accept or

process requests.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “server, starting and stopping.”
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Setting General Server Properties

Help Index On the General tab in the Autodesk MapGuide Server Admin Properties
server dialog box, you can specify the following properties for Autodesk MapGuide
general properties Server:

Server administrators e-mail address

Maximum number of simultaneous requests to the server
Maximum number of DWG file connections to cache

Search path for raster image files

Autodesk® GIS Design Server configuration data source

Services that must start before starting Autodesk MapGuide Server

To open the Properties dialog box

m In Autodesk MapGuide Server Admin, choose Edit » Properties.
The Properties dialog box is displayed.

Properties [ %]

General | Data Sourcesl Loggingl Users.-"GroupsI Hesourcesl Access Ke_l,lsl

Adminigtrator e-mail address: ||

Mawirnurn number of simultaneous requests: |4 ﬁ

M aximum number of cached DWG file -
cohnections: |5 j

Baster image file search path:
ID:\Program Filez\Autodesk M apGuideS erverBhProjects\S ample_\wWorld\Raster

Autodesk GIS Design Server configuration data source:

I Browse... |

Start theze services before starting Autodesk MapGuide Server:
|RPCSS

Click for details
about the

options in this
QK I Cancel | Lpply | Help —|——dFa|og box.

You use the six tabs in this dialog box to specify all of the properties for
Autodesk MapGuide Server. This chapter includes basic information
about each tab. You can find complete, step-by-step procedures in the
online Help.
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Setting Up Your Data Sources

78

You can set up and manage your data sources using Autodesk MapGuide
Server Admin. See “Managing Your Data Sources” on page 79 for more infor-
mation, and read this and the next section for an overview of data sources
and data providers.

Autodesk MapGuide Server needs access to the data sources containing the
spatial and attribute data for your maps. To communicate with these data
sources, Autodesk MapGuide Server uses data providers that provide commu-
nication between Autodesk MapGuide and your data source. Direct access to
the native data sources eliminates the need to convert your data before using
it with Autodesk MapGuide.

Autodesk MapGuide Server can access attribute data from an Autodesk DWG
data source or any standard OLE DB data provider, including Microsoft
Access, SQL Server, Oracle®, or any ODBC data source (using the Microsoft
OLE DB Provider for ODBC Drivers).

Spatial Data Providers (SDPs) are similar to OLE DB Providers but with
extended functionality that enables Autodesk MapGuide Server to access
data stored in a data source in binary format, such as polygons and polylines,
in an Autodesk SDF data source. Spatial data providers include Autodesk
MapGuide SDF, SHP, and Oracle Spatial.

Autodesk MapGuide Server connects to data sources using plain text files that
describe how to connect to a given data source. For OLE DB data sources,
Autodesk Mapguide Server uses a Microsoft Data Link file with a .udl file
extension. Autodesk MapGuide Server connects to Autodesk DWG data
sources using an Autodesk Data Link (.adl) file.

Chapter 4 Assembling and Administering Your Server



Help Index

data sources
managing

Data Providers

Support for SDF and Autodesk DWG data sources is included with Autodesk
MapGuide Server. You can purchase the following data providers for other
types of data sources:

m Autodesk GIS Design Server Extension
m Autodesk MapGuide Provider for Oracle Spatial
m Autodesk MapGuide Provider for SHP

The following OLE DB providers are installed with MDAC 2.5 or later:

m Microsoft OLE DB Provider for SQL Server
m Microsoft OLE DB Provider for Oracle

m Microsoft Jet 4 OLE DB Provider

m Microsoft OLE DB Provider for ODBC

MDAC 2.5 is included on the Autodesk MapGuide product CD in the
following location: \MDAC2.5\MDAC_TYP.EXE

Tip If a native OLE DB provider is not available for your data source (for example,
if you are using Lotus Notes), you can use the Microsoft OLE DB Provider for
ODBC Drivers.

Managing Your Data Sources

Using Autodesk MapGuide Server Admin, you can view a list of your data
sources, make data sources available or unavailable, create new data sources,
rename existing data sources, delete data sources, and specify where
Autodesk MapGuide Server looks for data sources. Autodesk MapGuide
Server Admin also links to the Microsoft Data Link Properties dialog box
where you can configure your data sources.
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You use the Data Sources tab of the Properties dialog box to manage your
data sources.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “data sources, managing.”

General Data Sources | Loggingl Users.-"GroupsI Hesourcesl Access Ke_l,lsl

D ata sources:
Mame | Available | Mew... |
Froperties...
SDF 4'

Fename... |
Delete |

Data source search path:
[:\Program Files\Autodesk\MapGuideServerBhDaata Sources

Click for details

|—|DK e— | Apply Help _|__ about the options

in this dialog box.

Managing Server Security

In addition to setting Windows permissions and using the access control
tools provided with your Web server to control access to individual maps
(MWF files) at your site, you can add another level of security by using
Autodesk MapGuide Server to control access to the resources (SDFs, DWG
files, raster image files, SQL data tables, and Zoom Goto Address definitions)
used by these published maps. This means that you can set up Autodesk
MapGuide Server to require additional authorization before providing
resources requested by a map, even if a user has access to the map. You can
do this in two ways:

m Use access keys to provide time-sensitive, map-embedded, passive,
transaction-based security.

m Use user-group/password security to provide map-independent, active,
session-based security.
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Access Keys Versus User IDs and Passwords

Access keys are passwords that the author of a map embeds in the definition
of the map layer. Each time the map layer requests map data, Autodesk
MapGuide Server verifies the embedded access key against the list of valid
access keys for the resource before fulfilling the request. Because this process
takes place automatically and invisibly every time the map layer requests
data, access keys are a convenient way to provide greater resource security
with no impact on the user. Additionally, access keys can be preset to be valid
for only a certain period of time, adding an additional level of control.

User passwords require the user to enter a valid user name and password at
the first request of map data from Autodesk MapGuide Server. Like the
typical Web server security model, the user name and password are required
only once for each layer that uses the restricted resource, providing a high
level of security without unnecessary impact on the user.

Together, access keys and user passwords provide a great deal of flexibility
in solving security problems over a variety of Internet/intranet implementa-
tions.

The following table provides a summary of the differences between the two
security methods:

Users/Groups/Passwords Access Keys

Time Period Active until deleted. Preset time periods.

End-User
Interaction

User must enter correct name No end-user interaction.

and password.

Implementa- Use Autodesk MapGuide Server
tion Admin to enter and maintain
users, groups, and passwords.

Use Autodesk MapGuide
Author to enter access keys in
MWFs; use Autodesk
MapGuide Server Admin to
link access keys to resources
at the server level.

Authorization
Frequency

Checked once per resource per
layer request (until the user
exits the current browser
session).

Checked by Autodesk
MapGuide Server for every
layer request.
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Choosing the Best Security Method

The following table offers recommendations about when each security

method is most appropriate:

Goal

Method

Provide MWF files for a certain
group of users only

Use the security protection in your HTTP server to
provide the MWF files to only a defined user

group.

Allow user of Autodesk
MapGuide Author to change
styles but not map content

Use access keys. You may want to allow a specific
group of map authors to change styles and display
ranges without being able to create new layers or
add layer files. In this case, you can protect your
resources with access keys. When you save a layer
to a Map Layer File (MLF), do not select the
Include Access Key In Map Layer File option. If
users want to add that layer to a map or create a
new layer, they must enter the correct access key
for the resource, or Autodesk MapGuide Server
will not respond to a request for that resource.

Limit access to confidential
data to a specific list of users

Assign users to a group, and assign that group to
the confidential resources, changing the pass-
words regularly.

Provide secure access that can
be disabled for a casual and
changing group of users

Assign access keys to the resources. Access key
security is transaction-based (every request
requires authentication) and requires no client-side
action. This makes it easier to allow distribution to
casual or public user groups without requiring
them to know and enter the name/password for
every layer in a published map.

Allow users to create maps and
to query Autodesk MapGuide
Server for a list of the resources
that are available to facilitate the
setup of map layers

Add users to the group called Authors. All mem-
bers of this group will have map authoring privi-
leges and full access to map data resources.

To implement any or all of these techniques for controlling access to the map
data resources at your site, you use Autodesk MapGuide Server Admin.
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Creating and Modifying Users and Groups

In order to control access to resources, you set up users and groups using the
Users/Groups tab of the Autodesk MapGuide Server Admin Properties dialog
box. To display the Autodesk MapGuide Server Admin Properties dialog box,
choose Edit » Properties. Then, click the Users/Groups tab.

Properties <]
Generall Diata Sourcesl Logging Users/Groups | Hesourcesl Acocess Ke_l,lsl
—Users:
i . —User properties ————————————————
e Mew i
bighw — Mame: I |
billiass _ l—
hiomman [Elete | Paszward:
LConfirm I
pazsword:
— Groups: :
— Group propertiess ———————————————
Authorz M e

elete | Members:

Add... | Eemoye |

Click for details

|—|DK m— | oy | Help _|__ about the options

in this dialog box.

First, you create users by specifying their names and passwords. Then, you
create groups. Finally, you assign users to the groups as members.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “users and groups.”

Assigning Users to the Authors Group

Autodesk MapGuide Server contains a predefined group called Authors.
When creating a map layer in Autodesk MapGuide Author, members of the
Authors group can query Autodesk MapGuide Server for a list of the available
data sources. Such queries elicit a prompt for a user name and password,
which are validated against the Authors group list. Although a user can enter
a data source’s full path name to include the data source in a map layer, it is
much easier to be able to choose from a list of available resources, rather than
entering a full path name.
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Warning Before Autodesk MapGuide Author users attempt to create map lay-
ers, they must be assigned to the Authors group.

For step-by-step instructions on assigning users to the Authors group, choose
Help » Contents, click the Index tab, and look up “Authors user group.”

Creating and Modifying Access Keys

When you author maps, you can embed a hidden access key within each map
layer or Zoom Goto definition. Then, each time a user attempts to access that
map layer or Zoom Goto definition, the access key is automatically sent to
the server along with the request for the data. Autodesk MapGuide Server
then verifies that the access key is on the list of access keys assigned to that
resource before providing the data.

For example, you could specify in Autodesk MapGuide Server Admin that the
text string FLIWMTD is an access key for the SDF lakes.sdf. An author
creating a map could then embed that string in a map layer that uses data
from lakes.sdf. Then, whenever a user zooms in or out on the map or works
with a feature on that layer, Autodesk MapGuide Viewer sends the access key
along with the request for data. This happens automatically without the user
being aware of the access key or needing to enter any information. Autodesk
MapGuide Server verifies that the access key is on the list of access keys
assigned to the resource lakes.sdf in Autodesk MapGuide Server Admin, and
then provides the data. The map author needs to coordinate with the
Autodesk MapGuide Server administrator to make sure that the access key
the author enters in a map layer is properly assigned to the specific resource
that provides data to that map layer.

Access keys are also useful for creating maps that are valid for only a specific
period of time, as you can change the values of access keys and their start and
end dates. Access keys also make it easy to stop serving data from a specific
resource quickly.

For step-by-step instructions on creating access keys, choose Help »
Contents, click the Index tab, and look up “access keys, creating.”
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You assign access keys using the Access Keys tab in the Autodesk MapGuide

Server Admin Properties dialog box. To display the Properties dialog box,

choose Edit » Properties. Then, click the Access Keys tab.

Properties [ %]

Mew

Generall Data Sourcesl Loggingl Users.-"GroupsI Resources  Access Keys |

Delete |

Description:
Llient:

Start date:

End date:

—Access key properties:

Access key

adtest2

ITom's key

IPotter Landscaping
|20m12:3
Farmat : MDD

|200212:1
Farmat : MDD

Cancel | Lpply | Help —I—

Restricting Access to Resources

You can restrict access to your resources (data sources) by adding the

resources to the Resources tab in the Autodesk MapGuide Server Admin

Click for details
| about the options
in this dialog box.

Properties dialog box. To display the Properties dialog box, choose Edit »
Properties. Then, click the Resources tab.

Managing Server Security
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Properties [ ]

Generall Drata Sourcesl Loggingl Users/Groups  Resources |Access Ke_l,lsl
Mame | Type
Sample_‘wWorld_DB/Sample_‘world_Cities [rata zource/T able
S ample_‘world_DE [rata zource/T able
LSADDRESS ZoomGoto Address
S ample_\World_DEM.jpg Fiaster Image File
S ample_\world_SDF [rata zource/T able
| | i
Add... | Eraperties... Eemoyve
Click for details
about the options
Cancel | Lol | Help —|—— . . . P
in this dialog box.

The Resource tab lists any resources you have added to Autodesk MapGuide
Server Admin. A resource can be any of the following:

Spatial Data File (SDF)

Raster image file

Directory containing multiple SDF or raster image files

OLE DB data source and all of its tables (optionally, a specific table)
ADL data source (optionally, a specific DWG file)

Zoom Goto specification

Autodesk GIS Design Server data source (optionally, a configuration and
theme)

Note that you add resources on this tab only if you wish to restrict access to
those resources.
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Warning When you run Autodesk MapGuide Server Admin, you are always
logged in under a user account. If Autodesk MapGuide Server is running under
the System account, it will not be able to access the User DSNs you can access in
Autodesk MapGuide Server Admin. In this case, you need to ensure that any
DSNs you configure through Autodesk MapGuide Server Admin are System
DSNs. Otherwise, database resources will not be set up correctly. Likewise, if
Autodesk MapGuide Server is running under a user account, be sure to log on to
that same user account before running Autodesk MapGuide Server Admin so that
Autodesk MapGuide Server and Autodesk MapGuide Server Admin can access
the same User DSNs.

To change the access properties of a resource, you must first add the resource
to the Resources tab of the Properties dialog box.

For step-by-step instructions on adding resources, choose Help » Contents,
click the Index tab, and look up “resources, adding.”

Taking Data Sources Offline

When you need to update or replace a data source, you must ensure that no
users are accessing the data source. To do this, you need to take the data
source offline.

To take a data source offline

1 On the Data Sources tab, select the data source you want to disconnect.
Note that you cannot take a single table offline.

2 Clear the Available check box.

Data sources:

[ Awailable I Clear a check box to take a data

! source offline. Select the check

g;?ple‘wmld‘sw box to put the data source back
- online.
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When you take a data source offline, all current connections to the data
source are removed and no new connections are allowed. Users cannot access
the data source again until you put it back online by selecting the Available
check box.

Keep in mind that taking a data source offline affects only the current server.
If other servers have access to this data source, you must take the data source
offline on each of those servers as well.

Tracking Server Requests

Help Index

log files
viewing
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When Autodesk MapGuide Server is running, its status is displayed on the
Autodesk MapGuide Server Admin title bar, and the number of requests
currently being processed is shown in parentheses. You can view additional
usage information by displaying one of the log files or running a usage
report. You can also rename and rotate log files, and customize the access and
map layer access log files.

For step-by-step instructions on viewing log files, choose Help » Contents,
click the Index tab, and look up “log files, viewing.”

Access Log File

The access log file records all requests to Autodesk MapGuide Server and gives
you a record of the activity at your site. An access log record is created for
each request as the request is completed. For information about customizing
the access log file for map layer data requests, see “Customizing the Access
Log” on page 90.

Error Log File

The error log file records errors that occur during Autodesk MapGuide Server
requests.

Trace Log File

The trace log file records the details of each request to Autodesk MapGuide
Server. Because any request can include data for several map layers, each
record in the trace log displays the details of the request for each layer.
Entries in the trace log are created as soon as a request comes in, before it is
serviced.
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Map Layer Access Log File

The map layer access log file records all requests to Autodesk MapGuide
Server for individual map layers. A map layer access log record is created for
each request as the request is completed. For information about customizing
the map layer access log, see “Customizing the Map Layer Access Log” on
page 91.

Usage Reports

You can run usage reports to track the number of Autodesk MapGuide
Viewers with unique IDs that query the Autodesk MapGuide Server. Usage
reports do not track instances of Autodesk MapGuide Author that query the
server.

The Standard Usage and Mobile Device Usage reports display the number of
unique Autodesk MapGuide Viewers for each day of the past twelve months,
and the total number of unique Autodesk MapGuide Viewers for each
month. The Summary Usage report displays the total number of bytes,
requests, and users served each month. These usage reports are not designed
to provide absolute numbers—they can help you spot trends in usage. This
helps you determine when you might need to improve performance as your
number of users increases.

For step-by-step instructions on viewing usage reports, choose Help »
Contents, click the Index tab, and look up “usage reports, viewing.”

Renaming Log Files

You can rename the access log, error log, and trace log using the Logging tab
of the Properties dialog box.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “log files, renaming.”
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Properties [ %]

Generall Data Sources  Logging | Users.-"GroupsI Hesourcesl Access Ke_l,lsl

Access log file: ID:\Program Filez\Autodesk WM apGuideS erverBhloghmacciyim
Error log file: ID:\Program Filez\Autodesk WM apGuideS erverBhloghmerraor. log
™ Trace log file: ID:\Program FilezAutodesk Wk apGuideS erverBhloghmirace. log

™ Map layer access log file: |D:\Program Files"Autodesk W apGuideS erverBhloghmlyriyims

Cancel Lpply Help

Rotating Log Files

For the access log, error log, and trace log, you can automatically create a new
file for each log every day at midnight, allowing you to have a different log
file every day. This is useful if you need to go back to check the information
in the log files for a particular day.

To rotate the log files, you include a date format string in the log file names
to indicate which date information will be used in the name of the log files.
For a complete list of format codes you can use, choose Help » Contents,
click the Index tab, and look up “log files, rotating.”

Customizing the Access Log

When a user sends a request to build map layer data in Autodesk MapGuide®
Author or Autodesk MapGuide® Viewer, the program sends a Map Layer Data
(MLData) request. Autodesk MapGuide Server site administrators can
customize the information that is recorded in the access log file for MLData
request types by modifying values in the Windows registry.

Warning Whenever you edit your registry, be sure to use great caution. We
recommend that you make a backup of your registry before you proceed.
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The MLData values are in the following key:

HKEY_LOCAL_MACHINE\SOFTWARE\ Autodesk\MapGuide Server\6.0\Log\
MLData\

For a complete list of parameters that you can use to customize the access log
file, choose Help » Contents, click the Index tab, and look up “access log,
customizing.”

Customizing the Map Layer Access Log

The map layer access log records all requests to the Autodesk MapGuide
Server for each map layer. Autodesk MapGuide Server site administrators can
customize the information that is recorded in the map layer access log file by
modifying values in the Windows registry.

Warning Whenever you edit your registry, be sure to use great caution. We
recommend that you make a backup of your registry before you proceed.

The map layer data values are in the following key:

HKEY_LOCAL_MACHINE\SOFTWARE\ Autodesk\MapGuide Server\6.0\Log\
MapLayerAccessLog\

For a complete list of parameters that you can use to customize the map layer
access log file, choose Help » Contents, click the Index tab, and look up
“map layer access log, customizing.”

Adding Geocoding Data

Help Index

geocoding database

Before you can enable zooming to a US street address or ZIP code, Autodesk
MapGuide Server must have access to a geocoding database. When the user
enters an address or ZIP code, Autodesk MapGuide finds that address and its
corresponding coordinates in the database, and then zooms to that location
on the map. For more information, see “Zoom Goto Address (Geocoding)
Data” on page 101.

After you have obtained the geocoding files, you need to set them up so that
Autodesk MapGuide Server can properly serve them to Autodesk MapGuide
Author or Autodesk MapGuide Viewer. For information about obtaining
geocoding data, go to: http://www.mapguide.com/data.

Adding Geocoding Data | 91



92



M

[

Working with Data in
Autodesk MapGuide

This chapter discusses the basic steps for working with
data and includes information about the different kinds

of data you can use with Autodesk MapGuide®.

This chapter may be especially helpful to:

m  Data engineers

m  Map authors

In this chapter

Basic steps for working with
data

Working with spatial data
Working with attribute data
Working with raster images
Working with symbols

Working with other types of
spatial data
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Basic Steps for Working with Data

In order to gather or create data, and then add it to map layers, you need to
follow these basic steps:

1 Determine the coordinate precision and coordinate system to use. For
more information, see “Designing the Map” on page 118.

2 Create spatial data sources and add them to layers. See the next section,
“Working with Spatial Data,” and see “Specifying Data Source Properties
for Layers” on page 160.

3 Create attribute data and link it to spatial data. For more information, see
“Working with Attribute Data” on page 97.

4 Create raster images and add them to layers. For more information, see
“Working with Raster Images” on page 101.

5 Create symbols and add them to layers. For more information, see “Work-
ing with Symbols” on page 109.

6 Create Zoom Goto categories. For more information, see “Setting Zoom
Goto Data” on page 100.

7 Create reports and add them to the map. For more information, see
“Working with Reports” on page 149.

This chapter is designed to give you an understanding of the different types
of data you can use with Autodesk MapGuide, and how you create or procure
the data. For information about using the data in map layers, see Chapter 9,
“Working with Map Layers.”

Working with Spatial Data

94

Coordinates that represent the geographic features on a map are called spatial
data. When you create a layer in a map, you specify which file contains the
spatial data to display on that layer.

Spatial data can be in a variety of formats. SDF is the native Autodesk
MapGuide format. However, Autodesk MapGuide can read spatial data from
other formats as well (such as Oracle® Spatial) if you have a data provider
installed for that specific format. For more information, see “Working with
Other Types of Spatial Data” on page 112. If you are creating a point or text
layer, you can specify an OLE DB data source, such as a table that contains
coordinates and text. For more information, see “Working with Attribute
Data” on page 97.
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Map Features

Map features are the geographic features that appear on a map. In Autodesk
MapGuide, map features are points, such as fire hydrants and cities,
polylines, such as rivers and roads, and polygons, such as lakes and land
parcels. Each map feature has a name, an optional URL link, and geometric
data specified by one or more coordinate pairs.

The files containing the spatial data can also contain compound map
features, such as polypolylines and polypolygons. Polypolylines are multiple
polylines grouped as one to represent compound line features, such as road
networks and river systems. Polypolygons represent compound area features,
such as islands in a lake.

The following sections describe each of the types of map features you might
have in your Spatial Data Files.

Points

A point is single place on a map, such as a telephone pole, or a city. Every
point corresponds to a single coordinate pair that locates the point’s symbol
or text on the map. To use the points from a Spatial Data File in a map, you
create a point layer.

Lines/Polylines/Polypolylines

A line represents a linear feature, such as a street, river, or sewer pipe. A
polyline is simply a line with multiple segments, such as a winding road. A
polypolyline is a single feature that includes two or more polylines; this is a
convenient way to group related polylines into one map feature so that they
can be selected or linked to a database as a single entity. The starting point
and the ending point of each line segment in a line, polyline, or polypolyline
has a coordinate pair, so that a polyline with several line segments, for
example, will have several coordinate pairs that define the polyline.
Autodesk MapGuide treats lines, polylines, and polypolylines the same
way—to use the lines, polylines, and polypolylines from a Spatial Data File
in a map, you create a polyline layer.
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Polygons/Polypolygons

A polygon represents a filled area on a map, such as a country or a lake. A
polypolygon is a map feature consisting of two or more polygons, for
example, a house with a detached garage. Although the polygons forming
the house and the garage are not connected, you may still want to treat them
as a single map feature. You can achieve this by making them both part of
the same polypolygon. Each vertex on a polygon or polypolygon is a coordi-
nate pair, and all the coordinate pairs make up the polygon. Autodesk
MapGuide treats polygons and polypolygons the same way—to use the poly-
gons and polypolygons from a Spatial Data File in a map, you create a
polygon layer.

Text

Also known as annotations in other applications, text features are blocks of
text placed at specific coordinates on the map. Like points, each text feature
has a single coordinate pair associated with it.

Creating a Spatial Data File

Typically, you use a GIS application to create your spatial data, then export
it to an Autodesk MapGuide SDFE. If the application you are using does not
support the SDF format, you can use SDF Loader or the SDF Component
Toolkit to convert the data to SDF format. Then, Autodesk MapGuide® Server
reads the SDF data and sends it to Autodesk MapGuide® Author and
Autodesk MapGuide® Viewer to be displayed.

If you need to convert data to SDF format, you should be aware of the coor-
dinate precision you will need (see “About Coordinate Precision” on
page 119), and then choose the best conversion tool for your needs.

When creating SDFs, you should use only one type of data in each SDE, if
possible. For example, an SDF might contain only points, lines/polylines,

polygons, or annotations (text) from your Autodesk Map® data. This opti-
mizes performance in Autodesk MapGuide.

Note When naming the SDF, make sure that the file name does not contain any
of the following characters: double quote ("), asterisk (*), colon (:), slash (/), back-
slash (\), less than (<), greater than (>), question mark (?), pound symbol (#), or
vertical bar (]).
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For points/symbols and text, you can store coordinates in a database instead
of an SDE. You can update coordinates in a standard database application
quite easily, and you can rotate, align, and size text based on fields in the
database.

The following sections explain the information you need to know about
using the two SDF conversion applications.

SDF Loader

You can use the SDF Loader to convert several file formats individually, or
you can create batch files to convert multiple files. The batch file can run the
SDF Loader and any necessary third-party programs to convert the files. This
is an efficient way to set up your source data and create your SDFs. For
complete information, refer to the SDF Loader Help.

SDF Component Toolkit

You can use the SDF Component Toolkit and a programming language, such
as Visual Basic or C++, to create an application that works with SDFs. The SDF
Component Toolkit provides powerful access to SDFs, including the ability
to work with individual features within an SDF. This means that your
program could convert individual features in the SDF rather than the whole
file at once, so you have more control of your conversion than you do with
the SDF Loader. For complete information, refer to the SDF Component Toolkit
Help.

Working with Attribute Data

Attribute data is data that can be linked to the spatial data in maps to provide
the user with information about those spatial features. Examples of attribute
data are population, area, name, total sales, a URL link to a related Web page,
style data, and any other data you want to associate with a spatial feature.
When you link attribute data to your spatial data, the data can be used in one
of four ways: to display the names of the features, to set the width (of
symbols), height and rotation (of symbols and text), and alignment (of text),
to create themes, or to generate reports. The following sections describe how
to prepare and use your attribute data.

Working with Attribute Data | 97



Help Index

troubleshooting
problems creating themes

Linking Attribute Data to Spatial Data Files

To link the attribute data to spatial data, you simply specify the OLE DB or
Autodesk DWG database table you want to use when setting up the layer.
Autodesk MapGuide Author matches the records in the table to the spatial
features in the SDF from which the layer was created by means of a key. A key
is a string that uniquely identifies each spatial feature in the SDF and each
record in the database. When a record in the attribute database and a spatial
feature in the SDF have the same key, the record is linked to the spatial
feature.

You can also use a database table for theme information. For example, you
might have three sources of data: an SDF of coordinates that represent lakes,
a secondary database table containing the name and linked URL for each
lake, and another database table containing theme information, such as the
size of each lake, water purity, and more. When you create the layer in the
Map Layer Properties dialog box in Autodesk MapGuide Author, you specify
the secondary table on the Data Sources tab, and specify the theme table
from the Styles tab when adding a theme. Note that neither of the tables
need to contain coordinates—they are linked to the polygons in the SDF only
by their keys. For more information, see “Setting Display Styles for DWG
Layers” on page 171.

To avoid potential conversion problems, be careful when creating the key
field. Depending on the type of database, you might not be able to use the
attribute data unless the key field in the database is exactly the same size as
the key field in the SDF to which you are linking it. Some databases, when
queried, will append the keys with blank space characters to make them the
exact length you specified for the field, so the database keys will not match
those in the SDF. For more information, choose Help » Contents, click the
Index tab, and look up “troubleshooting, problems creating themes.”

Linking Attribute Data to Another Database

You can create point layers and text layers from OLE DB or Autodesk DWG
data sources instead of SDFs. For these layers, you can still use a OLE DB or
Autodesk DWG database table for creating themes. For example, if you are
setting up a layer of cities, you might have two tables: one that contains basic
information about each city, such as the key, coordinates, name, and a URL
link, and a second table that contains data on which you want to create
themes, such as the population, majority political party, and so on. The
second table would also contain the same key values as the first table;
Autodesk MapGuide uses these keys to assign the theme values in the second
table to the corresponding cities in the first table.
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Preparing Attribute Data for Themes

As mentioned in the previous sections, you can use the data in a linked
attribute table as the basis for themes. Themes draw the map features on a
layer according to particular values. For example, on a map layer that
contains cities, you could use different symbols to represent cities that fall
within different population ranges. Themes also help to differentiate features
in a layer. For example, on a roads layer, you could draw interstate highways
differently from city streets, even though they’re on the same layer.

When setting up your attribute data, you should consider whether you will
be creating themes, and whether the data in the table lends itself easily to
this task. For example, for a roads layer, do you already have a column that
contains the text “Interstate” or “City Street” for each feature in the table? If
so, it will be very simple to specify this column as the theme column and
specify that if the column contains “Interstate,” the feature will be drawn as
a thick yellow line, and if the column contains “City Street,” the features will
be drawn as a thin black line. However, if you want your roads to be drawn
in such a way as to show how heavy the traffic is, a column indicating
whether it's an interstate highway or city street will not be useful—you will
need a column that indicates how much traffic each road has. You can then
use this third column to specify how the roads are drawn to show traffic.

For example, you might create four theme categories: fewer than 200 cars per
month, between 201 and 5,000, between 5,001 and 10,000, and greater than
10,000. You can then specify the display attributes separately for each of

these categories, so that roads with the lightest traffic are drawn in thin black
lines and roads with heaviest traffic are drawn in thick red lines, and so on.

If you are using point or text data, you need to consider which symbols you
will want to use for each theme category. For more information, see
“Working with Symbols” on page 109.

Setting Up Your Attribute Database

You need to take the following points into consideration when setting up
your attribute database:

m Before Autodesk MapGuide can use your databases, you must set them up
and configure them as OLE DB data sources or Autodesk DWG data
sources. For more information, see “Setting Up Your Data Sources” on
page 78.

®m You can limit users’ access to data sources by setting up passwords for users
or for groups or by assigning access keys to the resource. For more infor-
mation, see “Managing Server Security” on page 80.
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m When naming your attribute data sources, avoid using the ampersand (&)
in the names of databases, tables, and columns. This character is unsup-
ported in all names in Autodesk MapGuide, including SDF names, layer
names, user names, access keys, tracking IDs, and passwords.

m Make sure that the fields containing the coordinates, keys, names, and
URLs are all in the same table, view, or query in the data source. Your
theme data can be located in a different table, but it must contain keys
that match those in the source data.

m When setting up the layer, you can use a SQL Where clause to filter and
customize the data. For example, if this layer will display cities, you could
specify that the layer include only those cities with a population greater
than 10,000. For more information, see Chapter 9, “Working with Map
Layers.”

m When setting up a theme, the Theme Column text box will accept a sim-
ple expression in addition to the field.

Setting Zoom Goto Data

You can use Zoom Goto categories to allow users to zoom in on specific
features in the layer. There are two types of Zoom Goto data: Zoom Goto
Location categories and Zoom Goto Address data.

Zoom Goto Location Categories

A Zoom Goto category enables users to zoom in on a specific location that
falls within the current category. For example, if you have a category called
Airports, the user would be able to select from a list of airports and zoom to
the selected airport on the map.

Features that need to be part of a Zoom Goto category must have their coor-
dinates and category value entered into fields in an OLE DB data source.
Unlike other types of attribute data, Zoom Goto categories do not require a
feature key, so you do not need to include it in your Zoom Goto category
database. For instance, if you have a polygon layer of parcels that you want
users to be able to zoom to, you could store all of your parcel IDs and coor-
dinate values in an OLE DB database. You could then use Autodesk
MapGuide Author to create a Zoom Goto category called “parcels” with a
SQL statement that retrieves coordinates from the database based on a parcel
ID that is passed in. The Zoom Goto dialog box in Autodesk MapGuide
Viewer would let users enter the ID of the parcel they want to zoom to, and
the SQL statement would retrieve the coordinate values, enabling the Viewer
to zoom to that feature.
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Zoom Goto Address (Geocoding) Data

With a geocoding database installed on your server, map authors can add the
Zoom Goto US Street Address category to their maps. Autodesk MapGuide
Author comes with a predefined location category called “US Street Address.”
When map authors activate this category, they access the geocoding database
that you installed on your server (see “Adding Geocoding Data” on page 91).
When the category is in place, users can type an address or ZIP code and
zoom directly to that location on the map. For more information, see
“Creating and Modifying Zoom Goto Location Categories” on page 146.

Working with Raster Images

Raster images are pixel-based images, such as digital photographs (satellite
images, for example). Raster images are very useful as background images
underneath your vector data, for example, an aerial photograph of a city with
a layer of streets overlaying it.

Autodesk MapGuide supports various raster image file formats. The following
section contains a complete list of supported file formats.

Raster Image File Formats

The following table provides a brief description of the raster image file
formats supported by Autodesk MapGuide Author and Autodesk MapGuide

Server:
Format File Description
Extension
BMP .bmp Microsoft Windows Bitmap
CALS .cal CALS MIL-R-28002A Type 1 Format
ECW .ecw Enhanced Compression Wavelet
GeoSPOT .bil Band Interleaved (GeoSPOT, others)

Note that GeoSPOT files need their associated color
index files, which have a .cIr file extension. The CLR file
should be in the same directory as the BIL file.
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Format File Description

Extension
JPEG .Jpg, .jpeg Joint Photographic Experts Group
MrSID .sid Multi-Resolution Seamless Image Database
PNG .png Portable Network Graphic
TGA .tga TrueVision Targa 2.0 Format
TIFF tif, . tiff Tagged Image File Format

Efficient Raster Formats

Because raster images can be quite large, they can slow down performance.
To improve performance significantly, use tiled TIFF files, ECW files, or
MzrSID version 1.6 files.

Tiled TIFFs

A tiled TIFF file allows Autodesk MapGuide to access only specific portions of
the image. This greatly improves access speed, because Autodesk MapGuide
Server does not need to load the entire image every time—just the specific
portion requested. The difference in performance between using standard
TIFF files and tiled TIFF files is dramatic. You can use Raster Workshop to
generate tiled TIFFs from other raster file formats.

ECW Files

ECW, supported by ER Mapper, is a wavelet-based image compression format
with high-quality results at high compression rates.

MrSID Files

MrSID (Multi-Resolution Seamless Image Database), supported by Lizard-
Tech, Inc., is a wavelet-based image compression format designed specifically
for GIS to enable true portability of large images. Autodesk MapGuide
supports MrSID version 1.6 format .sid files.
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Raster Image Catalog Files

In addition to individual raster image files, Autodesk MapGuide supports
Raster Image Catalog (RIC) files. A RIC is a list of raster image files and their
lower-left and upper-right coordinates. When creating a raster map layer, you
can reference an individual raster image in any of the supported formats
shown on page 101, or in a RIC file. Each raster image file (whether an indi-
vidual image or a RIC) must be accompanied by a georeferencing file, which
provides additional information about how to position the raster image on
the map. Note that GeoTIFF files do not require a separate georeferencing file.
Raster images in ECW and MrSID format are already optimized, so there is no
reason to include them in RIC files.

When you access a layer that references a RIC file, Autodesk MapGuide Server
scans through the RIC file to determine the images or portions of images that
correspond to the area being viewed, and then sends only the data for that
area. This greatly increases performance, as only the necessary data is stored
in memory instead of the entire image.

It is important to keep in mind that the RIC file only determines which
images might be visible. Georeferencing information for each individual
raster image must still be available, as this information—not the information
in the RIC file—is used to place them in the correct position on the map.
Note that the raster image must be based on the same coordinate system as
the rest of the data on the map, and it cannot be converted automatically if
you change the coordinate system for the map.

If Autodesk MapGuide Server is running under the System account, please
note the following:

m All of the image files in the RIC must be on the same server as the RIC.

m The RIC must reference the raster image files using relative paths. If you
use a computer name in the path, Windows NT/2000 will not be able to
recognize it.

Raster Image Catalog File Format

Raster image catalog files are ASCII, comma-delimited (CSV) files with the
following format:

"<Name of the raster image file1>",<xMin>,<yMin>,<xMax>,<yMax>
"<Name of the raster image file2>",<xMin>,<yMin>,<xMax>,<yMax>
"<Name of the raster image file3>",<xMin>,<yMin>,<xMax>,<yMax>

"<Name of the raster image filen>",<xMin>,<yMin>,<xMax>,<yMax>
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Note that the names of the raster image files may not contain commas (,),
and the quotation marks (“) around the raster image file names are optional.
The names of the individual raster image files entered in the RIC may be
specified using the full absolute path name, the path relative to the RIC file
location, or only the file name itself. If only the file name of the raster image
is specified, the search will start in the directory where the RIC is located
before using the Raster Image Search Path (specified in Autodesk MapGuide
Server Admin) to locate the file.

All images in a RIC must be of the same color depth (1, 8, 24, or 32 bits);
combinations of different color depths are not supported. However, images
of different resolutions are supported. For example, you could mix 1- and 2-
meter resolution data. Also, images in a RIC can be in different formats, such
as TIFF, TGA, PNG, and so on.

Images are processed in the same order in which they are listed in the RIC.
Therefore, if two images overlap each other, the image specified later in the
list will cover the image specified earlier in the list. When you create a layer,
you can specify a transparent background for bitonal images, so the bottom
images can show through the background area of the top image. For detailed
information about creating a raster layer, choose Help » Contents, click the
Index tab, and look up “raster layers, creating.”

The extents (outer boundary) of each raster image must be specified using the
xMin, yMin, xMax, and yMax parameters. These parameters specify the
center or middle position of the lower-left and upper-right pixels of the
image (as opposed to the corners of the pixel), and they must be specified in
the same coordinate system as that used by the map and any other images in
the RIC. Autodesk MapGuide Server uses the extent parameters to quickly
determine if an image is within the viewing area without having to open the
georeference file associated with each raster image.

Generating Raster Image Catalog Files

The simplest way to generate RIC files is to use Raster Workshop, a utility
available from the Autodesk MapGuide CD. You can use this utility to create
a RIC, add raster image files to the RIC, subsample and merge the files, and
more.

You can also generate RICs manually by using an ASCII text editor or by
exporting the data in CSV format from a database. However, in many cases
the extents of the raster image file may not be readily available. For example,
ESRI world files use the coordinates of one corner and the width of each
pixel. You would have to open the image itself to determine how many pixels
it contained, and then calculate the extents for each image.
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Another way to generate a RIC manually is to use Autodesk MapGuide
Author to obtain the coordinates of the image extents. First, display each
image on a layer, and then zoom to opposite corners of the image (lower-left
and upper-right), reading the coordinates from the status bar. These coordi-
nates indicate the extents of the image. They do not have to be exact, only
greater than the extents of the actual image. The extents in the RIC are used
only to determine if an image might be visible. The georeferencing informa-
tion from each image will be used to georeference the image within the tiled
suite.

Georeference File Formats
A georeference file indicates how to place a raster image on a map. Autodesk

MapGuide Author supports four georeference file formats: ESRI world files,
Maplnfo tab files, GeoTIFF files, and header files.

ESRI World File

An ESRI world file is an ASCII text file that uses the following formats:

Format Example
<x dimension of a pixel> 2.0

<x rotation factor> 0.0

<y rotation factor> 0.0
<negative y dimensionofa  -2.0
pixel>

<x value of the upper-left 233001.5
pixel>

<y value of the upper-left 901999.5
pixel>

For example, a typical ESRI world file might look like this:

2.0
0.000000
0.000000
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-2.0
233001.5
901999.5

Note that the formats <x rotation factor> and <y rotation factor> must

always have a value of 0.0.

The ESRI world file extension depends on the raster image file format as listed

in the following table:

Raster Image Format

World File Extension

TGA taw
CALS .clw
PNG .pgw
BMP .bpw
JPEG Jgw
TIFF tw

Mapinfo Tab File

MaplInfo uses a TAB file (.tab) to georeference a raster image. It contains
control points to map pixel coordinates in a raster image to world or map
coordinates. To work in Autodesk MapGuide Author, you need to specify the
control points so that linear scaling is possible.

The raster image formats supported by the MapInfo tab file are: TGA, CALS,
PNG, BMP, JPEG, and TIFE. The following is an example of a tab file:

Example

Itable
lversion 300

Icharsest WindowsLatin1

Definition Table:
File "dublinca.tif"
Type "RASTER"
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(6144414, 2088370) (0,0) Label "Pt 1"

(6144416, 2088370) (1,0) Label "Pt 2"

(6144414, 2088370) (0,1) Label "Pt 3"

CoordSys Earth Projection 3, 74, "ft", 120.50, 36.50, 38.43, 37.07, 2000000,
500000

Units "ft"

RasterStyle 2 74

GeoTIFF

A GeoTIFF file is an extended version of the TIFF format, with embedded
georeference information inside one or more of its tags. A single file contains
both the raster image and its georeference information.

Header File

A header file is an ASCII text file containing keywords and values for speci-
tying the georeference information of the raster image. This format works
only with the GeoSPOT BIL raster image format. The following is an example
of a header file:

Example
GIS-GEOSPOT Header File
Image Information

DELTA_X_ORIGIN 0.0M
DELTA_Y_ORIGIN 0.0M

MAPUNITS METERS
ULXMAP 543134.90 M
ULYMAP 5283921.00 M
XDIM 10.0 M

YDIM 10.0 M

NCOLS 1269

NROWS 1862
NBANDS 3

I Frame Corner Support
!

NW_X_PIXEL 1

NW_Y_PIXEL 11
NE_X_PIXEL 1251
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NE_Y_PIXEL 1

SW_X_PIXEL 15
SW_Y_PIXEL 1862
SE_X_PIXEL 1269
SE_Y_PIXEL 1852
!

! File Encoding

!

NBITS 8
BYTEORDER I
SKIPBYTES 0

RECORDSKIPBYTES 0
BANDROWBYTES 1269
TOTALROWBYTES 3807
LAYOUT BIL
BAND_RGB 321

!

! Process Information

!

PRE_PROCESSING_LEVEL "3a"
|

| End of File

Exporting from ER Mapper

You can also use ER Mapper from Earth Resource Mapping to export images
as raster images in BIL (Band Interleaved Line) format along with associated
HDR files. Autodesk MapGuide Server can access BIL files randomly,
increasing performance over regular non-tiled raster images in some situa-
tions. For information about ER Mappet, go to:

http://www.ermapper.com/

Adding Raster Images to Your Map

As stated earlier, you can use raster images as layers that underlay vector
layers, so that, for example, street data could appear on top of an aerial photo
of the city. In this case, you must create a separate raster layer for each raster
image or RIC file. For detailed information about creating a raster layer,
choose Help » Contents, click the Index tab, and look up “raster layers,
creating.”
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Working with Symbols

Autodesk MapGuide Author enables you to select and modify symbols that
you want to make available to either a point layer or a redline layer, by using
one of the following three options:

m Symbol Manager
m Point Layer Symbol Manager dialog box
m API Symbol Manager dialog box

While the Point Layer Symbol Manager dialog box and API Symbol Manager
dialog box are accessed from within Autodesk MapGuide Author, you can
also work with symbols using Symbol Manager, a separate product.

Although used for different purposes, all three symbol managers support the
following functionality:

m Pasting symbols of any graphic file format from the Windows Clipboard
into the Symbol Manager

m Creating complex symbols that contain both bitmap images and vector
graphics

m Renaming symbols

m Making the color of a bitmap within a symbol transparent

m Importing symbol files of the following type:

Bitmap (BMP)

Device Independent Bitmap (DIB)
Enhanced Metafile (EMF)

Symbol Manager (SMB)

Windows Metafile (WMF)

The differences between the three symbol managers are described in the
following sections.

Note that you can also use the SDF Loader to convert blocks from Autodesk
Map to EMFs using the /BLOCKS:EMF switch. For more information, refer to
the SDF Loader Help.
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Symbol Manager

This application, which is installed with Autodesk MapGuide Author,
enables you to create your own SMB files or modify SMB files installed with
Autodesk MapGuide.

SMB files and the individual symbols they contain can be composed of bitmap
images and vector graphics. This enables you to combine vector graphics and
bitmaps in one symbol, create new SMB files, or modify existing SMB files by
adding and removing symbols. You can also modify the display properties of
specific symbols within SMB files to specify where the symbols are inserted
in a map layer and to make a bitmap color in a symbol transparent.

After you modify SMB files using Symbol Manager, you use one of the other
symbol managers to access the SMB file and apply the symbols in the SMB
file to a point layer or redline layer.

Using the Point Layer Symbol Manager dialog box from within Autodesk
MapGuide Author, you can select a point layer and add symbols. For more
information, see “Point Layers and the Point Layer Symbol Manager” on
page 111.

Using the API Symbol Manager dialog box from within Autodesk MapGuide
Author, you can make symbols available to a redline layer. For more informa-
tion, see “Redline Layers and the API Symbol Manager” on page 112.

As well as enabling you to modify SMB files, Symbol Manager includes the
following features not available in the Point Layer Symbol Manager or API
Symbol Manager dialog boxes:

m Creating and modifying SMB files
m Importing TrueType fonts to use as symbols
m Setting symbol reference points

For detailed information, choose Help » Contents, click the Index tab, and
look up “symbols, Symbol Manager.”
To start Symbol Manager

m From the Start menu, choose Programs » Autodesk MapGuide Release 6
» Symbol Manager.
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The Symbol Manager dialog box appears, displaying a blank file.

ET Autodesk MapGuide® Symbol Manager - Untitled - |EI|1|
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The complete, step-by-step procedures for using Symbol Manager are
included in the online Help. Choose Help » Contents, then refer to the
topics listed under “Creating and Publishing Maps » Using Autodesk
MapGuide Symbol Manager.”

Point Layers and the Point Layer Symbol Manager

You add symbols to point layers using the Point Layer Symbol Manager
dialog box available in Autodesk MapGuide Author. You use the Point Layer
Symbol Manager dialog box to access symbol files within SMB files, symbols
saved to a local or networked location, and symbols pasted to the Windows
Clipboard.

The symbols you add to point layers are visible to Autodesk MapGuide
Viewers and denote map features, such as state capitals or other point layer
features.

For details about adding symbols to point layers, see “Adding New Symbols
for Use in Point Layers” on page 168. For detailed information, choose
Help » Contents, click the Index tab, and look up “symbols, adding for
point layers.”
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Redline Layers and the APl Symbol Manager

Using the API Symbol Manager dialog box in Autodesk MapGuide Author,

you select and modify symbols and then make the symbols accessible to a
redline layer. Autodesk MapGuide developers can add these symbols to
redline layers using the Viewer API. For more information, refer to the
Autodesk MapGuide Developer’s Guide and the Autodesk MapGuide Viewer API
Help.

Working with Other Types of Spatial Data

112

In addition to Autodesk MapGuide SDFs, you can use other types of spatial
data formats with Autodesk MapGuide.

DWG files—Leave DWG files in their native format. With this release of
Autodesk MapGuide, you can use DWG files as map layers without con-
verting them to SDF format.

SHP files—Leave SHP files in their native format and use the Autodesk
MapGuide Provider for SHP with Autodesk MapGuide Server.

Oracle Spatial data—Leave Oracle Spatial data in their native format, and
use the Autodesk MapGuide Provider for Oracle Spatial with Autodesk
MapGuide Server.

GIS Design Server Theme Data—Leave GIS Design Server Theme data in
their native format, and use the Autodesk GIS Design Server Extension
with Autodesk MapGuide Server. See “Autodesk GIS Design Server Theme
Data” on page 112, for more information.

Other data types—Convert other types of spatial data to SDF format
using the SDF Loader or SDF Component Toolkit.

Autodesk GIS Design Server Theme Data

When Autodesk MapGuide uses Autodesk® GIS Design Server theme features
in a layer, it must perform several steps to transform the data so that it can
be displayed correctly in the map. Most data appears exactly as it does in
Autodesk GIS Design Server, but there are some important points you need
to know.
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Using URL Links

You can display the name of a map feature in Autodesk MapGuide by pausing
the mouse over the feature. The name then displays in a small yellow rect-
angle called a MapTip. Also, if a map feature has a URL associated with it, the
pointer changes from an arrow to a hand when the mouse passes over that
feature, allowing the user to double-click and open the Web page specified by
that URL.

Under normal circumstances, features on an Autodesk GIS Design Server
theme layer will not have URL links associated with them. This is because the
Autodesk GIS Design Server cache does not contain this information for each
feature in the theme. If you need to have URLs associated with the features,
you could create a custom utility to export the Autodesk GIS Design Server
features from the database to an SDF or OLE DB data source. For example,
you could use Visual Basic with Autodesk GIS Design Server Objects and the
SDF Component Toolkit. This kind of utility is beyond the scope of this docu-
mentation and should be implemented by a system administrator who is
familiar with Autodesk GIS Design Server and Autodesk MapGuide.

Parsing Map Feature Keys

If you will be developing reports, it is important to know how to parse the
keys for the map feature so that you can get information about the original
Autodesk GIS Design Server features. The keys of map features on Autodesk
GIS Design Server theme layers are formed from a composite of the original
Autodesk GIS Design Server Feature, Plan, Version Mode, Layer, and Network
numbers, with a vertical bar (|) character delimiting each of the numbers as
follows:

F<Feature#>|<Plan#>|<VersionMode#>|<Layer#>|<Network#>

For example, if the feature # is 967, plan # is 5, version mode # is O, layer # is
20, and network # is 7, the key for the map feature will be the following
string:

F967|5(0|20|7
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Note The version mode number used in the key is different from the version
number associated with a feature in the Autodesk GIS Design Server database.
The version mode number indicates whether the feature is from the Autodesk GIS
Design Server permanent version or from one of the more recent versions, as
defined in the following table.

Version Mode Description
Value
0 Permanent version. Always version number 0 in the Autodesk

GIS Design Server database.

1 A recent version. The most recent version number in relation to
when the theme was generated.
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Planning and Designing Maps

This chapter includes information to help you plan your In this chapter
maps, including details about designing the maps and the B Planning the data

B Planning layers
information you will need from your server administrator. L
B Designing the map
B Information you need from
your Autodesk MapGuide
Server administrator

This chapter may be especially helpful to:

m  Map authors

m  Data engineers
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Planning the Data

In planning the data you will need, data engineers and map authors should
consider the following questions along with possible solutions:

How should the data look? For example, what colors, symbols, linestyles,
and fills will you use?

Does the data relate to a database table? If so, create an OLE DB data source
for that database, and determine which data you will use as the key.

Is it point/text data or line/polygon data? If text, do you need to rotate or
resize the text differently? Does the location of the text need to be “fixed,”
that is, placed precisely? You can add columns in the table that indicate

the rotation angle, height, and width, so that Autodesk MapGuide® can

rotate and resize the text accordingly.

Do you need to display database information thematically? If so, which
column contains the theme data?

How large is the data set? Do you want to show different versions of the
data, each of which is used at different display ranges?

Will you need to use raster data? Where is the raster data referenced? How
is this data georeferenced?

Planning Layers

After you have created, gathered, converted, and prepared all of your data,
authors can use it to create their maps. Remember that when you create a
map and add data to it, you add the data to layers. Therefore, you need to
plan the layer to which you will add the data carefully. Before you create the
layer, consider the following questions:

What naming standard are you using for layers?
Do you want to organize layers into layer groups?

Do you want to use a different name in the Viewer legend? You can enter
a separate name for the layer in the Legend Label box on the General tab
of the Map Layer Properties dialog box. This is useful if you want to have
long descriptive names appear in the Design tab of the Autodesk

MapGuide Author Map Explorer when you're working with the map, but
you want shorter names to appear for Autodesk MapGuide Viewer users.

116 | Chapter 6 Planning and Designing Maps



For example, you might create two layers that show the same areas at dif-
ferent levels of detail: the less detailed layer displays when you zoom out
and the more detailed layer displays when you zoom in. In this case, you
might name the layers “Roads - General” and “Roads - Detailed” so that
you know which one you’re working with in Autodesk MapGuide®
Author (and through the Viewer API), but you could have them both dis-
play the name “Roads” in the Viewer, so that they appear to be the same
layer to the user.

m Should users be able to select features on this layer? If the layer is unselect-
able, users will not be able to generate reports, create buffers, or use the
Select Within command. However, if the layer contains data that is prima-
rily background data, making it unselectable prevents users from acciden-
tally selecting data on that layer when they try to select an overlapping
feature on another layer.

For example, if you have outlines of neighborhoods that are only for ori-
entation purposes, you could make the layer unselectable so that users
don’t accidentally select the neighborhood outline when they are trying
to click a street. Note that if a particular data set will be selectable, you
should divide it by feature types (transformers on one layer, fire hydrants
on another). If the data set will be unselectable, divide it the way you want
it to display (red lines on one layer, green lines on another).

m Do you want to display more or less data depending on the current scale?
If so, create multiple layers of the same area that turn on and off at partic-
ular display ranges. You can quickly create copies of a layer by pressing
CTRL as you drag and drop a layer in the Map Explorer in Autodesk
MapGuide Author.

m Will the data on this layer be used in a report? If so, be sure to add the
appropriate report to the map.

As you plan multiple layers, you can create a spreadsheet that helps you keep
track of your layers and the data sources they use. As you start filling it in
with your layers, you are beginning to plan for the whole map. For example,
you might decide that there are really three main display ranges: the first
shows the whole world, the second shows a whole country, and the third
shows a city. You could then look at your spreadsheet and determine which
layers should fall within which of these three display ranges and set display
ranges for them accordingly. For more information, see “Creating a Design
Spreadsheet” on page 120.
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Designing the Map

After you have planned the data and layers for your map, you need to address
design issues, such as which coordinate system to use, what precision you
want, and how to set up and use a design spreadsheet—as well as following
general design guidelines.

About Coordinate Systems

Mapping applications use coordinate systems to determine where to display
features on the map. In a latitude/longitude coordinate system, each coordi-
nate pair corresponds to an exact fixed location on the Earth; in an arbitrary
XY system, the coordinates have meaning in relation to each other but do
not necessarily correspond to exact fixed locations on the Earth.

For example, a floor plan map might specify that the southwest corner is 0,0
and the northeast corner is 500,500, so that if the building were moved to

another location, these coordinates would still be accurate because they are
not tied to exact locations on the Earth. If you used latitude/longitude coor-
dinates for that map, however, the coordinates would change if you moved
the building, because each pair corresponds to one exact point on the Earth.

Some types of arbitrary XY systems, such as the state plane coordinate
systems, make use of both of these concepts. Each coordinate system repre-
sents a specific area, usually a state or a section of a state. Within that area,
the coordinates are meaningful and represent exact locations on the Earth.
So a point with the coordinates 100000,100000 will always represent a
specific location in the New York state plane coordinate system. However, if
you change the coordinate system to another state plane coordinate system,
all of the data will move to that area, where 100000,100000 represents a
specific location in that area. In this way, the data is arbitrary XY, because the
numbers themselves do not represent exact locations except within the
context of the fixed areas.

Note that if you are using arbitrary XY data, it is not converted to lati-
tude/longitude, so you can use it only in maps that use arbitrary XY as the
coordinate system and in which all data is in arbitrary XY. For more informa-
tion, see the SDF Loader Help (SDFLOAD.HLP) located in the SDF Loader direc-
tory.

To see a complete list of the coordinate systems in Autodesk MapGuide, as
well as their corresponding codes that you use with the /COORDSYS param-
eter in the SDF Loader, refer to the file cscodes.txt that is installed with the SDF
Loader.
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About Coordinate Precision

Coordinate precision is the level of accuracy at which a point can be stored
and retrieved to match its original location. When you use the SDF Loader,
SDF Component Toolkit, or Autodesk Map® to convert your data to an SDF,
you can specify whether to use single (32-bit) precision or double (64-bit)

precision. For latitude/longitude coordinates, single precision is accurate to
about 16 feet or 5 meters, whereas double precision is accurate to better than
a fraction of an inch or 1mm. Single precision is usually more than enough
accuracy for most applications, but if you are creating very large-scale maps
for applications that require that you accurately pinpoint items, you might
need double precision. If you are using arbitrary XY coordinates and the base
unit of the map is already very small (such as inches on a facilities manage-
ment map of office equipment), single precision will probably be sufficient.

For more information, refer to the Coordinate Precision White Paper at:
http://www.autodesk.com/utilitypapers

Choosing a Coordinate System

If you do not know which coordinate system to use, or if you need to decide
which coordinate system to use in your office or department, consider your
options in this order:

Consult with the data engineer who provided your data.

Use the same coordinate system as other staff in your organization.

Use the same coordinate system as your most common data source.
Choose the coordinate system used by people who share data with you.

If the area is small, use the same coordinate system as your local city or
county government. If the area is large, use the same coordinate system as
the state, regional, provincial, or national mapping group.

m Ask surveyors, cartographers, consultants, and other mapping profession-
als for suggestions.
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Creating a Design Spreadsheet

One very effective technique for keeping track of all your data for a map is to
create a spreadsheet of all of the layers you create, consisting of the legend
layer name, which data sources they reference, the display range, and display
styles, such as color or line style, and notes. For example, you could create a
spreadsheet or table that looks something like this:

Layer Layer Name Data Source Display Display | Notes
Name in Legend Range Style
roads_1 roads roads_coarse.sdf 40K-10M thin Visible only when
green zoomed out. Shows
lines coarser data.
roads_2 roads roads_fine.sdf 0-40K thick Visible only when
green zoomed in. Shows
lines finer data.
roadsbytypel roads by type roads_coarse.sdf | 40K-10M thin red Visible only when
lines zoomed out. Shows
coarser data. Linked
to SQL and
themed.
roadsbytype2 roads by type roads_fine.sdf 0-40K thick red Visible only when
lines zoomed in. Shows

finer data. Linked to
SQL and themed.

In this example, there are four layers. The first two layers use different data
to show the same area at different levels of detail when zoomed in or out. The
second two are set up the same way. Note that the first and third layers use
the same SDF, and the second and fourth layers use the same SDFE. As you
might imagine, as you start adding several layers to achieve different results
at various scale ranges, it can become difficult to manage the process, so
taking an organized approach is critical during planning. In addition to the
columns shown in the example, you could also add columns that indicate
which server each layer uses, whether it is selectable, the layer type, the layer
group to which a particular layer belongs, and more.
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Another way you might set up a design spreadsheet is to break the Display
Range column into several discrete ranges; you can then block out the
display ranges in which layers are on. Also, you might want to place layers in
the spreadsheet according to their data type, which often corresponds to the
display ranges. For example, point layers would be in rows near the top of the
spreadsheet, polyline layers below point layers, polygon layers below
polyline layers, and so on.

General Guidelines

Following is a list of guidelines you should consider when designing your
map:

m Use elements of nearly equal size with no features dominating the map.
Text size should be neither too small to read nor so large that the text
dominates or obscures features in the map.

m Use different symbols to represent different features. For example, you can
use symbols to represent landmarks, such as hospitals, churches, and cem-
eteries. Draw symbols at an appropriate scale so they are legible and do
not obscure other data.

m Useline type and colors to represent different features. Representing roads
as double lines can be helpful for small areas, such as subdivisions, or for
maps in which right-of-way information is important.

m Do not use an excessive number of colors. Otherwise, the map becomes
too bright, and the colors dominate. Try to limit the map to four colors.

m If you are not using themes, use one color per layer. For example, if you
have an SDF that contains roads and highways, and you want to draw
them in different colors, it’s usually best to create a separate roads layer
and highway layer and apply one color to each. The other option is to
create one layer and create theme categories for roads and highways on
that layer, applying the colors you want to the theme categories. However,
this approach can decrease performance.

m Make layers selectable only if necessary. Always ask yourself whether the
data on this layer is there to help orient the user on the map or contains
features the user needs for retrieving information. If it’s there for orienta-
tion, such as lakes and parks in a parcel map, make the layer unselectable.

m Do not try to present too much data on the map at once. Maps are more
effective when they show topics clearly. Always set up the map so that
only the most necessary layers are turned on when the user first accesses
the map; this also speeds up the initial loading of the map. The user can
then turn on additional layers to get more information as needed.
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For more information about designing and creating the features that appear
on the map, refer to the documentation for the program you are using to
create map data.

Information You Need from Your Server
Administrator

122

Before you can begin creating map layers, you need information about the
resources (spatial, raster, and attribute data) that you will use in your map.
You also need information about Autodesk MapGuide® Server through
which you will access those resources. The following list tells you which
information you need to gather. Your server administrator will be able to
provide you with this information.

m The location of the resources, and any access keys or passwords assigned
to the resources. You will use this information when setting up a layer.

m The URL of the Autodesk MapGuide Server Agent (or MapAgent). If your
organization has more than one Autodesk MapGuide Server, you may
have more than one MapAgent to choose from. You specify the MapAgent
you want to use when you set up a layer. Typically, the URL looks some-
thing like:
http://www.yourcompany.com/MapAgent6/mapagent.exe

m Confirmation that you have been granted authoring privileges. Before
you can browse for available resources to use for a layer, the server admin-
istrator must grant you authoring privileges by adding your user name
and password to the Authors group in the Autodesk MapGuide Server
Admin. For more information see “Managing Server Security” on page 80.
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Getting Familiar with
Autodesk MapGuide Author

This chapter includes the essential information you need In this chapter

to get started with Autodesk MapGuide® Author, includ- W Installing Autodesk
MapGuide Author

ing instructions for installing and starting the program, B Starting Autodesk
MapGuide Author

navigating maps and layers, and other map authoring

Introduction to the program

window layout
fundamentals.
Setting preferences
This chapter may be especially helpful to: Opening a map

Moving around on a map
m  Map authors
Using the Map Explorer
Viewing map information
Measuring distances

Selecting map features

Creating buffers around
map features

Printing a map
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Installing Autodesk MapGuide Author

124

The setup program for Autodesk MapGuide Author installs the software in a
separate directory and program group specifically for this release. If you have
more than one release of Autodesk MapGuide Author installed at the same
time, you can try out the new release while still running the previous release.
You can also uninstall older releases without affecting the current release.

Note Before you install Autodesk MapGuide Author, log on to Windows as an
administrator or as a user who has administrative privileges. If you are using
Windows® 2000, you must have Power User/Administrator rights to install
Autodesk MapGuide Author. This is required for the installation process only; you
can log on with any privileges to run Autodesk MapGuide Author after you have
installed it.

To install Autodesk MapGuide Author
1 Insert the Autodesk MapGuide CD in the CD-ROM drive.

Note If the installation does not start automatically when you insert the CD
in the drive, click the Start button on the Windows Taskbar and then choose
Run. In the Run dialog box, enter e:\setup, where e: is your CD-ROM drive.

2 On the CD Browser screen, click Autodesk MapGuide Author Products.
3 In the Autodesk MapGuide Author Release 6 Setup dialog box, click Next.
The Software License Agreement dialog box appears.

4 Select your country of residence from the drop-down list, click I Accept to
accept the license agreement, and then click Next.

5 When the setup program prompts you to enter your serial number and
authorization code, do one of the following:

m If you are installing an evaluation copy, you do not need to enter a
serial number or authorization code. Click OK.

m If you are installing a registered copy of the software, enter your serial
number and authorization code, and then click OK. Your serial number
is the 11-digit number located on the Autodesk MapGuide package. For
instructions on obtaining an authorization code from Autodesk, refer
to the Read This First card included with your product documentation.
Note that if you are upgrading from a previous release, you will need a
new authorization code for Autodesk MapGuide Release 6.
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6 When prompted, accept the default installation directory, or click Browse
to specify a different directory.

If there are coordinate system (CSMap) files installed on your machine
from a previous version of Autodesk MapGuide®, you are prompted to
retain the existing CSMap files or update them.

7 Click Next to install Autodesk MapGuide Author, and when prompted,
click Finish.

If you do not enter your serial number, the product will be installed as an
evaluation copy. You will then have 30 days to try out the program, after
which it will expire unless you purchase the product and enter a serial
number and authorization code. During the 30-day evaluation period, the
Authorization Reminder dialog box will appear every time you start Autodesk
MapGuide Author. From this dialog box, you can access the dialog box in
which you enter your serial number and authorization code.

Starting Autodesk MapGuide Author

To work with your map, you need to gain access to your server (for example,
log on to your network so that you have access to the server) before you start
Autodesk MapGuide Author. If you do not currently have access to Autodesk
MapGuide® Server, you can still start Autodesk MapGuide Author, but you
will be limited in what you can do. For example, you will not be able to access
any databases or browse for spatial data located on other machines.

To start Autodesk MapGuide Author and create a new map

1 Click the Start button, and then choose Programs » Autodesk MapGuide
Release 6 » Autodesk MapGuide Author.

The program window appears. You can now open an existing map or
Create a new one.

2 Choose File » New.
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Autodesk MapGuide Author opens a new Map Window File (MWF) of the
world.

-l Popup

0 object(s) selected 1: 215,085,082 122,987 % 20.228 [mi)
[ Z

About Map Window Files and Map Window XML
Files

Autodesk MapGuide Author enables you to store each individual map as a
Map Window File (MWF) or in XML format as a Map Window XML File
(MWX).

MWTFs contain the specifications of the map window in binary format.
MWXs contain the specifications of the map window in text format using
XML element tags, or nodes. Both MWFs and MWXs contain map informa-
tion such as the map boundary, the background color, data source informa-
tion (SQL databases, SDFs, and raster image files), layers of cartographic data
(such as roads and countries), layer display information (such as attributes
and visible scales), and map display configuration specifications (such as
menus and legends).

MWFEs can only be modified using Autodesk MapGuide Author. MWXs can
be modified using Autodesk MapGuide Author or any XML parser. You can
use the Dynamic Authoring Toolkit to perform conversions between these
file formats. For more information about the Dynamic Authoring Toolkit,
refer to the Dynamic Authoring Toolkit Developer’s Guide.
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Introduction to the Program Window Layout

Menu bar — & g

The program window is designed to maximize the amount of space used for
displaying the map while still providing easy access to the Autodesk
MapGuide Author commands.

1, Autodesk MapGuide Author - [Map1]
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Viewer legend
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Map Explorer Status bar displays information about current map

Using the Map Window Popup Menu

The map window popup menu, which appears in both Autodesk MapGuide
Author and Autodesk MapGuide Viewer, provides quick access to the default
commands. You use the commands in the popup menu to modify map prop-
erties, move around on a map, or get information about map features. As a
map author, you can modify the popup menu to show or hide functionality
in Autodesk MapGuide Viewer. You can customize all but the first item on
the popup menu by adding or deleting commands, or by modifying the
actions assigned to specific commands. For more information, see “Custom-
izing the Popup Menu” on page 148.
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Note Changes that you make to the map window popup menu in Autodesk
MapGuide Author will also appear in the Autodesk MapGuide Viewer popup
menu for this map.

Right-click in the map to display the map window popup menu.

Properties. ..

Fan
FrelEad

Frint

Copy
Zoom
Bookmarks
Select
Wiew

Help

The following list summarizes the commands in the default map window
popup menu:

Popup Menu Commands

This command... Does this...

Properties Displays the Map Window Properties dialog box,
where you can specify the name, location, and
coordinate system of a map file, set up reports,
specify locations that can be zoomed to by name,
customize the popup menu, and assign a pass-
word to the map. This command does not appear
in Autodesk MapGuide Viewer.

Pan Moves the map to display areas that are outside
the current view. Drag the hand cursor to move a
different area of the map into view.

Reload Reloads the map from the last saved version. This
option discards any changes that have not been
saved.

Print Accesses the Print commands, which you can use

to customize the print layout (Page setup com-
mand) or print the map (Print command).
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Popup Menu Commands (continued)

This command... Does this...

Copy Copies the current map view to the Clipboard as
an Enhanced Windows Metafile (EMF). Programs
that cannot display Windows metafiles (WMF) will
not be able to use the files from the Clipboard. If
you use the Copy command when the Design tab
of the Map Explorer has focus, the currently
selected layers or layer groups are copied to the
Clipboard.

Zoom Accesses the Zoom commands, which you can
use to magnify specific areas of the map or zoom
out. For more information about zooming and a
list of the Zoom commands, see “Moving Around
on a Map” on page 133.

Bookmarks Accesses the Bookmark commands. You can use
these commands to add a bookmark for the cur-
rent view to the Bookmark menu (so that you can
quickly access this same view of the map again),
select a bookmark, or delete existing bookmarks.

Select Accesses the Select commands, which you can use
to select features on the map in various ways.

View Accesses the View commands, which you can use
to view a report, create buffers, or measure dis-
tances on the map.

Help In Autodesk MapGuide Author, accesses the Help
commands, which you can use to set preferences
for the map window, access the Autodesk
MapGuide Help contents, and view version and
copyright information for Autodesk MapGuide
Author. In Autodesk MapGuide Viewer, the Help
commands are specific to Autodesk MapGuide
Viewer.

All of the commands in the popup menu are also available from the menu
bar, and many of the same commands are available in the toolbar.
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Using the Toolbar

You use the toolbar to access the most commonly used commands. To use the
toolbar, simply click a button to perform that command.

IEEEEER SRS

The following table lists each toolbar button, its associated command, and a
brief description of the action that results.

Toolbar Buttons

Button = Command Description
New Creates a new map, starting with a map of the world.
Open Opens an existing map file on a local or network drive.
Save Saves the current map.
Properties Displays the Map Window Properties dialog box, where

you can specify the name, location, and coordinate sys-
tem of a map file, set up reports, specify locations that
can be zoomed to by name, customize the popup
menu, and assign a password to the map.

Print Prints the current map view.

B Copy Copies the current map view to the Clipboard as an

Enhanced Windows Metafile (EMF). Programs that can-
not display Windows metafiles (WMF) will not be able
to use the files from the Clipboard. If you use the Copy
button while the Design tab of the Map Explorer is
active, the currently selected layers or layer groups are
copied to the Clipboard.

Select Selects features in the map.
Pan Moves the map around in the map window to display
areas that are outside of the current view.
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Toolbar Buttons (continued)

Button Command Description
Zoom Zoom:s in to a specified rectangular area of the map, or
X to a specified center point by a magnification factor of
two.
Zoom Out Zooms out by a magnification factor of two and centers

A

the view at the point you click.

Zoom Previous

3]

Returns to the previous zoom magnification and loca-
tion.

Zoom Goto Zooms to a specified location.
Unzoom Redraws the map so that Autodesk MapGuide Author
X displays the full extents of the map in the current
window.
Stop Stops or interrupts Autodesk MapGuide Author from
updating the map display.
. Reload Reloads the map from the last saved version. This
@ option discards any changes that have not been saved.
. View Report Lists reports available for the current view or selected
El features.
Help Starts the Autodesk Mapguide Help, where you can get
information about working with Autodesk MapGuide

Author.

By default, the toolbar buttons are displayed in a small size without text. If
you prefer, you can display the buttons with their names for easy reference.
See the next section, “Setting Preferences,” for more information.
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Setting Preferences

Help Index You can customize Autodesk MapGuide Author by specifying preferences for

preferences toolbar button size, map units, status bar display, and more. When you
change the preferences, the new settings apply to all currently open maps, as
well as to all maps you open after setting the preferences. You open the Pref-
erences dialog box by choosing File » Preferences.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “preferences.”

™ Large buttons with test V' Open first window maximized E
[~ Open maps in & new window Cancel | Click for details
Map units: Selection mode: Help | 1 about the
- - options in this
US4 Units - Centraid - .
I = = dialog box.
Status bar
™ Display mouse position
Units:
ILatitude, Longitude j
Home page map location:
ID:\Program Filez\Autodesk W apGuideduthorByWWwFST emplate_‘world_LL. rwvef j
Drefault symbol and text size unit:
’7 &' Constant size screen units " Mapping coordinate system units
Opening a Map
Help Index Autodesk MapGuide Author can open maps saved as Map Window Files
opening maps (MWF) and Map Window XML Files (MWX) in the following ways:

m Open a map located on a local or network drive using the File » Open
command

m Download and open a map from a Web server using the File » Open
Location command

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “opening maps.”
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Moving Around on a Map

You use the zoom and pan commands to move around on a map. To access
these commands, right-click in the map window to display the map window
popup menu. You can also access these commands from the Edit menu.

Autodesk MapGuide Author downloads additional layer data from the server
when the zoom and pan commands display new areas or layers of the map.
You can click Stop or press ESC to interrupt a data download.

Pan and Zoom Commands

Command

Description

Pan

Moves the map to display areas that are outside the current
view. Drag the hand cursor to move a different area of the map
into view.

Zoom » Zoom

Increases magnification by a factor of two or zooms in to a spe-
cific area of the map. To magnify by a factor of two, click a point
on the map to indicate the center of the magnified area. To
zoom to a specific area, drag a rectangle around the area, and
then release the mouse button to zoom to the enclosed area.

Zoom » Goto

Zoom:s to a specified location. Select a category, enter the name
of a location, and then specify the width of the area you want to
view. Autodesk MapGuide Author zooms to the specified width
using the specified location as the center of the map.

Zoom » Width

Zooms to a specified width on the center of the current view.

Zoom » Scale

Zooms in or out to a specified scale, retaining the current center
of the map.

Zoom » Selected

Zooms to an area just large enough to enclose the selected map
features.

Zoom » Previous

Redraws the map at the previous zoom level and location.

Zoom » Out

Zooms out by a magnification factor of two. Click a point on the
map to zoom out and recenter the map on the point you
clicked.

Zoom » Unzoom

Redraws the map so that Autodesk MapGuide Author displays
the entire map.
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Zooming to a Location

Help Index When you zoom to a location, you specify the category of the location you
zooming want to view (such as museums, parks, airports, etc.) and then type the name
to a location of the specific location you want to see. Autodesk MapGuide Author looks up

the location and zooms to it. The categories of locations that are available
depend on the way the map was authored.

You use the Location tab of the Zoom Goto dialog box to zoom to a specific
location. To open this dialog box, choose Edit » Zoom Goto, and then click
the Location tab.

Location | 1S Street Addressl

Category : |us Place [~

Lacation : INew ok,

Zoom to width : |1 i} [mni]

Select a category then enter a location to goto...

Click for details about the
Ok ] Corcsl | e | options in this dialog box.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “zooming, to a location.”

Zooming to a U.S. Street Address or ZIP Code

Help Index If the map was authored to include a United States geocoding database, you
zooming can type in a street address or ZIP code and zoom right to it on the map. You
to an address use the US Street Address tab of the Zoom Goto dialog box to zoom to a U.S.

street address or ZIP code. To open this dialog box, choose Edit » Zoom
Goto, and then click the US Street Address tab.
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Help Index

bookmarks

Location U5 Street Address |

Address:

City: I

State: I

ZipCode:  [94903

‘ Zoom to width |4.D [mni] ‘

[&ddress, City, and State] or [Zip Code] must be specified.

Zip Code may be zzzzz, 222224444, or zzzzz-4444.

Click for details about the
Ok | _ Corcsl | Heb |- options in this dialog box.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “zooming, to a US street address.”

Using Bookmarks to Save the Current Map View

After you have panned and zoomed to get the exact view of the map you
want, you can add a bookmark to save the current view. In the future, when
you want to get to this view again, you simply choose the bookmark instead
of panning and zooming all over again. This can save you time and effort.

You create a bookmark by choosing Bookmarks » Add Bookmark. Note that
the name you type or select for your bookmark cannot contain any
commas (,), question marks (?), ampersands (&), or pound symbols (#).

For step-by-step instructions on using bookmarks, choose Help » Contents,
click the Index tab, and look up “bookmarks.”

Using the Map Explorer

The Map Explorer, which appears on the left side of the Autodesk MapGuide
Author window, contains the Design tab and the View tab. Both tabs display
the layers and layer groups in the map. As you design and create maps, you
work in the Design tab. You use the View tab to get an idea of what users will
see when they view your maps in Autodesk MapGuide Viewer. For informa-
tion about layers and layer groups, see Chapter 9, “Working with Map
Layers.”
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Select a
check

Using the Design Tab

The Design tab of the Map Explorer lists the names of all layers in the map
and their display ranges. Display ranges contain style information for a
specific display range. For more information, see “Specifying Display Ranges
for Layer Styles” on page 164. The layer and layer group names are always
listed in the Design tab, even if the layer or layer group is not currently
displayed. The Design tab also lists the reports and zoom goto definitions in
the map and gives you easy access to customize the popup menu.

@ Zoom Goto 15 Shest Address
= % Map La}lers

box to
change a
layer or a —|
layer
group'’s

default

[ == major city names
== |US capitals
-0 == major cities

[+] [+] US cemsus hacts
[3-- = IS States

visibility.

- |£] Reports
EICQ Zoom Gotos

‘3? Airparts

- %2 1S Place

C@ LS Street Address
- £ wiehsite

C@ Zipcode

j Fopup Menu

Layers that are available at the current scale are listed in the legend in black,
and those that are unavailable at the current scale are dimmed (gray).

The check boxes in front of the layer names indicate whether or not the
available layers are visible by default when the layers are within the current
display range. You can turn a layer’s visibility on or off simply by clicking its
check box.

Selected layers are highlighted. When a layer is selected, you can remove,
save, delete, compress, or expand it, or change its properties. You can also
drag and drop layers to move them. By pressing CTRL as you drag and drop,
you can quickly make copies of layers.

If the data for a layer cannot be retrieved, the layer is displayed as shown in
the following illustration:

) <% Major Roads This icon indicates that there was an error retrieving the
data for the layer.
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To select layers
Do one of the following:

m To select a layer, click the layer name.

m To select multiple contiguous layers, click the first layer, and then

SHIFT-click the last one.

m To select multiple non-contiguous layers, click the first layer, and then

CTRL-click each additional layer.

To deselect layers

Do one of the following:

m To select another layer instead of the currently selected layer, click the

other layer.

m To deselect a single layer in a group of selected layers, Ctrl-click a layer that

is already selected.

Using the View Tab

As you are creating a map or after you have finished creating a map, you can

use the View tab to see how the map’s legend will appear in Autodesk

MapGuide Viewer. This can help you verify that you have created your layers
as you planned. You can turn layers and layer groups on and off from the

View tab by clicking the check box next to a layer or layer group name.

< major cities
L

= IS capitals
+

< major city names
A

== LS States

Note The default width of the View tab is 275 pixels while the default width of
the Viewer legend is only 150 pixels. This means that text that appears in full on
the View tab may be truncated in the Viewer. To get an exact idea of how your
maps will appear in the Viewer, be sure to open your maps in Autodesk

MapGuide Viewer.

You can select layers and layer groups in the View tab just as you do in the

Design tab.

Using the Map Explorer
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Changing the Width of the Map Explorer

In either the Design tab or the View tab, you can make the Map Explorer
wider or narrower. If layer names are too long to display at the current Map
Explorer width, you may want to widen it. If you do not need the current
width of the Map Explorer to display layer information, you may want to
narrow it to display more of the current map.

To resize the Map Explorer

m Drag the vertical bar between the Map Explorer and map area left or right.

As you drag the vertical resizing bar right or left, the status bar displays the
width in pixels so that you can set the Viewer legend to a specific width.

Viewing Map Information

You can easily get information about the map as well as about individual
features on the map. The status bar displays information about the map. For
example, it displays the current map scale, width, and height, as shown in
the following illustration.

@ Ghiragdelli Square

Scale ——1: 6,809 |2510.3 2 25471 [ff] —F4—— Width and height
I 7
Help Index The status bar also displays information about individual features on the
MapTips map. When you point with the mouse to a map feature, the status bar

displays the feature’s layer followed by the feature’s name. Additionally,
Autodesk MapGuide Author displays the feature name in a yellow MapTip
popup that appears when you move the pointer over the feature. If the
feature is unnamed, the layer and feature name area of the status bar remains

blank, and no MapTip appears.
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Q Hotel / Motel
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Wwieb Sitez : Ghirardell Square

MapTip displays the
feature name.

Ghirardelli 5 quare

@ Ghirard

|EI object(z] zelected

Help Index

linked documents
displaying

If the feature under the pointer is linked to a Web document, the pointer
changes from an arrow to a hand, and Autodesk MapGuide Author displays
the URL of the linked Web document on the status bar. You can then double-
click the feature under the pointer to load and display the linked Web
document.

If the linked document does not appear when you double-click the pointer,
you may need to configure your browser to display linked documents.

Finarnice / Banking
Festraurant or Mig...
Government Buildi...
Health Care Facility
Hatel # Matel

Internet Teu:hnu:ulu:ugy_l

Mational Maritime kuzeum

|D object(z] selected

Hand pointer
L indicates a linked
Web document.

Ili Sqquare

i

Wwieh Sitez : Mational b aritime Muzeumn URL for linked

[ Web document

http: / fartdirect. camdcaliformialzan. francizco/muzeums/sbay/homepage

Measuring Distances

Help Index

measuring distances

You can easily measure the distance between points on a map. When you
measure the distance between multiple points in succession, you can view
the distance between each segment you measure as well as the cumulative
total of all segments measured.

For each map you create using Autodesk MapGuide Author, you can specify
whether to use the Euclidean or Great Circle formula for measuring
distances. If your map uses arbitrary XY coordinates, you must use the
Euclidean formula. For maps using geographic coordinate systems, distance
measurements will be more accurate if you use the Great Circle formula. You
specify which distance formula to use in the General tab of the Map Window
Properties dialog box.
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Note Depending on the map’s coordinate system and the area displayed
(smaller areas tend to be more accurate than larger areas), distances may not be
accurate. To improve the accuracy of distances, you can select a coordinate sys-
tem that has accurate or partly accurate distances, keeping in mind that the areas
will then appear distorted.

You use the View » Distance command to measure distances.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “measuring distances.”

B = World DEM
=S Visible at all soales

| Reports

City Repart
¥ Zoom Gotos

C@ ‘world Country
C@ Wworld Place
j FPopup Menu

Design I Wiew I

Mational Capitals : Bern, Switzerland

Distance: 373 (mi)
Total: 373 (mi)

|D feature(z] selected

In the previous illustration, Autodesk MapGuide Author displays the
distance between Paris and Bern, 373 miles, in the yellow MapTip popup.
Because only one segment was measured (the distance between two points
only), the total distance is the same as the distance of the segment.

Selecting Map Features

Help Index

selecting map features

When you select features on the map, you can then view a report that
provides information about the selected features, or you can adjust the map
display to zoom to the selected features. The number and type of selected
features are displayed on the status bar at the bottom of the map.

You can select map features only if you enable the Make Map Features Select-
able option on the General tab of the Map Layer Properties dialog box. For
more information, see “Specifying General Properties for Layers” on

page 159.

Note When you select a map feature, Autodesk MapGuide Author selects the
feature by its key. Therefore, if you select a map feature that contains multiple
points, each of which has the same key, each of those points will be selected. Sim-
ilarly, if there are multiple features in the map with the same key, selecting one of
those features will select all features that share that same key.
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You can select map features in several different ways:

m Use the mouse to select features.

m Use one of the options on the Select menu.
You can also combine multiple selection techniques.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “selecting map features.”

Note If a map includes multiple selectable polygon layers, some selection tech-
niques (such as Select » Radius, Select » Polygon, Select » Within, and using
the mouse to drag a rectangle around map features) will select features from all
selectable layers. When selected features on different layers overlap one another,
the selection color for each layer varies depending on how many features overlap.
Portions of unselected map features also change color if a feature in a layer
beneath them is selected. These color changes differentiate the different layers.

Creating Buffers Around Map Features

Help Index A common GIS spatial query involves finding all features within a specified

buffers distance, or a buffer, of one or more other features. A buffer is a polygon that
defines its boundaries at a specified distance from a point, line, or another
polygon. For example, you could locate all customers within one mile of a
number of store locations. As part of this query, you might also want to see
the area that defines the spatial query. Autodesk MapGuide Author can create
buffer zones around one or more selected features. You can then select
features that fall within these buffers.

You use the View » Buffer command to create buffers.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “buffers.”
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page setup

printing maps

Printing a Map

Although most users work with maps almost exclusively online, it is very
useful to be able to print out a map. If you are authoring a map, you might
want to print it out, to verify that it looks the way you want it to look, before
publishing it online. Or, if you are working with the map to answer specific
questions, such as determining the best location for a new store or substa-
tion, you might want to print out the map that accompanies a report you
generated to present to others on your team.

You can customize your printed maps by including a title, a legend, a scale
bar, a North arrow, the map’s URL, and the current date and time. Also, you
can specify the scale of the map you want to print, or you can have

MapGuide automatically scale the map to fit the printed page.

You use the File » Page Setup command to specify how to print your map.
For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “page setup” and “printing maps.”

Pagesoy &)

~ Include

ok |

Vi

)

v Legend v URL

V' North maw

IBa_l,l Area Demographics

[+ Scale Bar [+ Date and Time

—Map Size

& Fit to Page
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Cancel |
Help |

Frint Setup...
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Creating and Publishing a Map

This chapter explains how to create, save, and publish a
map, including details about setting passwords, specify-
ing a coordinate system, and working with Zoom Goto
location categories. It also includes information about
customizing the Map Window popup menu, working
with reports, and keeping track of how and when users

access your map.

This chapter may be especially helpful to:

m  Map authors

M

[

In this chapter

Creating a new map

Specifying a coordinate
system

Specifying a password to
protect a map

Creating and modifying
Zoom Goto location
categories

Customizing the popup
menu

Working with reports

Tracking user access to a
map

Saving a map

Publishing a map
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Creating a New Map

Help Index
maps
creating

Help Index

newmap.mwf

To create a new map, you start with either the map of the world or another
existing map. To create a new map, you can use one of two methods:

m Open the map of the world using the File » New command, specity the
area and settings you want, and then save it as a new map. Use this
method if you do not have any existing maps, or if you need to create a
map of a larger area than your existing maps.

m Open a map of the specific area you want using the File » Open com-
mand, make modifications, and then save it as a new map. Use this
method if you want to create a map that is similar to an existing map and
uses the same area or a smaller area within it.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “maps, creating.”

Changing the File to Use for New Maps

By default, the map of the world shown in the illustration on page 125 is the
basis for any new map you create using the File » New command in
Autodesk MapGuide® Author. The file used to create new maps is called
Newmap.mwf. If you prefer to start with a different map for all new maps that
you create, you can do so by saving your own map as Newmap.mwf, over-
writing the default new map. For more information, choose Help »
Contents, click the Index tab, and look up “newmap.mwf.”

Specifying a Coordinate System

Help Index
coordinate systems
specifying

144

The coordinate system you use determines which projection, center, and unit
of distance measurement you will use for this map. The default coordinate
system is World-Miller, which is an appropriate coordinate system for a map
of the entire world.

Specifying the correct coordinate system is a critical part of setting up the
map. Even if you created the map based on an existing map, you should still
verify that the coordinate system you are using is right for your purposes,
particularly if you are using a much smaller area than the original map. For
more information about how to choose an appropriate coordinate system,
see “Choosing a Coordinate System” on page 119.
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When you open a map that was created in Release 5.0 or earlier, it is a good
idea to reselect the coordinate system to ensure that you take advantage of
any fixes that were made in this release. By reselecting the coordinate system,
you update the map projection with the new information in this release.

You use the Coordinate System tab of the Map Window Properties dialog box
to specify a coordinate system.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “coordinate systems, specifying.”

Specifying a Password to Protect a Map

Help Index

passwords
setting for maps

You can secure your maps by assigning passwords to them. Using passwords
prevents other Autodesk MapGuide Author users from opening a proprietary
Internet-published map and accessing the information stored in its MWF file.
When you assign a password to a map, users must enter the correct password
each time they open the map.

Warning Don’t forget your password! Autodesk MapGuide Author has no
mechanism for accessing passwords, so assign them thoughtfully and record
them in a secure location.

You use the Security tab of the Map Window Properties dialog box to specify
a password for a map.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “passwords, setting for maps.”

Note You can also secure your maps by assigning access control keys to each
layer. For information about doing this, see “Specifying Security for Layers” on
page 173. Furthermore, you can assign access keys and passwords to the
resources themselves, so that all maps that use those resources require an access
key or password. See “Using Autodesk MapGuide Security” on page 51 and
“Managing Server Security” on page 80 for more information.
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Creating and Modifying Zoom Goto Location
Categories

Before you can zoom to specific map locations using the Zoom Goto

Help Index function, you need to set up Zoom Goto location categories for your map.

7 P . Each Zoom Goto location category includes the information required by

oom Goto location 1 ® . X

categories Autodesk MapGuide™ Server to look up locations in an SQL database. When
Autodesk MapGuide Server finds one or more matching locations, it returns
the associated coordinates to Autodesk MapGuide Author or Autodesk
MapGuide Viewer, which zooms to the specified location.

For example, if you have a database containing the coordinates for each
country in the world, you could create a category called “World Country.”
This would allow users to zoom directly to a country simply by typing the
name of the country in the location box. Adding location categories to your
map can save users a lot of time.

You can create, modify, and delete zoom location categories using the Zoom
Goto tab in the Map Window Properties dialog box. Note that you cannot
delete the US Street Address category.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “Zoom Goto location categories.”
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Data Source Formats for Zoom Goto Location
Categories
To use a data source for a Zoom Goto location category, it must contain five

specific types of data in separate fields. These fields are described in the
following table:

Field Type of Data It Contains

Location name The name to display if one or more features have been
found that match the query you specify.

Minimum latitude The minimum latitude for polylines and polygons, or
the latitude location for points. For arbitrary XY coordi-
nates, this field should specify the minimum Y value.

Minimum longitude The minimum longitude for polylines and polygons, or
the longitude location for points. For arbitrary XY coor-
dinates, this field should specify the minimum X value.

Maximum latitude The maximum latitude for polylines and polygons, or
the latitude location for points (same as minimum lati-
tude for points). For arbitrary XY coordinates, this field
should specify the maximum Y value.

Maximum longitude The maximum longitude for polylines and polygons, or
the longitude location for points (same as minimum
longitude for points). For arbitrary XY coordinates, this
field should specify the maximum X value.

Following are some important notes about the data in these fields:

m When you specify the location for a point, the minimum longitude and
latitude are the same as the maximum longitude and latitude. Therefore,
when the user selects this zoom location, the Width that the user specifies
(if any) is used. If the minimum longitude and latitude are different from
the maximum longitude and latitude, the Width that the user specifies is
ignored.

m The Location name field must not contain any special characters, such as
“\n” for forcing a new line. This can cause conflict if you have only one
name field that you want to use for both location names and feature
names, and you want to include newline characters to create multi-line
MapTips from the feature names. In this case, you should add a second
field for use as feature names in MapTips that contains the same name
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Zoom Goto location
categories
US Street Address

information and includes newline characters, while excluding newline
characters in the first field that will be used for location names.

The US Street Address Location Category

Autodesk MapGuide Author comes with a predefined location category
called “US Street Address.” When you activate this category, you access a
geocoding database that contains U.S. street addresses and their coordinates,
so that your users can type an address or ZIP code and zoom directly to that
location on the map.

To use this feature, you must have a U.S. street address geocoding database
licensed to Autodesk MapGuide Server. For more information, see 150.

To see an example of how to set up the US Street Address location category,
choose Help » Contents, click the Index tab, and look up “Zoom Goto loca-
tion categories, US Street Address.”

Customizing the Popup Menu

Help Index
popup menu
customizing
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The Map Window popup menu provides quick access to Map Window
commands from the menus and toolbar buttons. You can customize all but
the first item on the popup menu by adding or deleting commands, or by
modifying the actions assigned to specific commands. The changes you
make to the popup menu in Autodesk MapGuide Author will appear when
users view your maps using Autodesk MapGuide® Viewer. If you have your
own online Help system that you want to use for your Autodesk MapGuide
Viewer, you can specify it in the popup menu.

Note The first item on the menu is always Properties in Autodesk MapGuide
Author; however, Properties does not appear on the menu in Autodesk
MapGuide Viewer.

You use the Popup Menu tab of the Map Window Properties dialog box
to customize a map’s popup menu.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “popup menu, customizing.”
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Working with Reports

Help Index

reports
adding to maps

You can design customized reports for your map. When you link a report to
a layer, an Autodesk MapGuide Viewer or Autodesk MapGuide Author user
can select features on that layer and then generate a report for those selected
features. You can also add reports that are not linked to any layer, so that
when the user clicks a point on the map, the report is generated for that
point. Reports can include data such as population, total sales, a URL link to
a related Web page, or any other data you want to associate with a feature.

To design a report, use ColdFusion® by Macromedia or another third-party
network database connectivity and reporting tool, such as Active Server
Pages (ASP). Specify the data to retrieve for the selected map feature keys and
the output format for the report, and then place the report on your Web data-
base server. For information about designing reports, refer to the documen-
tation that came with the reporting tool you are using.

In addition to the report itself, you need a data source that contains the infor-
mation you will use in the report. Each record in the data source must either
contain a key that matches the key of the spatial feature to which you want
it linked, or it must contain coordinates in latitude/longitude format. For
more information, see “Specifying Data Source Properties for Layers” on
page 160.

To add the report to your map, use Autodesk MapGuide Author to specify the
report properties, which include a name for the report, the URL location of
the report, the map layers that may access the report, and any optional
parameters to be sent with the report request.

When users view a report, Autodesk MapGuide Author or Autodesk
MapGuide Viewer sends a request to the URL defined for that report. The
report engine then creates the report for the selected features or points.

When you have designed a report and have data for the report, you can add
the report to your map. You use the Reports tab of the Map Window Proper-
ties dialog box to add reports.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “reports, adding to maps.”
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viewing

Viewing a Report

When users want to view a report, Autodesk MapGuide Author or Autodesk
MapGuide Viewer sends a request to the URL defined for the report, sending
as parameters the map feature keys that you specified and any optional
parameters defined for the report. The report engine extracts the data from
sources on the server, creates the report, and then sends it either to the user
or somewhere else, depending on how the report was designed.

You use the View » Report command to view a report for selected features or
for a specific point you click in the map.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “reports, viewing.”

Tracking User Access to a Map

Help Index
tracking ID

To keep track of access to your map, you can set a tracking ID that is stored
with the map. When users access a map that has a tracking ID, every action
they perform (such as panning or zooming) can be logged by Autodesk
MapGuide Server. Using Autodesk MapGuide Server Admin, you can then
run a report to monitor usage based on the tracking ID. This can be useful,
for example, if you want to charge customers for using your maps.

You use the Security tab of the Map Window Properties dialog box to
specify a tracking ID for a map.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “tracking ID.”

Saving a Map

Help Index
saving
maps
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Saving your map as a Map Window File (MWF) is the last step in creating
your map. However, as with all software applications, it is a good idea to save
periodically to avoid lost work if your system fails.

Chapter 8 Creating and Publishing a Map



Warning After you save a map in Autodesk MapGuide Release 6, you cannot
open the map in earlier releases of the program. Autodesk MapGuide Viewer
users using older versions can easily upgrade to Release 6 by downloading the
new Viewer from:
http://www.autodesk.com/prods/mapguide/download/index.htm

If you opened the map using its Web URL by choosing File » Open Location
instead of File » Open, you can save the map locally, but you cannot save it
to the Web server. You can save the map to the Web server only if you
opened the map using File » Open, you have access to the Web server
through a network, and you have the proper permissions set up. For more
information about setting permissions, refer to “Creating and Modifying
Users and Groups” on page 83.

You use the File » Save, or File » Save As commands to save maps.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “saving maps.”

Publishing a Map

Help Index
publishing maps

Help Index

linking and embedding
maps

You can publish a map by copying or uploading the map to your Web server.

Note You must have either FTP access or Write access to the maps directory. If
you are not able to save the map to the Web server, you should ask your server
administrator to post it for you.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “publishing maps.”

After you have posted the map, Web site developers can embed your map in
their HTML pages or create links to them. When a user visits a Web page that
contains your map or clicks the link to it, Autodesk MapGuide Server sends
the map data to Autodesk MapGuide Viewer, which displays the map in the
user’s Web browser. The Web developer should make a note on the Web page
that Autodesk MapGuide Viewer is required for viewing the map and should
add a link to the Autodesk MapGuide Web site where the user can download
Autodesk MapGuide Viewer free of charge.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “linking and embedding maps.”
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Working with Map Layers

Each map authored with Autodesk MapGuide® Author
contains one or more map layers. This chapter explains
how to work with layers, including creating layers, speci-
fying layer properties, protecting layers with access keys,

and saving layers.

This chapter may be especially helpful to:

m  Map authors

M

[

In this chapter

About map layers

Working with map layers in
the Map Explorer

Specifying general
properties for layers

Specifying data source
properties for layers

Setting style properties for
layers

Specifying security for layers

Modifying multiple layers
simultaneously

Saving a layer

Adding a saved layer to the
current map

Rebuilding a layer or layer
group

Deleting a layer or layer
group
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About Map Layers

154

Layers are like separate transparent sheets on which your map data is drawn.
Every map generally contains a minimum of one layer, but because layers are
so useful for organizing and working with your data, a map typically will
contain several layers. At minimum, you must have a separate layer for each
type of data you use in the map. You cannot display points and polygons on
the same layer, for example.

You can create a layer and use it for a specific map, or save it as a separate
Map Layer File (MLF) and use it in several different maps. A map can contain
multiple layers of the same type, such as multiple polygon layers, each of
which you can set up independently of the others. You can also create collec-
tions of related layers, called layer groups to help you organize layers in a map.

You can create dynamic and static map layers. A dynamic layer stores only
the layer styles (such as color, style, and symbology) in the Map Window File
(MWF), not the map data, thus minimizing file size. When you access a
dynamic map layer using Autodesk MapGuide® Author or Autodesk
MapGuide Viewer, Autodesk MapGuide® Server sends the map data for the
layer on demand. As you zoom in and out on the map, Autodesk MapGuide
Server sends the data for the visible area only, not for the entire map.
Dynamic layers are most appropriate for medium to large data sets and for
maps that cover a large area.

A static map layer stores a snapshot copy of the layer data for the entire Map
Window and embeds it in the map file. Because all of the data is already in
the map, the layer takes a little longer to load, but zooming in and out is
faster than with dynamic layers, because no additional data needs to be
downloaded from the server. Note that if you change the map’s default center
and size or map projection, Autodesk MapGuide Server must rebuild all static
map layers, as it does with dynamic layers. Static map layers are most appro-
priate when the data set does not change often, the size of the data set is rela-
tively small, and the map covers a small area. Also, because the data is
contained within the map itself, static layers are best used when data security
is not an issue.

Autodesk MapGuide Author draws layers in order of increasing priority
starting with priority O, then priority 1 on top of layer priority 0, and so on,
until it draws the layer with priority 100 last, on top of all other layers. The
drawing order is reflected in the Autodesk MapGuide Viewer legend and in
the Map Explorer, where the layer with the lowest priority is at the bottom
of the list, and the layer with the highest priority is at the top of the list.
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For information about changing a layer’s priority, see “Specifying General
Properties for Layers” on page 159.

In Autodesk MapGuide Author, there are two main types of layers: vector and
raster. Vector layers contain spatial data that is made up of points and lines,
such as cities, countries, and roads. Each vector layer can contain only one
type of vector data, either text, points, polylines, or polygons. Raster layers
contain spatial data that is made up of tiny squares (pixels) that form an
image. An aerial or satellite photograph is a typical example of a raster image.
Most of the layers you create will probably be vector layers, which you might
place over a single raster image that you use as a background image.

If you have Autodesk® GIS Design Server theme data and the Autodesk GIS
Design Server Extension, you can create Autodesk GIS Design Server theme
layers. If you have Oracle® Spatial data and the Autodesk MapGuide Provider
for Oracle Spatial, you can create Oracle Spatial layers. If you have Autodesk
DWG files, you can automatically create Autodesk DWG layers. If you have
ArcView SHP files and the Autodesk MapGuide Provider for SHP, you can
create ArcView SHP layers.

Working with Map Layers in the Map Explorer

To work with map layers, you use the Design tab of the Map Explorer in
Autodesk MapGuide Author. Layers are listed under the Map Layers item.
Layers can be part of a layer group, such as the Cities layer group in the
following illustration.

(& Zoom Goto US Strest Address

EI% Map Layers
=) Layer group

Wl = majar city names—l

= S capitals Map layers

O == majar cities J

[+ [ US census tracts

[+- B == US States

Reports

= Zoom Gotos

C@ Airports

U5 Place

C@ US Street Address

C@ ‘website

C@ Zipcode

ﬂ FPopup Menu
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When you right-click a layer in the Design tab of the Map Explorer, the map
layer popup menu appears, as shown in the following illustration. You use
the commands in the map layer popup menu to create, modity, or manipu-
late the layers in a map.

@ Zoom Goto S Street Address
=1 88h Map Layers

FProperties

Mew Layer 3
Mew Layer Group...

Bt Cut The map layer popup menu appears

0 ZoomGotos  Copy when you right-click a layer.
i C@ Airports Faste
& US Place
(;Q S Street  Save as Map Layer File...

&2 ‘website Bemove
¢ Zipcode ~ Rsbuid
ﬂ FPopup Menu |

You create new layers in the Design tab of the Map Explorer, using one of the
commands in the New Layer submenu in the map layer popup menu.

Properties |

[ey er Text

Mew Layer Group... Paint

Palyline
Cut
- Polygon
S Aukodesk WG
Paste .
Autodesk GIS Design Server Theme
Save as Map Layer File... Raster
Remove
Rebuild

Creating a Vector Layer

You can create four types of vector map layers—text, point, polyline, and
polygon. Each layer can contain only one map feature type.

You create vector map layers from spatial data provider (SDP) data sources; if
you are creating point or text layers, you can also create them from points in
a SQL database table that you have set up as an OLE DB data source. You can
also use SQL database tables to link style information to the features in a
layer. For example, you could link a layer of roads to a table that provides
each road’s name, length, and last date paved. You could then create a theme
to display the data and quickly see which roads need paving the most.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “vector layers, creating.”
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Another type of vector layer you can create is a buffer layer. Buffer layers are
created automatically when you use the View » Buffer command in the Map
Window popup menu; you cannot create them manually as you do with the
other types of layers. You can modify a buffer layer using the Map Layer Prop-
erties dialog box as you would with the other layers, but because buffer layers
are intended for buffers only, you can specify only a limited set of options.
For more information, see “Creating Buffers Around Map Features” on

page 141.

Creating a Raster Layer

When you add a raster map layer to a map, Autodesk MapGuide Author
assumes that the raster images are in the same coordinate system as that used
by the map file. You cannot edit raster images within Autodesk MapGuide
Author; therefore, you must project them into the map’s coordinate system
using third-party image analysis and enhancement software before you
create the raster map layers.

You can create a raster map layer by referencing either a single raster image
or a Raster Image Catalog (RIC) file. A RIC file lists all the raster image files
that tile the area covered by a map or map layer. When you access a layer that
references a RIC file, Autodesk MapGuide Server scans through the RIC file
to determine the images or portions of images that correspond to the area
being viewed. It then sends the data for that area only.

Keep in mind that the RIC file is used only to determine which images might
be visible. Each image that is referenced by the RIC file must have its own
georeferencing file that indicates how to place this image correctly on a map.
Autodesk MapGuide Author uses the information in the georeferencing file
(not the information in the RIC file) to place the images in your map.

The simplest way to generate RIC files is to use Raster Workshop, a utility
available from the Autodesk MapGuide CD. You can use this utility to create
a RIC file, add raster image files to it, subsample and merge the files, and
more. For more information, see “Working with Raster Images” on page 101.

For step-by-step instructions on creating a raster layer, choose Help »
Contents, click the Index tab, and look up “raster layers, creating.”
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Creating an Autodesk GIS Design Server Theme
Layer

If you have Autodesk GIS Design Server theme data and the Autodesk GIS
Design Server Extension, you can create Autodesk GIS Design Server theme
layers. Unlike other layer types, each feature on a Autodesk GIS Design Server
theme layer can be drawn with a different style (font, color, line style, fill
style, and so on). All display characteristics are taken directly from the
features themselves in the Autodesk GIS Design Server theme. Therefore, you
do not specity the styles for the layer, as you do with other types of layers in
Autodesk MapGuide Author, nor are the styles stored with the layer defini-
tion in the MWE

To change the styles of the map features on a Autodesk GIS Design Server
theme layer, you must change the symbology definitions of the features in
the Autodesk GIS Design Server theme on which the layer is based.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “Autodesk GIS Design Server, creating Autodesk GIS Design
Server theme layers.”

Creating an Autodesk DWG Layer

If you have Autodesk DWG files, you can create Autodesk DWG layers by
choosing New Layer » Autodesk DWG Layer from the popup menu in the
Design tab of the Map Explorer.

Autodesk MapGuide supports scale, rotation, and XY offset of drawings refer-
enced by Autodesk Map project drawings. If you want to tile a set of arbitrary
XY drawings, or if you want to scale, offset, or rotate one or more drawings,
attach the drawings to an Autodesk Map project drawing and set the appro-
priate values for the scale, offset, and rotation.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “DWG layers, creating.”
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Creating a Layer Group

To organize your layers, you can create one or more layer groups and then
add layers to the appropriate groups. The layer groups appear in the Map
Explorer. You can specify whether or not they appear in the Autodesk
MapGuide Viewer legend. One advantage of using layer groups is that you
can turn on or off all of the layers in a layer group with a single command.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “layer groups.”

Specifying General Properties for Layers

Help Index

layers
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You use the General tab of the Map Layer Properties dialog box to assign a
name to the map layer. You can also specify properties that control how it
will be listed in the legend, whether a layer is selectable, dynamic, or static,
and the drawing priority for the layer.

Map Layer Properties - US capitals [ %]

General | Data Sourcesl Styles I Securityl

Layer type: Faint
Layer name: |mm
Legend label: IUS capitals ¥ Show in Viewer legend

V' Make map features selectable

Map data
’76’ Diynamic " Static

Dirave pricrity: |3?.EDDD _I;

QK I Cancel Help
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Specifying Data Source Properties for Layers
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You use the Data Sources tab of the Map Layer Properties dialog box to specify
the data source that contains the features you want to use on this layer, the
URL of the Autodesk MapGuide Server MapAgent that will serve this data,
and additional data source properties. If you are creating a raster layer, the
Data Sources tab looks different than it does when you are creating a vector
layer. For more information, see “Creating a Raster Layer” on page 157. If you
are working with a buffer layer that you created with the View » Buffer
command, the Data Sources tab is not available.

To specify data source properties

1 Double-click a layer in the Design tab of the Map Explorer, and then click
the Data Sources tab in the Map Layer Properties dialog box.

2 Do one of the following:

m For an SDP (Spatial Data Provider) or OLE DB Data Source, select from
the Draw Features From drop-down list.

m For a DWG (Autodesk) data source, click the browse button next to the
Data Sources box.

The dialog box that is displayed depends on the type of data source you

selected.

If you choose SDP (Spatial Data Provider) Data Source, the dialog box dis-

plays two secondary tabs as shown below.

Map Layer Properties - major cities [ %]

General Data Sources | Styles I Securityl

Draw features from:

S0P [Spatial D

ata Provider] data source

[ SDP Data Source | Mame, URL, Where I

[rata zource:

Fr |

Feature table:

Icities.sdf J

Key column: Key column type:

[FEATURE_ID J [sting =]
Geometry column:

[FEaTURE_GEOM J

Map server URL:

Ihttp:.-".-"www.mapguide.c:om.-"c:gi.-"mapagent.exe j

QK I Cancel | Help |
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If you choose OLE DB Data Source, the dialog box displays two different
secondary tabs, as shown below.

| Map Layer Properties - major c I

Secondary General ['ata Sources | Styles | Securityl

tabs for OLE

DB Data Drraw features from:

Sources:

OLE DB Data OLE DB Data Source | Pasition, Size, Alignment, Hotationl

Source and [rata source: Mame column:

Position, Size, | J | J
A“g n ment/ Feature table: URL colurmm:

Rotation | J | J

Key column: Key column type:

| = |

S0L where clause:

Map server URL:

Ihttp:.-".-"www.mapguide.c:om.-"c:gi.-"mapagent.exe j

QK I Cancel | Help |

Note The Position, Size, Alignment, Rotation tab is available only for text and
point layers based on an OLE DB data source.

If you choose DWG Data Source, the following dialog box appears.

| Map Layer Properties - New Layer I

General Data Sources | Styles I Securityl

[rata zource: Autodesk DWG:

|| Ll |
Key table: Key colurmm: Key column type:

| L] ] ]
Mame table: Mame columm:

| .l |

LRL table: UBL column:

| -l |

Layer filker:

| |

Map zerver URL:

Ihttp:.-".-"www.mapguide.c:om.-"c:gi.-"mapagent.exe j

QK I Cancel | Help |
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3 Specify data source properties as described in the online Help.

You can click the Help button in each secondary tab to get details about
the options on the tab.

Setting Style Properties for Layers
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layers
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You can specify properties that control how data appears on a map. For
example, you can specify the display (scale) ranges at which a layer is visible,
the line color, and add labels to the map features. You can also set up a theme,
which displays the data in varying styles to indicate different values in the
data.

Note Raster layers have different style properties from vector layers. For more
information, see “Setting Style Properties for Raster Layers” on page 163.

When specifying the style properties for a layer, you are setting up one or
more style sets. Each style set has a display range and at least one style that
controls how the data displays. By default, there is only one style set per
layer, but you can add more style sets to display the data differently
depending on the current scale. For example, you could create one style set
to display roads with thick lines when you zoom in, and create a second style
set that displays roads with thin lines when you zoom out.
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You use the Styles tab of the Map Layer dialog box to set styles for a layer.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “layers, style properties.”

Map Layer Properties - Major Cities [ %]

Generall Data Sources  Styles |Security|
Dizplay range:

Dizplay ranges:

(- 1,000,000,000,000 [visible at all 5 Mew... | Eemoyve | LChange... |
~ Theme
" Theme Bazed on range of values j Theme Settings... | Theme Metaulis. . |
— Style:
F M ajor Cities | [ | Femoye | Change... |
ove llp | e Diowm | Sige Units... |

— Labels and overposting

[T Label map features W Allow labels on ar laver bo overpost features on this laper SEtings.. |

QK I Cancel | Help |

Styles tab for vector layers

Setting Style Properties for Raster Layers

The style properties that you can set for raster layers are different from those

Help Index
you can set for other types of layers.

raster layers
styles
For step-by-step instructions, choose Help » Contents, click the Index tab,

and look up “raster layers, styles.”
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Map Layer Properties - New Layer [ %]

Generall Data Sources  Styles |Security|

Dizplay range:

Dizplay ranges:

- 1.000.000,000,000 [visible at all scales) LChange... |

Biebuild layer after zooming in by a factor of: 2.00 _:|

Bitonal image characteristic:

Foreground pixel value: |1 [ the "on'" bits ] j
Foreground colar: [ ] 4 -
Background color: I 1 -

QK I Cancel Help

Styles tab for raster layers
Specifying Display Ranges for Layer Styles

Help Index You use the Display Ranges area on the Styles tab to specify the visible display

display ranges range for the current style set. The other options on the Styles tab determine
how the layer displays in the Map Window when the map’s zoom level is
within the display range currently shown in the Display Ranges box.

When the current zoom level of Autodesk MapGuide Author or Autodesk
MapGuide Viewer is within the visible display range of a particular layer, the
program redraws that layer as specified in the associated style set.

Most map layers have only one style set, but multiple style sets can be useful
for some polyline map layers. In the following table, three different display
ranges, each with its own set of styles, are set up to display major roads.
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Using these ranges and styles, Autodesk MapGuide Author draws the roads
with heavier line styles as the zoom increases.

Display Range Styles Used To Draw the Road

0-20,000 ]

20,000 - 50,000

50,000 — 100,000

When setting up multiple style sets for a layer, make sure that the display
ranges do not conflict. For example, the ranges 500,000 — 5,000,000 and
2,000,000 - 10,000,000 conflict, because the second range overlaps the first
one. In such cases, when the current map scale is within the overlapping
display range, Autodesk MapGuide Author displays the features using the
styles of the first style set in the list only.

Keep in mind that the style set will be used if the current map scale is greater
than the From value and less than or equal to the To value. For example, if the
display range is 0 — 20,000, the style set will be used if the current map scale
is between 1 and 20,000. Therefore, when setting up adjacent display ranges,
you should use the same From value as the previous style set’s To value. Do
not set one range to 0 — 20,000 and then set the next range to start at 20,001.

If you want to draw the same data multiple times in different ways to create
the effect of complex line styles, you can specify multiple styles for a single
style set. For details, see “Creating Complex Line Styles with Polylines” on
page 170.

For step-by-step instructions on specifying display ranges, choose Help »
Contents, click the Index tab, and look up “display ranges.”

Specifying Map Layer Styles

You can specify different display styles for each layer in your map, such as
new symbols for a point layer or font style for a text layer. Use the Styles area
of the Styles tab in the Map Layer Properties dialog box to specify how a layer
is displayed.

When themes are disabled, the Styles list contains only one display style (a
symbol for point layers, text font for text layers, line style for polyline layers,
or fill style for polygon layers), as shown in the following illustration.
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The settings you specify for this particular style determine how all features
on the layer are drawn. However, on polyline layers, you can add additional
display styles if you want to overlap display styles to create the effect of
complex line styles. For more information, see “Creating Complex Line
Styles with Polylines” on page 170.

— Style:
F M ajor Cities | [ | Femoye | Change... |

ove llp | MoveDgwnl Si;eUnits...l

This button is enabled for text and point layers only. —

When themes are enabled, there is a separate entry in the Styles list for each
theme category. You specify settings for each theme category separately. For
more information, see “Setting Display Styles for DWG Layers” on page 171.

Specifying Size Units for Text and Point Layers

With text and point layers, you can specify whether to use screen units
(inches or centimeters) or mapping coordinate system units to express the
width and height of features in the map.

To specify size units, you click the Size Units button in the Styles tab of the
Map Layer Properties dialog box.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “size units, for text and point layers.”

Size Units [ %]

Units for spmbol and text size:

" Mapping coordinate system units [METER)

QK I Cancel Help
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Setting Display Styles for Point Layers

You can use symbols to represent point layer features. Autodesk MapGuide
Author comes with predefined symbols that are grouped by type in a number
of symbol (SMB) files. These files are located in the \SMB folder installed in
the Autodesk MapGuide Author program folder. You can also use Windows
Metafiles (WMF), Enhanced Windows Metafiles (EMF), Bitmaps (BMP),
Device Independent Bitmaps (DIB), and pictures from the Clipboard as
symbols. Additionally, you can create your own symbols in Autodesk Map,
and import or paste them into Autodesk MapGuide Author.

For details about working with SMB files and symbols, see “Working with
Symbols” on page 109.

To specify styles for point layers, you double-click a style (or click Change) in
the Styles tab of the Map Layer Properties dialog box, to display the Point
Style dialog box.

Point Style E
TihiEme:
Ok
s o |
Cancel |
Help |

Awailable symbols:

Symboks_|

T Overide colors

=2 I 1 vl Edge: I 1 vl
Limes I 1 vl Fill: I 1 VI
 Size and rotation

“wéidth (i) ID.‘I‘IS _I::' IV Mairtain aspect ratio ]
Height (in] |U-118 _,:i' FRotation [deg): ID _1:3[

Preview:

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “point layers, styles.”
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Adding New Symbols for Use in Point Layers

If you have symbol files that you want to use on point layers, you can add
them so that they are available in Autodesk MapGuide Author. You use the
Point Layer Symbol Manager dialog box to add symbols.

For detailed information, choose Help » Contents, click the Index tab, and

look up “symbols, adding for point layers.”

For details about working with SMB files and symbols, see “Working with

Symbols,” on page 109.

| Point Layer Symbol Manager ﬂ

Click here to add
symbols to use in

Spmbols: |

Add From File... | Paste

Eename... | Femoye

Iransparency... |

Preview:

QK I Cancel | Help |

a layer.

Click here for infor-
mation about the
| other options in

this dialog box.

Setting Display Styles for Text Layers

You can specify the font, color, background, alignment, height, and rotation
of text layer features. To specify styles for text layers, double-click a style in
the Styles tab of the Map Layer Properties dialog box to display the Text Style

dialog box.
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For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “text layers, styles.”

Text Style [ %]
— Foreground
Lolor: m Font... | Cancel |
— Background ﬁl
Mode: lm Calor: lﬁ
Preview:
— Alignment
Horizontal: lh Wertical: lm
—Height and rotation
Height fin] ID.1 EH _|::' Biotation [deg]: ID _|::'

Setting Display Styles for Polyline Layers

You can specify the line style, color, and thickness of polyline layer features.
To specify styles for polyline layers, you double-click a style in the Styles tab
of the Map Layer Properties dialog box to display the Polyline Style dialog

box.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “polyline layers, styles.”

Polyline Style [ %]
Ul !
[ Titieme
Cancel |
Help |
~ Palyline Preview:
Style: Thickness:
———— 3] F =
Lolor:
I -

Setting Style Properties for Layers

169



Help Index
polygon layers

styles

170

Creating Complex Line Styles with Polylines

On polyline map layers that do not use themes, you can create complex line
styles by defining multiple display styles for the same display range.
Autodesk MapGuide Author draws each display style on top of the one that
precedes it in the Style list, creating a more complex display than a single
style can produce.

The following illustration shows a style set with three styles. The first is a
wide red line, the second is a narrower yellow line, and the third is a very thin
dashed red line. This will draw the polylines on the layer three times in three
different ways to create the visual effect of a highway with a center line.

Shyle:

Mew... | Femoye | Change... |

ove llp | MoveDgwnl Si;eUnits...l

Styles area in the Styles tab of the Map Layer Properties dialog box

In the preview box, the right half of each style shows the style you specified
for it, and the left half of each style shows the cumulative effect of drawing
that style on the previous style (the first style in the list is drawn first, the
second style is drawn on top of that, and so on). Thus, the left side of the last
style shows you the final style that will be used to draw the polylines on the
map.

To create another style, click New in the Styles area, and then specify the line
style, color, and width that you want to appear on top of the existing style.

Setting Display Styles for Polygon Layers

You can specify the fill style and color, edge style and color, background, and
line thickness used to draw polygon layer features. To specify styles for
polygon layers, you double-click a style in the Styles tab of the Map Layer
Properties dialog box to display the Polygon Style dialog box.
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For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “polygon layers, styles.”

Polygon Style [ %]
Ul
_DK
[ Titieme
Cancel |
Help |
v Edge
Style:
I j Preview:
Foregound: Lolor:
[ 2> B
Backaround: Thickness:
ITransparent j I 1 ﬁ

Setting Display Styles for DWG Layers

Help Index You can set the display styles of Autodesk DWG layers including the display
DWG layers range at which the layer is visible, the number of times the user can zoom in
setting styles before the layer is redrawn, and whether to render fonts describing layer

features using TrueType fonts or polygons.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “DWG layers, setting styles.”

Map Layer Properties - New Layer [ %]

Generall Data Sources  Stules |Security|

Dizplay range:

Dizplay ranges:

0 - 1.000.000.000,000 [visible at all 5

Biebuild layer after zooming in by a factor of: 2.00 _:|

& Render TrueType fonts as bext

" Render TrueType fonts as polylines and polygons

[k I Cancel Help
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Creating Themes

You can create themes that allow users to quickly see and understand data on
your map. For example, a typical theme for a point layer could display retail
store locations with a different symbol for each type of store. A polygon layer
theme could display each land use classification with a different color or
shading.

Note You cannot apply themes to text or buffer layers.

Use the Theme area in the Styles tab in the Map Layer Properties dialog box
to create or change a display theme for the features on the current map layer.

Theme
’]7 Theme IBased on range of values j Theme Settings... | Theme Defaults... |

Theme area in the Styles tab of the Map Layer Properties dialog box

Before you can create a theme, you need to link the layer to a database. For
more information, see “Specifying Data Source Properties for Layers” on
page 160.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “themes, creating.”

Specifying Layer Feature Labeling and
Overposting

Use the Labels And Overposting area in the Styles tab of the Map Layer Prop-
erties dialog box to specify the font, size, color, and map display range of
automatic labeling for this style set, and to control how features overlap on
a layer.

Vil sz ™ Allow labels on any layer to overpost features on this layer Settings... |

"Labels and overposting

Labels And Overposting area in the Styles tab of the Map Layer Properties dialog box

Overposting occurs when feature labels overlap or cover other map features.
To minimize overposting, the default setting prevents a label from being
drawn at a specific zoom level if it will obscure other labels or features on the
map. However, the program will display the label when you zoom in far
enough to allow sufficient space to display it. The source of the map feature
label is the name field of the data source for the layer. Note that you cannot
create labels for buffer layers.
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For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “labels for features.”

Specifying Security for Layers

Help Index
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Click here for
information
about the
other options

You can secure the data on a layer and control access to resources by setting
an access key. The access key you specify is embedded in the layer, so that
when Autodesk Mapguide Author or Autodesk MapGuide Viewer requests
data from a resource for the layer, Autodesk MapGuide Server checks the
resource access key against the layer access key. If the keys match, Autodesk
MapGuide Server loads the layer’s data. If keys do not match, access to the
resource data is denied. If the resource does not use an access key, the access
key embedded in the layer is ignored.

You can also control whether Autodesk MapGuide Viewer API users can
obtain coordinate information from map features in your map and whether
they can access the map layer setup. Disabling API access to the coordinates
prevents developers from writing scripts that can download all of the coordi-
nates on the layer and re-use the data.

You use the Security tab of the Map Layer Properties dialog box to specify
security settings.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “layers, security.”

Map Layer Properties - Roads [ %]

Generall Diata Sourcesl Styles  Fecurity |

—Access key security
Access key: LConfirm access key:

— &Pl security
& Do not allow access to coordinate values from AP

' Allow access to coordinate values from AP
' dllow access to coordinate valuss from AP with the following passkey

Easshen [Canfimm passhen

& Do not allow access to map layer setup from AP
' dllow access to map layer setup from AP
' dllow access to map layer setup from AP with the following passkey

Eagskey: [Camfimm passhen

in this dialog
box.

QK I Cancel Help
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Modifying Multiple Layers Simultaneously

Help Index Although you need to specify most properties for each layer individually, you
layers can change the visibility status and the Autodesk MapGuide Server
modifying multiple MapAgent URL of multiple layers at the same time. If you have several layers

in a map, this can save you time.

To modify properties of multiple layers, you use the Multiple Map Layer
Properties dialog box, which you access by selecting two or more layers in the
Design tab of the Map Explorer, and then choosing Properties from the
popup menu.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “layers, modifying multiple.”

Multiple Map Layer Properties [ %]

Map server URL:

Ihttp:.-".-"www.mapguide.c:om.-"c:gi.-"mapagent.exe j Camcel |
v Wisible Help |

Saving a Layer

After you save a layer as a Map Layer File (MLF), you can use it to create new
layers in the same map or in different maps. This can save you time if you
create similar layers repeatedly, because you can simply add the MLF as a new
layer and make modifications to its existing settings. Therefore, you should
consider saving commonly used layers as MLFs. Note that if the layer is static,
the MLF will include all of the data for that layer, as well its properties. For
more information, see the next section, “Adding a Saved Layer to the Current
Map.”

You can also add MLFs to a map using the Autodesk MapGuide Viewer APIL.
For more information, refer to the Autodesk MapGuide Viewer API Help.
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To save a layer to a file

1 In the Design tab of the Map Explorer, right-click the name of the map
layer to be saved, and then choose Save As Map Layer File from the popup
menu.

2 Navigate to the folder where you want to save the layer file, and then enter
a name for the file.

3 If you have assigned an access key to the layer, select the Include Access
Key In Map Layer File check box to save the access key with the layer file,
or clear it to prevent the access key from being saved with the layer.

Adding a Saved Layer to the Current Map

You can use the same layer in multiple maps. This is very useful, for example,
when you need to create several maps of the same area that show variations
of the same data. Using a saved layer saves you the work of having to recreate
the same layer for each map. Before you can add a layer from one map to
another, you must save the layer.

To add a saved layer to a map
1 Right-click over the Map Layers item in the Design tab of the Map
Explorer, and then choose Add Layer From File.

2 Navigate to the folder where the saved layer’s MLF file resides, select the
folder, and then click OK.

Rebuilding a Layer or Layer Group

Help Index

rebuilding layers

If you have made changes to one or more layers, you can have Autodesk
MapGuide Server rebuild the layers so that you can see the changes in
Autodesk MapGuide Author. Rebuilding a layer group rebuilds all of the
layers in the group. Note that you cannot rebuild a buffer or redline layer.
You use the Rebuild All Layers command or the Rebuild command to rebuild
layers.

For step-by-step instructions, choose Help » Contents, click the Index tab,
and look up “rebuilding layers.”
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Deleting a Layer or Layer Group

You can delete layers and layer groups that you do not want in your map.
Note that deleting a layer group deletes all of the layers in the group.

To delete a layer or layer group

1 In the Design tab of the Map Explorer, select one or more layers or layer
groups to delete.

2 Right-click and choose Remove from the popup menu.
A message appears to confirm the deletion.

3 Click Yes to delete the selected layer(s) or layer group(s).
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access key An alphanumeric string used by Autodesk MapGuide Server to determine
whether a map layer has permission to gain access to a resource. In the Autodesk
MapGuide Server Admin, you can assign one or more access keys to a resource. Then,
when a map author sets up a layer to use that resource, the author must type one of the
valid access keys in the Map Layer Properties dialog box.

ADL See Autodesk Data Link file.

arbitrary XY coordinates Cartesian coordinates that specify points on a particular
map, which do not correlate to coordinates on the globe as latitude/longitude do. An
arbitrary XY coordinate system is suitable for floor plans or very small sites.

ArcView Shape file (SHP) A data format that includes files created in ESRI ArcView.
You can convert these files to latitude/longitude SDFs using the SDF Loader.

attribute data Alphanumeric data that describes the characteristics of map features.
Attribute data is maintained in tables and databases, which are linked to map layers in
Autodesk MapGuide Author. Examples of attribute data include street names, building
addresses, land-use codes, and population counts. Attribute data is used either to label
map features, create themes, or generate reports. See also spatial data.

attribute table See database and table.

Autodesk Data Link file (ADL) A file that establishes a connection between Autodesk
MapGuide Server and Autodesk DWG files. ADL files are similar to UDL files but have
an .adl file extension. You can create or modify ADL files using Autodesk MapGuide
Server Admin.

Band Interleaved Line (BIL) A format for compressing raster images that consists of
an unstructured file and an ASCII metadata HDR file that are combined into one file.

BIL See Band Interleaved Line.

bmp A format for compressing raster images that is typically used for icons or images
that need to load quickly.

BNA file format A data format that includes files created in ESRI Atlas GIS. You can
convert these files to latitude/longitude SDFs using the SDF Loader.

bookmark A saved view position and zoom magnification identified by a URL that
you specify. When you use a bookmark, the map is redrawn at the view position and
zoom magnification saved in the bookmark.

buffer A polygon that locates its boundaries at a certain distance from a point, line, or
other polygon. An example of a buffer is a polygon whose boundaries are 200 feet from
the bank of a river.

Cals See Computer Aided Acquisition and Logistics Support.
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centroid A point designated as the center of a polygon. A centroid is typically com-
puted using information derived from the boundary of the polygon. Computed cen-
troids generally lie within the polygon, but they can also lie outside of the polygon.

CGI See Common Gateway Interface.

character spacing ratio The ratio of the distance between text characters to average
character width. For example, if the distance between text characters is 3.5 mm, and the
character spacing ratio is 0.5, the average character width is 7 mm.

Common Gateway Interface (CGI) An interface that allows server applications to
work with Web servers. You can use the CGI version of the Autodesk MapGuide Server
MapAgent to work with either Microsoft Internet Information Server or a Netscape
Internet Server.

complex symbols A symbol composed of one or multiple bitmaps and one or multi-
ple vector graphics, all of which appear as one symbol in the associated layer.

Computer Aided Acquisition and Logistics Support (CALS) A format for compress-
ing raster images. MapGuide supports CALS MIL-R_28002A Type 1 Format. This format
typically works best for black-and-white images that use 1 bit per pixel.

coordinate system Any of a number of reference systems used to define the unique
location of a point in space and to reference point, line, and area information by defin-
ing its geographic location. A coordinate system is usually defined by a projection, an
ellipsoid definition, a datum definition, one or more standard parallels, and a central
meridian.

coordinate system origin The reference location for a planar coordinate system that
is stored with a map.

Coverage A data format that includes files created in ESRI Arc/Info. You can convert
these files to latitude/longitude SDFs using the SDF Loader.

CTRL-click A method of selecting multiple, non-contiguous items in a list by holding
down the CTRL key, and then clicking each item you want to select.

database A collection of interrelated alphanumeric data files controlled by a database
management system (DBMS). Databases are structured so that the DBMS can perform
rapid search and retrieval by various data elements. In Autodesk MapGuide, “database”
refers to a relational database that stores attribute data, such as a database of records that
contain information like population and area for each country. See also RDBMS.

data provider A data provider that can process spatial queries and access spatial data.
You can purchase Autodesk MapGuide data providers for Autodesk GIS Design Server,
Oracle Spatial, and ArcView SHP.

data source A Microsoft Data Link (UDL) file or Autodesk Data Link (ADL) file, with
a .udl or .adl extension. These files contain all the information required to connect to a
specific data provider. Before you can access an external database from within Autodesk
MapGuide, you must configure it as an OLE DB or Autodesk DWG data source.

Data Source Name (DSN) An ODBC data source that contains information about how
to connect to a particular database, spreadsheet, or other data source. You can set up
User DSNs, which are available only when you log on to your computer, and System
DSNs, which are available to all users and to NT services on your computer.
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datum Information about the interpretation of the Earth on which the coordinate sys-
tem is based. The datum can include the size and shape of the Earth (such as an ellipsoid
or flat map), origin point, orientation, and more. The datum is critical for accuracy,
because if a different datum is applied to a coordinate system, the coordinates will fall
onto different positions on the Earth.

decimal degrees The mathematical representation of degrees in floating point values.
For example, in decimal degrees, 30°30'0" is 30.5°.

degrees® minutes' seconds" The mathematical representation of degrees as minutes
and seconds, where one degree equals 60 minutes and one minute equals 60 seconds.
For example, in degrees® minutes' seconds", 30.5° is 30°30'0".

DGN file format See Microstation Design File.

digitize To convert spatially dispersed information on maps, drawings, or charts into
machine-readable digital data that can be processed by computer software. Digitizing
captures spatial data as XY coordinates in digital form.

display range The maximum and minimum scale at which Autodesk MapGuide will
display a layer. In Autodesk MapGuide Author, you can specify that a layer will display
only at certain ranges, or specify multiple display ranges for a layer and specify different
attribute styles for each of the display ranges, so that the layer will be drawn differently
depending on the current scale at which the map is displayed. By default, Autodesk
MapGuide displays the layer regardless of the current scale. See also map scale.

display styles A set of properties that define how to display data on the layer. Layers
without themes typically have only one display style, which defines how to display all
of the data on the layer. Layers with themes typically have multiple display styles: one
for each category in the theme. You specify different properties for each display style,
such as color, fill style, line width, or point symbol. Display styles are defined for each
style set on a layer.

drive alias A name for the location of drawings attached to an Autodesk Map project
drawing that replaces the traditional file path. Drive alias information is stored in the
Autodesk Map initialization file (acadmap.ini). Network users of Autodesk Map typically
assign the same drive alias to a network location when they share projects containing
attached source drawings. You create the aliases in Autodesk Map or by editing the
acadmap.ini file. The acadmap.ini file is shared by all your Autodesk Map projects.

dynamic layer A layer that gets data from Autodesk MapGuide Server as the user
zooms in and out on the map, turns the layer on and off, and so forth. Unlike static lay-
ers, which store all of the data for the entire layer in the MWE, dynamic layers download
only the data needed for the current view, so the dynamic option is better for layers with
large data sets or data that needs to be kept more secure.

ECW  See Enhanced Compression Wavelet.

ellipsoid An approximation of the Earth’s shape that does not account for variations
caused by non-uniform density of the Earth.

Enhanced Compression Wavelet (ECW) Supported by ER Mapper, a wavelet-based
image compression format with high-quality results at high compression rates.

extents The smallest rectangle that contains all features in a map, that is, the outer-
most boundaries of the map.

extranet An intranet that is available to authorized users outside of the organization.
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DWG layer A single layer within an Autodesk drawing (DWG) file.

DWG map layer A single Autodesk MapGuide map layer that is sourced from an
Autodesk DWG or an Autodesk DWG Project File.

feature See map feature.

FeatureProperties table A table of Autodesk Map object properties (color, area, and
object handle) that are on an Autodesk MapGuide DWG layer.

field A specific class, or column, of information in a database. For example, in a data-
base of demographic information for countries, one field might be “Country Name,”
and another might be “Population.”

geocode When used as a noun, refers to the unique key of a map feature (see key). As
a verb, to geocode means to assign real-world coordinates to spatial features so that they
can be displayed consistently and correctly on a map. See also georeferencing file.

geographic coordinate system A coordinate system that uses angular coordinates,
such as latitude and longitude. This is the default Autodesk MapGuide Author coordi-
nate system.

Geographic Information System (GIS) An organized collection of computer hard-
ware, software, and geographic data designed to efficiently capture, store, update,
manipulate, analyze, and display all forms of geographically referenced information.

georeferencing file (TFW) A file that accompanies a raster image file and tells
Autodesk MapGuide Server how to scale and translate the raster image onto the current
map.

GIS See Geographic Information System.
handle A unique numeric identifier for an Autodesk Map object.
hatch A regular pattern used to fill an area with a series of cross-angled lines.

IntelliMouse A pointing device designed by Microsoft that has a wheel control (a
rotating wheel that is also a third button). The IntelliMouse provides extended naviga-
tional functions in the areas of zooming and panning. It allows you to perform these
operations directly from the mouse instead of interacting with navigation controls on
the screen.

Internet A global collection of linked, independent networks that use the TCP/IP pro-
tocol to function as a single large network. The Internet can be accessed by the public.

Internet Server Application Programming Interface (ISAPI) An interface that
allows server applications to work with Microsoft Internet Information Server (Microsoft
1IS). If you are using Microsoft IIS as your Web server, you can use either the ISAPI or CGI
version of the Autodesk MapGuide Server MapAgent.

intranet A private network that uses Internet technology but cannot be accessed by
the public. If an intranet extends access to authorized users outside of the organization,
it is called an extranet.

ISAPI See Internet Server Application Programming Interface.

island An excluded area within the perimeter of a closed polygon. An island can also
be an included area outside such a perimeter. A lake in a parcel and an island in a lake
are both examples of islands.
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Joint Photographic Experts Group (JPEG) A format for compressing raster images
that offers a compression ratio of up to 20:1. Note that some image information is lost
when a raw image such as TIFF or BMP is converted to JPEG format.

JPEG See Joint Photographic Experts Group.

key An alphanumeric character string or an integer used to uniquely identify a map
feature or a record in an attribute table. If a spatial feature in an SDF and a record in an
attribute table use the same key, they are linked, so you can select that spatial feature
and retrieve the data in that record. This is useful for generating reports because you can
select the spatial features you want and then generate a report containing the attribute
data for those features only. Keys must be unique; if more than one spatial feature or
record uses the same key, the links between the spatial features and the attribute data do
not work. Note that for an SDF and for OLE DB providers linked to an SDF, the key must
be a string. See also primary key.

latitude/longitude system A global coordinate system in which locations are
expressed by geographical coordinates (the geodetic latitude and longitude) that depict
angular measurements relative to the Earth’s ellipsoid. These coordinates are often
expressed in decimal degrees or degrees® minutes' seconds". See also arbitrary XY
coordinates.

layer See map layer.

layer group A collection of related map layers. You create layer groups in Autodesk
MapGuide Author.

legend A key to or an explanation of the symbols in a map, and their meaning or val-
ues. In the View tab of the Autodesk MapGuide Author Map Explorer and in Autodesk
MapGuide Viewer, you can use the legend to turn layers on and off so that the map fea-
tures they contain are no longer visible or selectable.

line A drawing entity with start and end coordinates connected by a single straight
line. Lines typically represent the shape of map features too narrow to be displayed as
an area at the given scale (contours, street centerlines, or streams), or linear features with
no area (county boundary lines).

line spacing ratio The ratio of the distance between lines of text to text character
height. For example, if the distance between lines of text is 10 mm, and the line spacing
ratio is 0.5, the font height is 20 mm.

linetype A property of a line that defines its appearance. Examples of linetypes include
continuous, dashed, and dotted.

linked table or database A table or database linked to a layer using Autodesk
MapGuide Author. The records in the table are linked to the spatial features in the layer
via common keys.

map An abstract representation of the physical features of a portion of the Earth’s sur-
face graphically displayed on a planar surface. Maps display signs, symbols, and spatial
relationships among the features. They typically emphasize, generalize, and omit certain
features from the display to meet design objectives. For example, railroad features might
be included in a transportation map but excluded from a highway map.

map feature Any spatial feature on a map. In the Autodesk MapGuide products, map
features can be points, polylines, polygons, or text. Although raster images are techni-
cally not map features, you can display them in raster layers.
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Maplnfo Interchange File (MIF/MID) A data format that includes files created in
Maplnfo. You can convert these files to latitude/longitude SDFs using the SDF Loader.

map layer A grouping of map features that are stored and displayed together. Individ-
ual map layers can be turned on and off to show or hide the features they contain. When
all map layers are displayed, they overlap like transparencies and show all features in the
map. There can be several types of Autodesk MapGuide map layers, including ones
sourced from SDF files, SHP files, DWG files, and so on.

map projection The representation of the Earth, which is curved, on a flat map sur-
face. A map projection defines the units and characteristics of a coordinate system. The
three basic types of map projections are azimuthal, conical, and cylindrical.

map scale The ratio between one unit of distance on the map and the real-world dis-
tance it represents. For example, if a map is displayed at a scale of 1:200,000, then one
centimeter on the map would represent 200,000 centimeters (2,000 meters) in the real
world. The larger the second number in the ratio, the larger the area of the world that is
displayed (zoomed out), and the smaller the scale; the smaller the second number in the
ratio, the smaller the area of the world that is displayed (zoomed in), and the larger the
scale. For example, 1:1 is life size and is therefore large scale, whereas 1:200,000,000 is
zoomed out to display the whole Earth and is therefore small scale. The fact that a larger
second number creates a smaller scale and vice versa can be very confusing. A good
phrase to remember is “as large as life” to help you remember that the closer you get to
a scale of 1:1 (life size), the larger the scale is.

Map Window File MWEF) Created with Autodesk MapGuide Author, Map Window
Files (MWFs) contain the specifications of the map window. These specifications include
the boundary of the map, the background color, data source information (SQL data-
bases, Spatial Data Files, and raster image files), layers of cartographic data (such as roads
and countries), layer display information (such as styles and display ranges), and map
display configuration specifications (such as menus and legends).

Map Window XML file MWX) Created with Autodesk MapGuide Author, Map Win-
dow XML files contain the specifications of the map window in XML format. These
specifications are denoted by XML element tags, or XML Nodes, that specify the bound-
ary of the map, the background color, data source information (SQL databases, Spatial
Data Files, and raster image files), layers of cartographic data (such as roads and coun-
tries), layer display information (such as styles and display ranges), and map display con-
figuration specifications (such as menus and legends).

MapTip The information that is displayed in a yellow popup when the user pauses the
mouse pointer over a map feature. See also ToolTip.

Microsoft Data Link (UDL) file A file that establishes an OLE DB connection
between Autodesk MapGuide Server and a provider, such as the Autodesk Spatial Data
Provider for SHP. UDL files have a .udl extension and include the type of data to access,
the server where the data resides, and the database where the data is stored. You can
create or modify UDL files using Autodesk MapGuide Server Admin.

Microstation Design File (DGN) A data format that includes files created in Inter-
graph/Bentley Microstation. You can convert these files to latitude/longitude SDFs using
the SDF Loader.

MIE/MID file format See Maplnfo Interchange File
MrSID See Multi-Resolution Seamless Image Database.
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Multi-Resolution Seamless Image Database (MrSID) Supported by LizardTech, Inc.,
a wavelet-based image compression format designed specifically for GIS to enable true
portability of large images. Autodesk MapGuide supports MrSID version 1.6 format .sid
files.

MWE See Map Window File.
MWX See Map Window XML File.

Netscape Server Application Programming Interface (NSAPI) An interface that
allows server applications to work with Netscape Internet servers, either Netscape
FastTrack Server or Netscape Enterprise Server. If you are using one of these Netscape
Internet Servers as your Web server, you can use either the NSAPI or CGI version of the
Autodesk MapGuide Server MapAgent.

NSAPI See Netscape Server Application Programming Interface.
object See map feature.

Object Linking and Embedding Database (OLE DB) Provides communication
between client applications and a variety of databases.

ODBC See Open Database Connectivity.
OLE DB See Object Linking and Embedding Database.

Open Database Connectivity (ODBC) A standard API (Application Programming
Interface) used to communicate with database management systems, developed by
Microsoft.

pan To move the active view up, down, or sideways to display areas in the map that,
at the current viewing scale, lie outside the window.

paper boundary A rectangle with a drop shadow that represents the printable area. It
is also called the Printable Page.

pattern A property of a fill entity that consists of an artistic or mechanical design. A
pattern typically incorporates lines or symbols that are equidistant from each other in
the form of a matrix. For example, you could fill a polygon with a hatch pattern.

PNG See Portable Network Graphic.

point A zero-dimensional abstraction of a feature represented by a single coordinate.
A point normally represents a map feature too small to be displayed as a line or area; for
example, the location of a building on a small scale map, or the location of a service
cover on a medium scale map.

polygon Also called an area, a polygon is a closed, connected set of lines that reside on
the same layer and share the same line style, linetype, and thickness. Because a polygon
is a closed area, you can apply fill colors and patterns to it.

polyline A connected set of points, arcs, splines, or vertices that reside on the same
layer and share the same line style, linetype, and thickness.

Portable Network Graphic (PNG) A format for compressing raster images that is pri-
marily designed for use on the World Wide Web. PNG enables partial transparency of
colors; for example, you can set the transparency of a color to 5%.
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primary key A field or combination of fields that uniquely identifies each record in a
table. The primary key is used to link the records to map features that share the same
primary key. See also key and primary key field.

primary key field A field or combination of fields that uniquely identify each record
in a table. The primary key is used to link the records to map features that share the same
primary key. See also key and primary key.

project drawing file An Autodesk Map DWG drawing file with additional project
information including links to a set of attached source drawing, coordinate system infor-
mation, options, and other settings.

projection See map projection and coordinate system.

properties The parameters and settings for a map feature or layer. For example, the
properties of a line layer include the SDF file containing the lines, the display styles
(such as the color and thickness), and more.

Raster Image Catalog (RIC) file A file containing a list of raster image files. Raster
Image Catalog files allow a map author to use multiple raster images on the same layer
in a map. This is useful if the images are set up to look like a single image (tiled), because
you can create one layer with many images, rather than creating a separate layer for each
image. Autodesk MapGuide Author allows only one image file or RIC per layer.

raster image file A file containing an image such as a photograph that is stored in a
grid of pixels (or cells), unlike SDFs, which store spatial data as vectors (lines). The ability
to overlay vector data on raster data is a key feature of Autodesk MapGuide. For example,
you can display a raster image file containing a photograph of a particular area, and then
overlay a layer of streets and ZIP code boundaries to help identify landmarks in the pho-
tograph. Because raster images store a value for every pixel in the grid, rather than stor-
ing only the vertices of the lines as SDFs do, raster image files can be quite large and
require greater amounts of memory to process.

RDBMS See Relational Database Management System.

Relational Database Management System (RDBMS) A database that can include
links to other databases, so that when you update the data in one database, the linked
database is updated as well. See also database.

report An HTML page generated by a script you create using a third-party tool like
ColdFusion from Macromedia. The report provides information about the selected map
features or a point you specify, depending on the settings you specify in Autodesk
MapGuide Author. When a user chooses to view the report, Autodesk MapGuide Server
sends the selected map features or specified point to the report script, which then
extracts attribute data from a database for those map features or that point, and then
displays the HTML page in your Web browser with the results. Examples of reports might
be demographic data for the specified layers or the latitude/longitude of the specified
point.

resource A file that contains spatial data or attribute data that you can use in a map
layer. A resource can be a Spatial Data File (SDF), Raster Image File, Zoom Goto specifi-
cation, or attribute database.

RIC See Raster Image Catalog File.
scale See map scale.

scale range See display range.
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SDF See Spatial Data File.
SDP See Spatial Data Provider.

select To designate one or more map features as those you want to work on. You can
select by clicking with the mouse, dragging an area around an feature, selecting the
name of the map features from a list, and more. Selected features are displayed in a dif-
ferent color (specified in Autodesk MapGuide Author).

Select statement See SQL Select statement.

server There are three types of servers that are related to Autodesk MapGuide: a Win-
dows NT server, which is a computer with Windows NT installed on it that is configured
as a server; Autodesk MapGuide Server, which is an application that runs on the Win-
dows NT server and serves map data to Autodesk MapGuide Author and Autodesk
MapGuide Viewer; and a Web server, which works with a Web browser to provide access
to the Internet via the World Wide Web and display the maps sent by Autodesk
MapGuide Server.

SHIFT-click A method of selecting multiple, contiguous items in a list by clicking the
first item you want to select, and then holding down the SHIFT key and clicking the last
item you want to select.

SHP  See ArcView Shape file.

spatial data Data that represents the location of a spatial feature, such as text, points,
lines, and polygons. In Autodesk MapGuide, spatial data is contained in spatial data files
(SDFs) or spatial data provider (SDP) data sources. Point and text features can also be
contained in SQL databases. See also attribute data and raster image file.

Spatial Data File (SDF) The Autodesk MapGuide native file format for files that con-
tain spatial data, such as roads, cities, and countries.

Spatial Data Provider (SDP) An OLE DB data provider that can process spatial queries
and access spatial data.

SQL See Structured Query Language.

SQL Select statement A SQL statement that you specify to select records from a data-
base. You use a SQL Select statement when creating a Zoom Goto location in Autodesk
MapGuide Author, for example. See also Structured Query Language.

static layer A layer that stores all of the data for the entire layer in the MWE. Unlike
dynamic layers, which download only the data needed for the current view, static layers
download all of the data for the layer when the layer is first accessed, so the static option
is better for layers with small data sets and data that does not require high security.

Structured Query Language (SQL) A syntax for defining and manipulating data from
a relational database. Developed by IBM in the 1970s, it has become an industry stan-
dard for query languages in most relational database management systems. See also SQL
Select statement.

style set A style set defines how a layer will display at a particular display range. Each
layer has at least one style set. To display the layer always the same way, you define the
style properties for this one style set only. To display the layer differently at different dis-
play ranges, such as adding a theme to the layer when the map is zoomed in far enough,
you create additional style sets, and define their style properties.
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table A set of data with a horizontal dimension (rows/records) and a vertical dimen-
sion (columns/fields). A table has a specified number of columns and any number of
rows. Tables are typically stored in relational databases (RDBMS), such as Oracle or
Access, but can also be stored in files such as Excel spreadsheets and delimited text files.

Tagged Image File Format (TIFF) A format for compressing raster images that is
widely used and supported.

Targa See TrueVision Targa 2.0.

template A saved map layer file (.mlf) that you can add to any map. Templates save
time, as you can open an existing template (map layer file) and simply modify the prop-
erties you want to change, rather than creating a new layer and having to set all of its
properties.

text A textual description, composed of printable characters, that you define in a map
layer. Text entities are often used to label the graphic representations of spatial features.

TFW See georeferencing file.
TGA See TrueVision Targa 2.0.

theme A set of categories that display the map features with different styles and sym-
bols to depict different values. A theme can have categories for a range of values (such
as displaying countries in varying colors between black and white to show heavy and
light population) and for individual values (such as displaying highways in red and sur-
face streets in black). Examples of themes might be property assessment, housing qual-
ity, population density, and average rainfall.

TIFF See Tagged Image File Format.

ToolTip An online Help feature that displays a brief explanation of a toolbar button
when you hold the mouse pointer over the button for more than a second. See also
MapTip.

TrueVision Targa 2.0 (TGA) A format for compressing raster images also referred to as
TARGA.

UCS A coordinate system that defines the orientation of the X,Y, and Z axes in three-
dimensional space. The UCS determines the default placement of geometry in a drawing.

UDL See Microsoft Data Link files.
UNC See Universal Naming Convention.

units The unit of measurement used in all areas where a distance is specified or dis-
played. You can specify that a map use U.S. units or metric units using the Preferences
dialog box in Autodesk MapGuide Author or Autodesk MapGuide Viewer.

Universal Naming Convention (UNC) The standard method of specifying the full
path name of a file. For example, to specify a file named ROADS.SDF in a folder named
SDF on a computer named Data with the share name CDrive, you would type
\\Data\CDrive\SDF\ROADS.SDF. If the computer is mapped to a drive letter, you could
use the drive letter in the path, such as D:\SDF\ROADS.SDF, but it is safer to use the
UNC, just in case, for example, the drive mapping is lost.

vertex One of a set of ordered XY coordinates that constitute a map feature.

width ratio The ratio of text character width to text character height. For example, if
the font size is 20 mm, and the width ratio is 0.5, the width of a text character is 10 mm.

Glossary



zoom To change the display magnification so that it focuses on progressively smaller
areas (when you zoom in) or larger areas (when you zoom out) of an image.

Zoom Goto category A set of locations you can zoom to. For example, a Zoom Goto
category, “Offices,” might allow you to type the name of one of your offices and zoom
directly to it on the map.
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Symbols

/COORDSYS parameter 118

/LINK switch, specifying URL columns 63
/NULLNAME switch, trimming feature names 63
\n character, in location names 147

A

access keys 51, 52
assigning
to layers 52, 173
to resources 173
to time sensitive data 84
controlling access to layers with 52
creating 84
defined 80
editing 84
embedding in layers 52
for security 52
setting
vs. user IDs and passwords 81
access logs 88-91
and MLData requests 90
customizing for map layers 90
MLData values 90
actions, adding to popup menus 148
Active Server Pages (ASP)
and application developers 20
and server administrators 20
and server-side scripting 41
installing 75
ActiveX Viewer. See Autodesk MapGuide Viewers
adding
layers to maps 175
users to Authors users group 83
address matching (geocoding), activating 101
addresses, zooming to 134
ADL files 78
administrator responsibilities, server 20
ADN. See Autodesk MapGuide Developer Network
aerial photos. See raster images
annotations, about 96
API Symbol Manager
adding symbols to redline layers 110
redline layers, adding symbols to 112

API. See Autodesk MapGuide Viewers
API
Apple Macintosh 63
and the Autodesk MapGuide Viewer, Java
Edition 35
APPLET tag, using 39
application developers, responsibilities and
required skills 20
application development
See also Autodesk MapGuide Viewer API
applications
client side 38
overall strategy for developing 43
server-side 38
arbitrary XY coordinates 118
Arc/Info Coverage files, converting to SDFs 33
architecture, distributed 54-63
ArcView SHP files 155
converting to SDFs 33
ASCII comma-delimited CSV files, converting to
SDFs 33
ASP. See Active Server Pages (ASP)
assembling your server
attribute data, adding 78
geocoding data, adding 91
assigning access keys
to layers 52
to resources 173
to time sensitive data 84
Atlas BNA, converting to SDFs 33
attribute data
accessing without converting 37
adding to server 78
configuration considerations 99
converting 33
data providers 37
linking to
database 98
SDFs 98
spatial data 97
setting access 78
setting up themes 99
supported formats 37
using for themes 99
working with 97-101
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attributes
based on values 172
combining for polyline layers 170
layer visibility 164
list of 135
map layers 162-171
point symbols 167
polygons 170
polyline layers 169
text 168
themes 172
Author. See Autodesk MapGuide Author
authoring privileges, obtaining 19
Authors users group 83, 122
assigning users 53
AutoCAD DWG. See Autodesk DWG
AutoCAD Map. See Autodesk Map
Autodesk Data Link (ADL) files 78
Autodesk Developer Network (ADN) 28
Autodesk DWG 158
Autodesk GIS Design Server
theme data 112-114
theme layers 158
changing styles of map features 158
changing symbology definitions 158
creating 158
Version Mode Value 114
Autodesk GIS Design Server Extension 37
Autodesk Map
and data engineers 19
converting DWGs to SDFs 33
Autodesk MapGuide
about 10
additional information. See documentation
application development
strategy 42-46
components 31-42
concepts 30
data providers 37, 79
designing implementations 45
development strategy 43
documentation 22-28
general properties, setting 77
Help system 21
implementation 47-66
online Help 21
product architecture 30
roles and required skills 18-20
security 51-54
understanding 30
Web site URL 27
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Autodesk MapGuide Author
about 32
and map authors 19
CD installation 124
evaluation period 125
hard disk requirements 15
installing 124
installing and testing 44
key features 10
Map Explorer 135
memory requirements 15
new features 14
online Help 22
opening a map 132
operating system requirements 15
popup menus 127
preferences, setting 132
program window 127
running old and new releases concurrently
124
serial number 125
setting preferences 132
starting 125
starting the CD 124
status bar, viewing 138
system requirements 15
toolbar 130
Autodesk MapGuide Developer’s Guide
PDF file 25
Autodesk MapGuide Server
about 36, 75
getting information from your server
administrator 122
hard disk requirements 16
installing 68
installing and testing 44
Key Features 11
MapAgents 37
MDAC 16
memory requirements 16
new features 14
online Help 22
operating system requirements 16
parallel data requests 56
removing Autodesk MapGuide Server for
VISION* 69
security 80
server administrator 20
Server Agent 37
Server Service 37
starting and stopping 76
system requirements 16
tracking usage 89



Autodesk MapGuide Server Admin
online Help 22
overview 75
starting 76
starting and stopping the server 76

Autodesk MapGuide Server Agent. See MapAgents

Autodesk MapGuide Server Service 37
Autodesk MapGuide User’s Guide
conventions 21
PDF file 23
terminology 21
Autodesk MapGuide Viewer
choosing 63
customizing with the API 20
installing and testing 44
key features 11
new features 15
understanding 35-36
Autodesk MapGuide Viewers
about 35, 65
and flicker-free 15
API
and client-side scripting 40
class definitions 66
online Help 25
passkeys 51, 53
security 173
understanding 40
Autodesk MapGuide components 35
development considerations 65, 66
documentation 23
downloading 35
hard disk requirements 17
memory requirements 17
online Help 23
Sun Solaris operating system 18
supporting 63
system requirements 17
versions of 35
Windows operating system 17
Autodesk MapGuide Web site, setting up 42
Autodesk Server
uninstalling MapGuide Server for VISION*
69

balancing processing requirements 72
Band Interleaf (BIL) files 108
bandwidth 61
batch conversion
and the SDF Loader 97
responsibility for 19
BIL (Band Interleaf) files 108
bitmap symbols 109
bitmaps, making transparent 109

bookmarks, setting 135
browser, requirements 15
buffer layers 157, 160, 172
rebuilding 175
restrictions 172
themes 172
buffers
creating 141
defined 141

C

C++

writing applications with 34, 36, 40
categories, for zoom locations 146
CGI

designing reports 45

MapAgent 54
changing map data

dynamically 41

using a Web browser 41
client-side scripts and applications 38, 39

components of 39
ColdFusion 34

and application developers 20

designing reports 149

installing 75

server-side scripting 41
coloring

polygons 170

polylines 169

text 168
columns, for zoom location categories 147
comma-delimited files, converting to SDFs 33
commands

accessing common 130

adding to popup menu 148
comma-separated (CSV) files 62
components, viewing 35
configuring MIME types 69
configuring Web servers 68-75
conflicting display ranges 164
conventions in this guide 21
converting data 33
converting file formats

ArcView Shapefile 33

ASCII comma-delimited CSV 33

Atlas BNA 33

Autodesk Map DWG and DXF 33

ESRI Arc/Info Coverage 33

Integraph DGN 33

MapInfo MID/MIF 33

using SDF Loader 97
converting map data 46
coordinate precision 119

32-bit and 64-bit 119
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coordinate systems 144
about 118
and map authors 19
considerations 119
converting to latitude/longitude 33
selecting 119, 144
updating 144
verifying 144
coordinate values
accessing with the getLayerSetup method 53
accessing with the getVertices method 53
coordinates, zooming to 134
COORDSYS parameter 118
CSV files, converting to SDFs 33
custom applications, responsibility for creating

custom reports

about 41

creating 41
customizing reports 149

D

data
conversion 33
determining needs and conversion strategy
45
distributing across multiple servers 58
engineer, responsibilities 19
generalizing 34
limiting display by scale 117
linking to
database 98
SDF s 98
mirroring on multiple servers 58
planning display and properties of 116
providers 37
setting up 99
themes 99
data directories, setting up 48-50
data providers 37, 79
about 37
GIS Design Server 158
Oracle Spatial 155
SHP 155
data requests, simultaneous processing 56
data resolution, reducing to improve map
performance 62
data security, planning 50-54
data sources
accessing 79
creating 79
deleting 79
disconnecting 87
for zoom location categories 147
formats 147
properties, specifying 160
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data sources (continued)
renaming 79
restricting access to 85-87
specifying properties 160
specifying type for layer 160
taking offline 87
tracking with spreadsheet 120
updating 87
viewing 79
databases
linking to
SDFs 44
second database 98
responsibility for access 20
updating via the map 42
viewing using a Web browser 42
datum shifts and SDF Loader 33
DCOM 71
default coordinate system 144
definitions of terms 177
demos on the Autodesk MapGuide Web site 27
deploying Autodesk MapGuide, strategy 43
Design tab of Map Explorer 136, 155
developer support 27, 28
developing applications for Autodesk MapGuide
42-46
Device Independent Bitmap symbols (DIB) 109
directories 48-50
examples 48
guidelines 48
planning 48-50
security for 51
virtual 49, 50
disconnecting data sources 87
discussion groups 27
display ranges
conflicting 164
improving map performance 62
layers 164
overlapping 164
setting 164
viewing 136
display styles
overlapping 165
selecting 165
tracking with spreadsheet 120
distance, measuring 139
distributed architecture 54-63
Distributed Component Object Model (DCOM)
71
distributed data
architecture diagram 58
combining mirrored and distributed servers
60
distributing requests to several servers 58
features 58
limitations 58



distributed data (continued)
vs. mirrored systems 58
distributing map requests 72
Document Object Model (DOM), about 40
documentation 22-28
Autodesk Developer Network (ADN) 28
Autodesk MapGuide 22-28
Autodesk MapGuide documentation 25
Autodesk MapGuide Web site 27
online discussion groups 27
third-party 26
double coordinate precision 119
downloading Autodesk MapGuide Viewers 35
draw priority, understanding 154
DWG files 112
converting to SDFs 33
creating layers with 158
DWG layers 158
creating 158
setting display styles for 171
Dynamic Authoring Toolkit 12, 14, 33
converting files 126
documentation for 25
sample applications 26
Dynamic HTML and Web browser APIs 40
dynamic layers 154
benefits 154
dynamic reports, creating 41

E

ECW files 15
editing
access keys 84
user and group accounts 83
EMBED tag, using 39
engineer, data 19
Enhanced Compressed Wavelet Image (ECW) 15
and RIC files 103
Enhanced Metatile symbols (EMF) 109
ER Mapper 108
error log 88
ESRI Coverage files, converting to SDFs 33
ESRI World files 105
extranet, defined 35

F

FAT file system 51
fault tolerance, distributed data 58
features
creating buffers around 141
keys 113
labels for 172
measuring distances between 139
new in Autodesk MapGuide Release 6 12
on a map 95

features (continued)

security 173

selecting 140

selecting from a list 100

viewing information about 138
fields for zoom location categories 147
file systems, FAT and NTFS 51
files

georeferencing 105

importing layers from 175

saving layers to 174
files and directories

.bil 108

.bna 33

.csv 33

.dgn 33

.dwg 33

.dxf 33

.mid/.mif 33

.mlf 61

.mwf 32

.shp 33

.smb 109

.tif 34

coverage 33

planning 48-50

security for 51

See also directories
filtering data 100
firewall, configuring 73
folders. See directories

G

generalizing data 34
geocoding
activating the Zoom Goto US Street Address
category 101
geocoding files
responsibility for 20
setting up on server 91
georeferencing files
ESRI World files 105
for RIC files 157
GeoTIFF files 107
header files 107
Maplnfo tab files 106
supported formats 105
georeferencing information for raster images 103
GeoSPOT BIL raster image format 107
GeoTIFF
files defined 107
georeferencing files 107
getLayerSetup() method, controlling layer access
from 53
getting started 18
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getVertices() method, controlling layer access
from 53
GIS (geographic information systems) 30
about 30
and map authors 19
concepts 30
features 30
understanding 30
GIS Design Server. See Autodesk GIS Design Server
glossary 177
groups, creating accounts 83

H

hard disk, space requirements 15
hardware requirements 15
HDR files 108
header files
example 107
for georeferencing raster images 107
Help 21
how Autodesk MapGuide components work
together 31-42
how to use this book 18
HREF tag, using 39
HTML pages
client-side scripts and applications 39
dynamic 40
embedding maps 39
responsibility for creating 20
HTML scripts
security 53

implementing Autodesk MapGuide application
46
improving map performance 62
insertion point. See reference points 110
installing
Autodesk MapGuide Author 124
Autodesk MapGuide Server 68
mandatory components 43
MapAgents 69
report engine 75
Web server 68-75
Web server software 69
Intergraph DGN files, converting to SDFs 33
intermediate Autodesk MapGuide users (getting
started) 18
Internet Explorer, supporting 65
intranet, defined 35
IP address, editing remote server 72
ISAPI, MapAgent 54
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Java

choosing as scripting language 63

skills for application developers 20

writing applications with 36, 40
Java Viewer. See Autodesk MapGuide Viewers
JavaScript

and client-side scripting 39

choosing as scripting language 63

skills for application developers 20
JScript. See JavaScript

K

keys 113
access. See access keys
defined 98

parsing 113

L

labels for features, overlapping 172
latitude, for zoom locations 147
latitude/longitude coordinates, converting 118
layer groups 154
advantages of 159
creating 159
deleting 176
examples 155
rebuilding 175
layers
access keys, assigning to 52
accessing via the API 45
adding
from external files 175
to maps 175
to reports 45
adding symbols
to point layers 111
to SMB files 110
and access keys 173
Autodesk DWG 158
available 136
changing priority 159
changing URLs 174
changing visibility status 174
controlling access with access keys 52
coordinate system units 166
copying 174
creating test layers 44
data sources for 160
deleting 176
deselecting 137



layers (continued)
designing 45, 116
displaying 136
draw priority, understanding 154
dynamic 154
filtering data 100
groups 159
improving performance 154
labels for features 172
list of 135
making visible by scale 117
making visible or invisible 136
map performance, improving 62
modifying multiple 174
names 116, 159
organizing 159
overlapping 172
planning process 116
point symbols 167
point, styles for 167
polygon, styles for 170
polyline, styles for 169
popup menu 156
previewing 137
priority 154, 159
properties 159-174
raster 108, 157
rebuilding 175
referencing separate SDFs 62
saving 174, 175
scaling for visibility 164
screen units 166
security 52, 53, 173
selectability 117
selecting 137
static 154
styles 162-171
symbols for 109-112
text styles 168
themes 99
turning on and off 137
using multiple layers to control data display
45
using separate layers to improve
performance 62
vector layers 155
visibility of 136
legend, popup menu 156
Lightweight Directory Access Protocol (LDAP) 70
lines, about 95
LINK switch 63
linking
an SDF and an SQL table 62
reports 149
SDFs to databases 44
to GIS Design Server map features 113

LiteView
about 36, 66
development considerations 66
understanding 36
load balancing 72
and third party software 73
loading Web documents linked to map features
139
location categories
adding 146
Zoom Goto 100
locations
creating zoom categories 146
zooming to 134, 146
log files
access logs 88, 90
error logs 88
map layer access 89
renaming 89
rotating 90
trace logs 88
logging user actions 150
longitude, for zoom locations 147

M

Mac OS 64

Active Server Pages (ASP) 64

Java Server Pages (JSP) 64

Perl 64

version required 17
Macromedia ColdFusion. See ColdFusion
Make Map Features Selectable option 140
making data available to MapGuide servers 61
map author

obtaining authoring privileges 19

responsibilities and required skills 19
map data

creating 94

gathering 94

getting information from your server

administrator 122

tracking with spreadsheet 120
map design

considerations 121

guidelines 121

issues 118
Map Explorer 127, 135

changing width 138

Design tab 135, 155

narrowing 138

resizing 138

View tab 135

widening 138

working with map layers 155
map feature keys, parsing 113
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map features 95

annotations 96

area features 96

compound line features 95
creating buffers around 141

in Spatial Data Files (SDFs) 95-96
keys 113

labels for 172

lines, polylines, and polypolylines 95

linked to Web documents 139
measuring distances between 139

multiple selection techniques 141

polygons and polypolygons 96
selecting 140

selecting from a list 100

text 96

viewing 138

viewing information about 138

map information, viewing 138
map layer access log 89

customizing 91

Map Layer Files (MLFs)

adding saved layers to maps 175
for multiple maps 154

for single maps 154

saving a layer to 174

map layers

about 154-155

adding from external files 175
Autodesk DWG 158
considerations 116
copying 174

data sources for 160
deleting 176

display ranges for styles 164
dynamic 154

groups 159

labels for features 172
making visible by scale 117
modifying multiple 174
names 116

planning 116

point symbols 167
polygon styles 170
polyline styles 169

popup menu 156

priority 154

properties 159-174

raster 157, 163

saving 174

scaling for visibility 164
security 173

selectability 117

setting properties 159-174
static 154

styles 162-171
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map layers (continued)
styles 162-171
symbols for 109-112, 168
text styles 168
tracking with spreadsheet 120
understanding 154-155
units for text and point 166
map legend, previewing 137
map performance
exporting theme categories 62
improving with Raster Workshop 63
improving with tiled TIFF files 63
reducing data resolution 62
storing points in an SQL table 62
trimming feature names 63
map resources, updating using a Web browser 42
map segments, measuring 139
map serving components 36
map viewing components 35
Map Window 127
popup menu 127, 128
map window
customizing popup menu 148
Map Window Files (MWFs)
about 126
authoring 32
controlling access 52
creating with Autodesk MapGuide Author 32
displaying 35
security for 52
spatial data 30
specifications 126
viewing with Web browsers 30
where to store 49
map window specifications, about 126
Map Window XML Files (MWXs) 12, 14, 33, 126
MapAgents
about 37
CGI 54
configuring to use remote server 71
Distributed Component Object Model
(DCOM) 55
ISAPI 54
NSAPI 54
remote 55, 71
Remote Procedure Calls (RPCs) 55
setting up 71
where to store 50
MapGuide Author. See Autodesk MapGuide
Author
MapGuide Server. See Autodesk MapGuide Server
MapGuide Viewer. See Autodesk MapGuide
Viewer
Maplnfo
georeferencing files 106
MID/MIF files, converting to SDFs 33



maps
adding layers from external files 175
changing Newmap.mwf 144
coordinate systems 144
creating 144-150
customizing printouts 142
list of layers 135
moving around in 133
opening with Autodesk MapGuide Author
132
page setup 142
panning 133
passwords 145
printing 142
publishing 151
saving locally 150
saving to Web server 150
styles for layers 162-171
templates, using 144
text layer styles 168
uploading to Web server 151
viewing 35
zooming 133
See also Map Window Files (MWFs)
Mapserver_IP registry value 72
MapTips 113, 138, 139, 147
Maximum 147
MDAC 16
version required for Autodesk MapGuide
Server 16
measuring
distances 139
map segments 139
memory, requirements 15
menus
customizing popup menus 148
map layer popup menu 156
Map Window popup menu 127, 128
MGMap component 66
MGMapApplet component 66
Microsoft Data Access Components 16
Microsoft Data Link (UDL) files 78
Microsoft Internet Explorer
and the Autodesk MapGuide Viewer ActiveX
Control 35
supporting 65
Microsoft Internet Information Server (IIS)
installing 70
Windows NT Option Pack 70
Microsoft Windows Installer (MSI) 68
MIME types, configuring manually 69
Minimum 147

mirrored data
combining mirrored and distributed servers
60
distributing requests to mirrored servers 60
features 58
limitations 58
mirrored systems vs. distributed data 58
Mobile Device Usage report 89
mobile devices, Mobile Device Usage report 89
monitoring server requests 88
MirSID files 15
and RIC files 103
multiple data servers
benefits 56
using 56-61
multiple display ranges 164
multiple servers, using
See also MapAgent
multiple simultaneous server requests 56
multiple style sets 164
Multi-Resolution Seamless Image Database
(M1SID)
about 15
and RIC files 103
MWE. See Map Window Files (MWFs)
MWX. See Map Window XML files (MWXs)

N

names
of attribute data sources 99
raster file conventions 104
SDF conventions 96
Netscape Navigator
and the Autodesk MapGuide Viewer Plug-In
35
supporting 65
Netscape Web servers
installing 70
required service packs 70
network, connections, responsibility for 20
new Autodesk MapGuide users (getting started)
18
new features
Autodesk MapGuide Author 6, 14
Autodesk MapGuide Server 6, 14
Autodesk MapGuide Viewer 6, 15
in Autodesk MapGuide Release 6 12
Newmap.mwf, overwriting 144
NSAPI 54
MapAgent 54
NTES file system 51
NULLNAME switch 63
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OBJECT tag, using 39
objects. See features
ODBC. See OLE DB
OLE DB
data sources 44
providers 20
providers installed with MDAC 79
taking data sources offline 87
online discussion groups 27
online Help 21
Autodesk MapGuide Viewer API 25
Autodesk MapGuide Viewers 23
Raster Workshop 23, 34
SDF Component Toolkit 26, 34
SDF Loader 23
Symbol Manager 23
opening maps with Autodesk MapGuide Author
132
operating systems
choosing 63
remote MapAgents 55
optimizing raster images 34
Oracle Spatial 11, 78, 112
data provider 155
layers, creating 155
Oracle Spatial data 37
Oracle Spatial provider 79
documentation for 24
organizing layers 159
overlapping display ranges 164
overlapping features 172
overview, Autodesk MapGuide 10, 30

P

page setup for printing maps 142
Pan mode, accessing 133
panning 133
parallel data requests 56
understanding 56
parsing map feature keys 113
passkeys
HTML scripts 53
Viewer API 51, 53
passwords
and server security 80
assigning to maps 145
controlling user access 53
for data resources and maps 51
specifying 145
vs. access keys and user IDs 81
path to log files 89
PDF
Autodesk MapGuide Developer’s Guide 25
Autodesk MapGuide User’s Guide 23
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performance 54-63
determining needs for 45
improving
via data preparation 61
via map authoring 61
via raster images 102
via site configuration 61
improving via raster images 103
MapAgents compared 54
multiple simultaneous server requests 56
scalability 56
using multiple servers 56-61
photographs. See raster images
pixel-based images. See raster images
planning
Autodesk MapGuide implementation 45,
47-66
data and its properties 116
security 50-54
Plug-In. See Autodesk MapGuide Viewers
Point Layer Symbol Manager 111
Point Layer Symbol Manager, adding symbols to
layers 112
point layers
adding new symbols 168
adding symbols to 112
setting display styles 167
specifying size units 166
points
about 95
accuracy of 119
labels for 172
layers 166
linking to attribute data 98
styles 167
symbols for 167
points and text, storing in an SQL table 62
polygon layers
adding symbols 110
display styles 170
polygons
about 96
polyline layers
adding symbols 110
combining style sets 170
creating complex line styles 170
defining multiple display styles 170
styles 169
polylines, about 95
polypolygons, about 96
popup menus
adding and deleting commands 148
commands 127
customizing 148
display and options 127
displaying 127
map layer 156



popup menus (continued)

Map Window 127, 128

modifying 127
precision, coordinates 119
previewing

layers 137

map legends 137
printing maps, page setup 142
priority of layers 154
processing map requests, about 37
product architecture 30
programmer. See application developer
project directories, setting up 49
projections, about 118
projects, grouping files into 49
properties

access keys 84

layer security 173

layers 159-174

modifying for multiple layers 174

passwords 145

popup menus 148

resources 85

security for layers 173

users and groups 83
Properties dialog box

Access Keys tab 84

Resources tab 85

Users/Groups tab 83
protocols, standardizing on 55
publishing maps 151

Q

questions, posting on discussion group 27

R

Raster Image Catalog (RIC) files
about 103
creating 34, 104, 157
format 103

manually generating 104
path to file 104
processing files within 104
referencing 157
supported formats 103
raster image file conventions 104
raster images
adding to maps 108
color depth specifications 104
controlling access

coordinate system specifications 103

exporting from ER Mapper 108
file formats, supported 101
grouping into catalog files 103
locating 104

raster images (continued)
optimizing 34
placing on maps 105
resolution specifications 104
role of data engineers 19
selecting transparent background 104
specifying
extents 104
parameters 104
search path 104
tiled TIFFs 102
working with 101
raster layers
adding to maps 157
creating 108, 157
data types 155
projecting into map coordinate systems 157
properties 159-174
style properties 163
Raster Workshop
about 34
generating
RIC files 104
tiled TIFFs 102
online Help 23
accessing 34
understanding 34
ReadMe file 24
rebuilding
layer groups 175
layers 175
redline layers 175
redline layers
adding symbols to 112
rebuilding 175
redlining 42
reference points, setting 110
remote MapAgents 71
communicating through firewall 55
communicating with server using same
operating system 55
editing registry settings 72
enhancing security 55
installing 71
Remote Procedure Calls (RPCs) 71
diagram 74
MapAgent 55
Removing Autodesk MapGuide Server 4.1 for
Autodesk GIS Design Server 69
renaming log files 89
replacing data sources 87
report scripts, creating 46
reports 149
and server-side scripting 41
creating scripts 46
customized 149
data requirements 149
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reports (continued)

designing with ColdFusion 149

generating 41

for points 149
for selected features 149

installing engine 75

linking 149

planning 45

responsibility for creating 20

sending keys to 113

serving 41

specifying layers that work with 45

specifying properties with Autodesk

MapGuide Author 149

Summary Usage 89

usage reports 89

using the View command 150

viewing 136, 150
requirements 15

Autodesk MapGuide Viewers 17
resolution

determining needs for 116

See also coordinate precision
resources

restricting access to 85-87

security for 53

taking offline 87
responsibilities

application developers 20

data engineer 19

developers 20

map authors 19

server administrators 20
restricting access to resources 85-87
RIC. See Raster Image Catalog (RIC) files
roles in Autodesk MapGuide development 18-20
rotating

log files 90

text 116
RPC. See Remote Procedure Calls (RPCs)

S

sample applications on the Autodesk MapGuide
Web site 27
satellite photos. See raster images
saving
layers 175
locally 150
to Web servers 150
views with bookmarks 135
scalability 56
scale range, tracking with spreadsheet 120
scale, to limit visibility 117
scaling, layer visibility 164
scripting languages 39, 63
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scripts
client-side 38
for reports 46
server-side 38
SDF Component Toolkit
about 34
and application developers 20
converting SDFs with 97
online Help 26, 34
understanding 34
writing applications 34
SDF Loader
about 33
and data engineers 19
and datum shifts 33
converting file formats 97
creating SDFs using 97
installing and testing 44
online Help 23, 34
restrictions 33
understanding 33
SDF. See Spatial Data Files (SDFs)
search paths, responsibility for 20
security
access keys 51, 52
and API access 173
assigning users to Authors users group 53
Autodesk MapGuide 51-54
Autodesk MapGuide Server 80
comparison 82
for layers (access keys) 173
for maps (passwords) 145
passwords 51, 53
planning 50-54
responsibility for 20
restricting access to resources 85-87
selecting method 82
setting for home directories and virtual
directories 51
user IDs 51, 53
Viewer API passkeys 51, 53
Web server 51
Windows 51
Security tab, setting map passwords 145
selecting coordinate systems 144
serial number
Autodesk MapGuide Author 125
server
administrator roles, responsibilities and
required skills 20
architecture, responsibility for 20
components 36
tracking usage 89
using more than one 56-61
Server Admin. See Autodesk MapGuide Server
Admin



server requests
monitoring 88
tracking 88
tracking with access logs 88
tracking with map layer access logs 89
tracking with trace logs 88

server security 50-54

server usage, tracking 89

server-side scripts and applications 38
about 41
responsibility for creating 20
understanding 41
where to store 49

serving maps, about 36

setting tracking IDs 150

SHP files 112, 155

SHP Provider
documentation for 24

SHP provider 79, 112, 155

single coordinate precision 119

size units, selecting 166

skills needed for Autodesk MapGuide roles 18-20

SMB files. See Symbol Manager

Solaris OS
Active Server Pages (ASP) 65
Java Server Pages (JSP) 65
Perl 65

spatial data 37
about 94
accessing without converting 37
acquiring and creating 19
converting 33
formats 94
setting access 78
supported formats 37
understanding 94

Spatial Data Files (SDFs)
about 96
applications, creating 97
controlling access 80
converting 33, 96
creating 96
illegal name characters 96
limitations 96
naming 96
optimizing performance 96
storing coordinates in a database 97
testing link to database 44
understanding 96
updating via the map 42
working with 94

SQL
data tables, controlling access 80
in Zoom Goto location categories 100
tables, improving map performance 62
Where clause 100

stand-alone applications 40
Standard Usage report 89
starting Autodesk MapGuide Author 125
starting Autodesk MapGuide Server 76
static map layers 154
improving performance 62, 154
stopping Autodesk MapGuide Server 76
strategy for Autodesk MapGuide development 43
style sets 162
styles
combining for polyline layers 170
display ranges for 164
map layers 162-171
point symbols 167
polygons 170
polylines 169
properties for raster layers 163
text 168
viewing information 136
Summary Usage report 89
Sun Solaris and the Autodesk MapGuide Viewer,
Java Edition 35, 63
support, technical 27, 28
symbol files, about 109-112
Symbol Manager
about 33
adding symbols to SMB files 110
creating SMB files 110
modifying SMB files 110
modifying symbols 110
online Help 23
reference points, setting 110
removing symbols from SMB files 110
symbol managers
making bitmaps transparent 109
pasting symbols 109
renaming symbols 109
symbols
.bmp 109, 167
.dib 109
.emf 109, 167
wmf 109, 167
creating and modifying libraries 14
display styles for point layers 167
for point layers 109
for polygon and polyline layers 109
for redline layers 109
making transparent 109
planning 116
setting transparency 109
specifying 167
working with 109-112
system requirements
Autodesk MapGuide Author 15
Autodesk MapGuide Server 16
system, installation 43
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tab files
and raster images 106
example 106
supported raster image formats 106
tags
APPLET 39
EMBED 39
HREF 39
OBJECT 39
tasks, what to do for your job 18-20
TCP protocol 55
technical notes and white papers 27
technical support 27, 28
templates, saving layers as 174, 175
terms, definitions 177
testing
Web server 71
your installation 43
text
about 96
linking to attribute data 98
rotating 116
styles 168
text layers
display styles 168
specifying size units 166
themes 172
creating 99, 172
planning 116
specifying data source for 98
third-party documentation 26
TIFF files
creating 34
tiled 102
tips and tricks on the Autodesk MapGuide Web
site 27
toolbar 130
button descriptions 130
using 130
trace log 88
tracking data spreadsheet, example 120
tracking IDs 150
getTrackingID() method 54
setting 150
setTrackingID() method 54
specifying 150
training 27, 28
TrueType font symbols (TTF) 109
turning layers on and off 137
tutorial.mwf, using to test installation 44
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UDL files 78
UDP protocol 55
unlock method, enabling access 53
updating data sources 87
updating via the map
databases 42
SDFs 42
URLs
linked to map features in GIS Design Server
layers 113
US Street Address
location category 148
requirements 148
Zoom Goto 101
usage reports 89
user accounts, creating 83
user groups 80, 81
creating accounts 83
editing accounts 83
user IDs 51, 53
user’s guide. See Autodesk MapGuide User’s Guide
users
creating accounts 83
editing accounts 83
users groups, Authors 83

Vv

VBScript
and client-side scripting 39
choosing as scripting language 63
skills for application developers 20
vector layers
creating 156-157
data types 155
properties 159-174
verifying coordinate systems 144
View tab of Map Explorer 137
Viewer. See Autodesk MapGuide Viewer
viewing reports 150
virtual directories 48, 49, 50
and HTML files 49
server side scripts and applications 49
vs. physical directories 49
Visual Basic, writing applications with 36, 40

w

Wavelet Image, about 15

Web browser
and Autodesk MapGuide 35
APIs and client-side scripting 40
choosing 63
installing and testing 43
scripts 39



Web root

and directory structures 48

including HTML files within folders 49
Web server

about 36

installing 43, 69

responsibility for 20

security 51

and ColdFusion template files 51

testing 43, 71

understanding 36
Web site

Autodesk MapGuide 27

responsibility for your 20
Webmaster, responsibilities 20
Where clause, filtering attribute data with 100
white papers and technical notes 27
windows (MapGuide), description 127
Windows 2000 Server

responsibility for 20

security 51
Windows Metafile symbols (WMF) 109
Windows NT Server

responsibility for 20

security 51
Windows operating systems, choosing a

Viewer/browser environment 63

Windows OS

Active Server Pages (ASP) 64

Java Server Pages (JSP) 64

Perl 64
Windows security, setting 51
working with maps, dynamically 41
World, ESRI georeferencing files 105

X

XY coordinates 118

y 4

ZIP codes, zooming to 134
Zoom Gotos 147
address data 100
controlling access to address definitions 80
creating data 46
creating location categories 146
definitions, viewing 136
geocoding files for 91
illegal characters 147
latitude and longitude 147
location categories 100
location name 147
planning the categories 45
required fields 147
US street address 134
US Street Address category, activating 101
working with categories 100
zoom locations, setting up 146
Zoom mode, accessing 133
zooming 133
to a location 134
to an address 134
to selected features 133
to specified area 133
to specified scale 133
to specified width 133
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