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Welcome to Autodesk MapGuide Viewer 

Introduction 

Autodesk MapGuide® Viewer allows you to interact with maps that were created using Autodesk MapGuide® 
Author. Using Autodesk MapGuide Viewer, you can zoom in and out on a map, find specific features, select 
features that meet certain criteria, display information about selected features, print the current view of the 
map, and more. 

In addition to this HTML-based help that you are currently viewing, there is also a Portable Document 
Format (PDF) version of the help called MGViewerHelp.pdf, which is located on the top level of the Autodesk 
MapGuide® CD. With this file, you can search and print the entire help contents easily. Note that you must 
have Adobe Acrobat Reader, which is included on the Autodesk MapGuide CD, installed on your computer 
to view MGViewerHelp.pdf.  

What Is a GIS 

Autodesk MapGuide® is a geographic information system (GIS). Unlike a typical map, which shows only 
spatial data such as roads, cities, and country borders, a GIS links attribute data such as population statistics 
to the spatial data in a map. This link provides the ability to analyze spatial data, letting you use map data 
in a whole new way. After you have worked with the map and the data to specify what you want to display, 
you can copy the current map view into a report or print it, giving your reports and presentations greater 
impact and clarity. 

Contents of the Maps 

The maps you work with in Autodesk MapGuide Viewer were assembled and edited in Autodesk MapGuide 
Author, a program in which the person creating the map (who is referred to as the map author) specifies the 
data that will be on the map. The map author can create display themes that vary the display of map 
features according to certain values. For example, one theme might display counties in a range of colors to 
indicate population, allowing you to quickly spot the counties with the lowest or highest populations. The 
map author also specifies the commands that appear in the popup menu, the data you can access, how far 
you can zoom in and get detail, the reports associated with the map, and more. 

Autodesk MapGuide Viewer displays only the popup menus, data, and reports that the map author 
included when creating the map. If you need data that is not included in the map you are viewing, we 
recommend that you contact the author of the map. 

Organization of Data into Layers 

The map author organizes the data in a map into map layers. Layers are like transparencies that can be 
stacked and viewed at one time, or viewed separately. For example, there might be one layer that contains 
roads, another that contains cities, and another that contains state boundaries. When you turn on all of the 
layers, you see a single map with all of the data: roads, cities, and states. To see only the states and cities, 
you can turn off the roads layer to hide the roads. 

The map author can also separate different types of data into separate layers, and even separate different 
levels of detail into separate layers. Additionally, because the map data is on separate layers, you can easily 
select the features you want from a specific layer without selecting overlapping features from other layers. 

A map can also contain groups of layers, which are called layer groups. With layer groups, you can turn on 
or off all of the layers in the group at one time. In the following illustration, "Cities" is a layer group. For 
more information about layers, see Working with Layers and Layer Groups. 
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Accessing Commands 

You can access commands in Autodesk MapGuide Viewer using either the toolbar buttons or the map 
window popup menu. The toolbar buttons appear across the top of the map window. 

  

For a description of each of the buttons on the toolbar, see the Toolbar Button Summary. 

The map window popup menu appears when you click the right button on your mouse (referred to as 
"right-clicking") anywhere in the map. 

  

After you right-click to display the map window popup menu, you can click one of the items in the menu 
to choose that command. When you click a command that has a right arrow next to it (such as Print), a 
secondary popup menu appears. 

  

When you right-click in the legend instead of in the map window, a separate legend popup menu appears. 
For descriptions of all of the menu commands in both the map popup menu and the legend popup menu, 
see Popup Menu Command Summary. 
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Available Versions of Autodesk MapGuide Viewer 

Autodesk MapGuide Viewer is available as a Microsoft® ActiveX® Control, a Netscape® Plug-In, and a Java™ 
Edition. Depending on your Web browser and system, you should download one of the following versions 
of the Viewer: 

�� If you are using Netscape® Navigator® 4.x, Microsoft Windows® 98 Second Edition, Windows NT® 4.0 
with Service Pack 6a, or Windows 2000 Professional with Service Pack 1, download Autodesk MapGuide 
Viewer Plug-In. 

�� If you are using Microsoft® Internet Explorer 5.x, Microsoft Windows 98 Second Edition, Windows NT 
4.0 with Service Pack 6a, or Windows 2000 Professional with Service Pack 1, download Autodesk 
MapGuide Viewer ActiveX Control. 

�� If you are using an Apple® Macintosh® or Sun® Solaris®, download the Java Edition of Autodesk 
MapGuide Viewer. For more information about the Java Edition, see About the Java Edition of Autodesk 
MapGuide Viewer. 

You can download and install more than one version of the Viewer. For example, if you want to use 
Autodesk MapGuide Viewer with both Netscape Navigator and Microsoft Internet Explorer, download and 
install both the Plug-In and the ActiveX Control. When you access certain Web pages, the Autodesk 
MapGuide ActiveX Control is automatically downloaded to your machine if it is not already installed. For 
more information, including information about how to delete the ActiveX Control, see Downloading and 
Installing the Autodesk MapGuide ActiveX Control Automatically. 

Copyright Information 

Apple and Macintosh are trademarks of Apple Computer, Inc., registered in the U.S. and other countries. 

Java, all Java-based trademarks and logos, Sun, and Solaris are trademarks or registered trademarks of Sun 
Microsystems, Inc. in the United States and other countries. 

Netscape and Netscape Navigator are registered trademarks of Netscape Communications Corporation in 
the United States and other countries. 

Microsoft, Windows, and ActiveX are registered trademarks of Microsoft Corporation in the United States 
and/or other countries. 

All other brand names, product names, or trademarks are the property of their respective holders. 

About the Java Edition of Autodesk MapGuide Viewer 

Because the Java Edition of Autodesk MapGuide Viewer is based on Java technology, you have the 
flexibility of viewing maps on platforms other than Windows, but some features do not work the same way 
as they do using the Plug-In or ActiveX Control versions of Autodesk MapGuide Viewer. The following 
traits are unique to the Java Edition. 

Printing 

Before you print, you must enter the size of the page to print in the Page Setup dialog box. 
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You can click the Print Test Page button to print a sample page that shows rectangles of different sizes to 
determine the best printing size. You then enter these dimensions in the Page Dimension text boxes in the 
Page Setup dialog box. 

Bookmarks 

If you are using the Plug-In and/or ActiveX Control in addition to the Java Edition, and you have created 
bookmarks for the Plug-In or ActiveX Control, you cannot access those bookmarks with the Java Edition. 

Copying 

Java provides no mechanism for copying maps to the Clipboard. Thus, the Copy > Copy command does 
not appear in the popup menu, and the Copy button does not appear on the toolbar. 

Colors 

Depending on your system, the quality of the colors displayed may vary. 

Regional Customizations 

The Java Edition will recognize changes you make to your Regional Settings or Input Locales for your 
system, as long as you use the default options. If you customize the number, time, date, or currency 
options, however, the Java Edition will not recognize them.  

Internet Explorer 

If you are using the Java Edition of Autodesk MapGuide Viewer with Internet Explorer and you click outside 
any Autodesk MapGuide Viewer dialog box, the dialog box will go behind the Internet Explorer window. 
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Using Autodesk MapGuide Viewer 

Opening a Map 

When you open a map in your Web browser, it launches Autodesk MapGuide Viewer to display the map. 
You can then change the view of the map by zooming, panning, or using bookmarks to see the exact 
portion of the map you want. 

To open a map 

1. Choose File > Open Location in Netscape Navigator (in Navigator 4.06, choose File > Open Page), or 
choose File > Open in Microsoft Internet Explorer. 

2. Enter the map's URL, and then click OK (in Navigator 4.06, click Open). 

3. If any of the initial layers in the map are password protected, you are prompted for a password. At the 
prompt, type your user name and password in the provided boxes. If you do not have a password, check 
with the author of the map.  
 
The map appears in the Autodesk MapGuide Viewer window. 

Changing the Map View 

You can do any of the following operations to change the view of a map: 

�� Zooming to a Specific Location or Address 

�� Zooming to a map width 

�� Zooming to a map scale 

�� Zooming in by a magnification factor of two 

�� Zooming to a rectangular area 

�� Zooming to selected map features 

�� Zooming to the previous view 

�� Zooming out by a magnification factor of two 

�� Zooming out to display the entire map 

�� Moving up, down, left, or right (panning) 

�� Saving the current view in a bookmark 

�� Viewing a bookmark 

�� Deleting a bookmark 

Zooming to a Specific Location or US Street Address (Zoom Goto Command) 

You can use the Zoom Goto dialog box to zoom to a location, such as an airport, or to a US street address or 
ZIP code. 

To display the Zoom Goto dialog box, click the Zoom Goto button on the toolbar, or right-click in the map 
and choose Zoom > Goto from the popup menu. 
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You can now do one of the following tasks. 

To zoom to a location: 

1. Click the Location tab, and then select a category from the Category list. 

2. Type a location name to use as the center of the map, type the map width to display, and then click 
OK.  
 
You can enter just a portion of the name you are looking for. Autodesk MapGuide will return a list of 
places that contain the text you entered. For example, to find San Francisco, you could type "San" to 
receive a list of all places that begin with "San," and then choose San Francisco from the list.  
 
Note You specify the width in the current display units. If the location you're zooming to is a point or 
text feature, type the width of the area you want to display in the map window. If the location is not a 
point or text feature and you specify a width, the width setting will be ignored. 

3. If the zoom location has an access key assigned to it, enter the access key. You will need to contact the 
author of the map if you do not know the access key. 

To zoom to a street address or ZIP code: 

1. Click the US Street Address tab (not available on all maps), and then enter a complete US street address 
(address, city, and state) or a ZIP code.  
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2. Type the map width to display, and then click OK.  
 
Note You specify the width in the current display units. 

Zooming to a Map Width 

You can zoom to a specific width in a map. 

Note You specify the width in the current display units. 

To zoom to a map width 

1. Right-click in the map, and then choose Zoom > Width from the popup menu to display the Zoom 
Width dialog box.  
 

  

2. Enter a value in the Zoom Width dialog box, and then click OK.  
 
The map zooms in or out to the width you specified, retaining the current center of the map. 

Zooming to a Map Scale 

You can specify the map scale to zoom to. Remember that the larger the second number in the scale ratio is, 
the more you will zoom out, so you will display a larger area with less detail. The smaller the second 
number is, the more you will zoom in, so you will display a smaller area with more detail. 
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To zoom to a map scale 

1. Right-click in the map, and then choose Zoom > Scale from the popup menu to display the Zoom Scale 
dialog box.  
 

  

2. In the text box, type the scale ratio you want to use. For example, to zoom to a scale of 1:200000, type 
200000 in the text box. 

3. Click OK.  
 
The map zooms in or out to the scale you specified, retaining the current center of the map. 

Zooming In by a Magnification Factor of Two 

You can click a point in the map to zoom in on that point. 

To zoom in by a magnification factor of two 

1. Click the Zoom button on the toolbar, or right-click in the map and choose Zoom > Zoom from the 
popup menu. 

2. Click a point to be the center of the redrawn map.  
 
The map zooms in on the point you clicked to display the map at twice the previous magnification.  
 
You can continue to zoom in by clicking another point in the map. 

3. When you finish zooming, press ESC, click the Select button on the toolbar, or choose Select > Select 
from the Map Window popup menu. Note that pressing ESC does not work if you are using the Java 
Edition of the Viewer on an Apple Macintosh computer. 

Zooming to a Rectangular Area 

You can use the mouse pointer to draw a rectangular area on the map and then zoom in to that area. 

To zoom to a rectangular area 

1. Click the Zoom button on the toolbar, or right-click in the map and choose Zoom > Zoom from the 
popup menu. 

2. Press the mouse button and drag to draw a rectangle over the area you want to display.  
 
When you release the mouse button, the rectangle disappears, and the map zooms in to display the area 
within the rectangle at the highest possible magnification.  
 
You can continue by zooming in on other rectangular areas. 



10   �   Autodesk MapGuide  

3. When you finish zooming, press ESC, click the Select button on the toolbar, or choose Select > Select 
from the popup menu. Note that pressing ESC does not work if you are using the Java Edition of the 
Viewer on an Apple Macintosh computer. 

Zooming to Selected Map Features 

After you select features in a map, you can zoom in to display just enough of the map to show those 
features.  

To zoom to selected map features 

1. Select one or more features. 

2. Right-click in the map, and then choose Zoom > Selected from the popup menu.  
 
The map centers on the selected features and zooms in far enough to display only the selected features. 

Zooming to the Previous View 

You can redraw the map at the previous zoom magnification and location. 

To zoom to the previous view 

�� Right-click in the map, and then choose Zoom > Previous from the popup menu, or click the Zoom 
Previous button on the toolbar.  

Zooming Out by a Magnification Factor of Two 

You can click a point on the map to recenter the map on that point and zoom out. 

To zoom out by a magnification factor of two 

1. Click the Zoom Out button on the toolbar, or right-click in the map and choose Zoom > Out from the 
popup menu. 

2. Click a point on which to center and redraw the map.  
 
The map zooms out on the point you clicked and displays the map at half the previous magnification.  
 
You can continue to zoom out by clicking another point in the map. 

3. When you finish zooming out, press ESC, click the Select button on the toolbar, or choose Select > 
Select from the Map Window popup menu. Note that pressing ESC does not work if you are using the 
Java Edition of the Viewer on an Apple Macintosh computer. 

Zooming Out to Display the Entire Map 

You can zoom out to display the entire map. 

To zoom out to display the entire map 

�� Click the Unzoom button on the toolbar, or right-click in the map and choose Zoom > Unzoom from 
the popup menu. 

Moving Up, Down, Left, or Right (Panning) 

You can move the map around to display areas that are outside of the current view.  
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To move up, down, left, or right (pan) 

1. Click the Pan button on the toolbar, or right-click in the map and choose Pan from the popup menu. 
Notice that the cursor changes to a "hand." 

2. Press the mouse button and drag to move the map around. 

3. Release the mouse button to redraw the map and show the new view.  
 
You can continue panning by dragging the map again. 

4. When you finish panning, press ESC, click the Select button on the toolbar, or choose Select > Select 
from the Map Window popup menu. Note that pressing ESC does not work if you are using the Java 
Edition of the Viewer on an Apple Macintosh computer. 

Saving the Current View in a Bookmark 

After you zoom and pan to position the map exactly as you want it, you can save the current view of the 
map as a bookmark. A bookmark saves all of the information about the current view of the map under a 
name you specify. By using the bookmark in the future, you can go directly to this same view of the map 
without having to zoom and pan again. To save the current view as a bookmark, do the following: 

To save the current view in a bookmark 

1. Right-click in the map, and then choose Bookmarks > Add Bookmark from the popup menu to display 
the Add Bookmark dialog box.  
 

  

2. Enter a name for this bookmark, and then click OK.  
 
Note Be sure to use a unique name for the bookmark. If you use an existing name, both bookmarks will 
appear in the menu under the same name with no way to tell them apart. The name you type or select 
for your bookmark cannot contain any commas (,), question marks (?), ampersands (&), or pound 
symbols (#). 

Viewing a Bookmark 

You can go directly to a map or portion of a map that you saved previously as a bookmark. 

To view a bookmark 

1. choose Bookmarks from the popup menu. 

2. Click the name of the bookmark you want to view. If you have added more bookmarks than can be 
displayed in the popup menu, choose Bookmarks > More Bookmarks from the popup menu, and then 
select the bookmark you want from the Goto Bookmark dialog box.  
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Deleting a Bookmark 

You can delete one or more bookmarks if you no longer need them. 

�� Choose Bookmarks > Delete Bookmarks from the popup menu, select the bookmark(s) you want to 
delete, and then click OK. 

Working with Map Features 

After you have opened your map and moved it around to display the features you want, you can identify 
the map features, measure distances between them, and follow any links they contain. 

�� Identifying map features 

�� Measuring distances 

�� Following links to Web pages 

Identifying Map Features 

When you pause the mouse pointer over a map feature, you see the name of that map feature displayed in a 
small yellow popup window called a MapTip. For example, when you position the mouse pointer over 
Washington, the MapTip displays the name of the city, as shown in the following illustration. 

  

The MapTip disappears when you move the mouse again. If a name has not been provided for this feature 
on this map, the MapTip does not appear. 

Also, if the map has a status bar, you will see the layer name and the name of the map feature displayed on 
the status bar when you pause the mouse pointer over the map feature, as shown in the following 
illustration. 
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In this illustration, the status bar indicates that the mouse is currently positioned over Washington, which 
is on the Major Cities layer. 

Measuring Distances 

You can measure the distance between two points on the map. You can also measure the distance between 
several points to get a cumulative total distance. For example, if you want to know approximately how far 
you would travel if you flew from Paris to London to New York, you could measure each leg of the trip and 
get a cumulative total. Note that, depending on which map projection the author of the map chose, the 
distances measured may vary in accuracy. For example, if the map author chose a projection that provides 
the most accurate results when you measure the distance between two points in France, the accuracy will 
decrease if you measure the distance between points across the world. For more information, contact the 
author of the map.  

To measure the distance between points on a map 

1. Right-click in the map, and then choose View > Distance from the popup menu. 

2. To measure the distance between two points, click the first point, and then pause the mouse pointer 
over the second point.  
 
As you move the pointer, the measurement of the distance appears dynamically in a MapTip (the 
yellow box), as shown in the illustration below. If the Display Mouse Position check box is selected in 
the Preferences dialog box, the coordinates of the cursor are displayed in the status bar.  
 

   
 
You may notice when you measure distances in some maps that the MapTip displays "Great Circle 
Distance" rather than "Distance." This means that the map author specified that the Great Circle 
distance formula be used for measuring distances instead of the default Euclidean formula. Great Circle 
distance measurement is more accurate than Euclidean measurement for maps that use geographic 
coordinate systems. In rare circumstances, you may notice that the MapTip for distance measurements 
changes from "Great Circle Distance" to "Distance" within the same map. If this happens, it means that 
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you have a selected a point that cannot be measured using the Great Circle method because it is outside 
the mathematical range of the map projection. 

3. To measure the distance from the second point to a third point, click the second point, and then pause 
the pointer over the third point.  
 
The distance between the second and third point appears on the status bar and in the MapTip display, 
along with the total of all distances measured. 

4. To clear the cumulative distance and exit the View > Distance function, click the right mouse button, 
double-click the left mouse button, or press ESC. Note that pressing ESC does not work if you are using 
the Java Edition of the Viewer on an Apple Macintosh computer. 

Following Links to Web Pages 

When you pause the mouse pointer over a feature that is linked to a Web page, the pointer changes from 

an arrow to a pointing hand  , as shown in the following illustration. 

  

The name of the feature appears in a MapTip, and the uniform resource locator (URL) of the Web page 
linked to this feature appears at the bottom of your Web browser window. To display the linked Web page, 
double-click the feature. 

Selecting Map Features 

When you select features on a map, you can then view a report that provides information about the 
selected features, or you can adjust the map display to zoom to the selected features. The number and type 
of selected features are displayed on the status bar at the bottom of the map. 

Note When you select a map feature, Autodesk MapGuide selects the feature by its key. Therefore, if you 
select a map feature that contains multiple points, each of which has the same key, each of those points 
will be selected. Similarly, if there are multiple features in the map with the same key, selecting one of those 
features will select all features that share that same key. 

You can do any of the following to select features on a map: 

�� Specifying the selection mode 

�� Selecting features within other map features 

�� Selecting features within a specified distance from other map features (View Buffers command) 

�� Selecting map features by name 

�� Selecting individual map features 



MGViewerHelp.doc   �   15 

�� Selecting all map features in a rectangular area 

�� Selecting all map features in a circular area 

�� Selecting all map features in a polygonal area 

�� Deselecting map features 

Specifying the Selection Mode 

By default, when selecting features inside a rectangle, circle, polygon, or buffer, Autodesk MapGuide selects 
only those features whose centroids (center points) are within that selection area. However, you can specify 
that you also want to select features that intersect the selection area. 

To specify the selection mode 

1. Right-click in the map, and then choose Help > Preferences from the popup menu to display the 
Preferences dialog box.  
 

  

2. Click the Selection Mode drop-down list, and then choose the method you want to use for selecting 
features inside of other features.  
 
If you choose Centroid (the default), only those features whose centroids are within the selection area 
will be selected. If you choose Intersection, features that touch, intersect, or are within the selection 
area will be selected. 

Selecting Features Within Other Map Features 

Autodesk MapGuide Viewer can select all map features that are within selected polygon map features. The 
polygons should be on their own layer in order for this command to work effectively. 

To select features within other map features 

1. Select the polygon map feature(s) containing the map features you want to select. 

2. Right-click in the map, and then choose Select > Within from the popup menu to display the Select 
Within dialog box.  
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3. Choose the map layer containing the map features you want to select should they fall within the 
polygon(s) you selected in Step 1, and then click OK.  
 
For example, if you selected a buffer feature in step 1 that represents a specific distance from a 
customer's location, and you want to find all Acme Widget resellers within that specified distance from 
the customer's location, you would select the layer that contains the reseller locations.  
 
All map features from the specified layer that fall within the previously selected polygon(s) are now 
selected.  

Selecting Features Within a Specified Distance from Other Map Features (View Buffers 
Command) 

By creating a buffer around selected map features, you can view all features that fall within that buffer. This 
is particularly useful in site selection. For example, you could create a buffer to find all vacant lots within 
two miles of your stores, or using a report that will calculate area, you could determine the total area within 
the buffers around your stores. 

To select features within a specified distance from other map features 

1. Select the map features around which you want to create buffers. 

2. Right-click in the map, and then choose View > Buffer from the popup menu.  
 
The View Buffer dialog box appears.  
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3. In the Buffer Offset Distance text box, type the distance you want the buffers to extend from the 
selected features, and then select the unit (such as miles or kilometers) you want to use from the drop-
down list.  
 
For example, to find all features within two miles of your stores, type 2 in the text box and choose "mi" 
from the unit list. Note that you can also use the up and down arrows to increase or decrease the 
distance.  

4. To treat all of the buffer areas as a single feature, instead of treating each buffer area as a separate 
feature, select the Construct One Buffer For All Selected Map Features check box.  
 
This is particularly useful if any of your buffers overlap and you do not want the overlapping area 
counted twice. For example, if you want to determine the total area around your stores, and two stores 
are close enough that their buffers overlap, you would not want to count the overlapping area twice. 
Overlapping buffers will also appear differently on the screen. For example, if you did not select this 
check box, overlapping buffers might display like this:  
 

   
 
If you did select this check box, however, the same buffers would display like this:  
 

   

5. In the Create Buffer On list, select the map layer on which you want to create the buffers, or type a new 
name to create a new map layer that contains only the buffers. 

6. In the Fill area, specify the style, color, and pattern to use for filling the buffer areas. 
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7. If you chose a hatch pattern for the fill, the color you specified is for the pattern, so you need to specify 
settings for the background behind the pattern. In this case, in the Background area, specify whether 
the background should be opaque (buffers cover the map features) or transparent (map features show 
through the buffers), and the color to use for the background. 

8. In the Edge area, specify the style, color, and thickness to use for drawing the outer line around the 
buffer areas. 

9. Click OK.  
 
Autodesk MapGuide creates the buffers around the selected features. To select the features within the 
buffers, you select the buffers, and then use the Select Within command to select map features from 
other layers that fall within the buffers.  
 
If you receive an error message about low memory while processing the buffers, see Improving Buffer 
Processing.  

Selecting Map Features by Name 

If you know the names of the map features you want to select, you can select them from a list. 

To select map features by name 

1. Right-click in the map, and then choose Select > Select Map Features from the popup menu to display 
the Select Map Features dialog box.  
 

   

2. In the Map Layers list box, select the map layer that contains the map features you want to select. 

3. In the Map Features list box, select the map features you want by doing one or more of the following:  

�� Click a single map feature. For example, click Connecticut to select it. 

�� Shift-click to select multiple contiguous features. For example, click Arizona, and then Shift-
click California. Arizona, Arkansas, and California are all selected. 

�� Ctrl-click to select multiple non-contiguous features. For example, after selecting Arizona 
through California, you could Ctrl-click Connecticut to add it to the selection without adding 
Colorado as well. You can also Ctrl-click to deselect individual features from the group of 
selected features. 

�� Click All to select all features in the list. 

�� Click Clear to deselect all features in the list. 

4. When you finish selecting the map features you want, click OK. 
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Selecting Individual Map Features 

You can easily select an individual map feature. 

To select individual map features 

Do one of the following: 

�� Turn on Selection mode by clicking the Select tool on the toolbar or by choosing Select > Select from 
the popup menu, and then click the feature. This selects the feature and deselects all previously selected 
features. 

�� While in Selection mode, Shift-click the feature. This adds the feature to the group of previously 
selected features. 

Selecting All Map Features in a Rectangular Area 

You can draw a rectangle to select all map features that fall within that rectangular area. 

To select all map features in a rectangular area 

1. Turn on Selection mode by clicking the Select tool on the toolbar or by choosing Select > Select from 
the popup menu. 

2. Click the left mouse button, drag the mouse pointer diagonally until the rectangle covers the area you 
want, and then release the mouse button.  
 
All map features that are within the rectangular area are now selected. 

Selecting All Map Features in a Circular Area 

You can draw a circle to select all map features that fall within that circular area. 

To select all map features in a circular area 

1. Right-click in the map, and then choose Select > Radius from the popup menu. 

2. Press and hold the left mouse button on a center point, drag to define the radius, and then release the 
mouse button.  
 
The radius appears dynamically on the status bar at the bottom of the map as you drag the pointer. 
When the pointer stops, the radius also appears as a MapTip.  
 
All map features that are within the circular area are now selected. 

Selecting All Map Features in a Polygonal Area 

You can draw a polygon to select all map features that fall within that polygonal area.  

To select all map features in a polygonal area 

1. Right-click in the map and choose Select > Polygon from the popup menu. 

2. With the left mouse button, click each point that you want to use as a vertex of the polygon. 

3. On the last vertex you want to use, double-click using the left mouse button.  
 
All map features that are within the polygonal area are now selected. 
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Deselecting Map Features 

You can deselect map features after you have selected them. 

To deselect one feature while leaving the other features selected 

�� Shift-click the feature you want to deselect. 

To deselect all features 

Do one of the following: 

�� Right-click in the map, and then choose Select > Clear from the popup menu. 

�� Press ESC. Note that this does not work if you are using the Java Edition of the Viewer on an Apple 
Macintosh computer. 

Working with Layers and Layer Groups 

The map legend displays layers and groups of layers, called layer groups. You can control the layers and layer 
groups in the following ways: 

�� Display or hide layers or layer groups 

�� Display or hide the list of layers in a layer group 

�� Turn on or off all the layers in a layer group 

�� Rebuild layers 

�� Show or hide a list of styles for a layer 

�� Show or hide a list of theme categories for a layer 

In the following illustration, "Cities" is a layer group, and the other items are layers. 

  

Displaying or Hiding Layers or Layer Groups 

You can display or hide the features on a map layer by turning the layer on or off. This is useful for viewing 
exactly the features you want to see. 

To turn on a layer or layer group 

�� Select the check box next to the layer or layer group's name in the legend. 

To turn off a layer or layer group 

�� Clear that check box next to the layer or layer group's name in the legend. 
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Note If you select more than one layer or layer group, and then select or clear the check box, the display 
status of all the selected items will be the same. 

Displaying or Hiding the List of Layers in a Layer Group 

You can show or hide the list of layers in a layer group. Note that showing or hiding the list of layers does 
not turn the layers on or off; it simply displays the layer names in the legend. 

To show the list of layers in a layer group 

�� Right-click the layer group and choose Expand from the popup menu, or simply double-click the layer 
group. 

To hide the list of layers in a layer group 

�� Right-click the layer group and choose Collapse from the popup menu, or simply double-click the layer 
group.  

To change the status of multiple layer groups 

�� Select multiple layer groups and then choose Expand or Collapse from the popup menu. 

Turning On or Off All the Layers in a Layer Group 

You can turn on or off all of the layers in a layer group with a single command. 

To turn on all the layers in a layer group 

�� Right-click the layer group and choose Turn On All Layers from the popup menu. 

To turn off all the layers in a layer group 

�� Right-click the layer group and choose Turn Off All Layers from the popup menu. 

Rebuilding Layers 

If a layer is not displaying properly, such as during a server error, you can rebuild it. If the map contains 
layer groups, you can rebuild all of the layers in the layer group. You can rebuild any layer except a buffer 
or redline layer. 

The following illustration shows a layer that did not download correctly, indicated by the icon to the left of 
the layer name. 

  

To rebuild layers 

1. Select one or more layers or layer groups in the legend. 

2. Right-click and choose Rebuild from the popup menu. 

Showing or Hiding a List of Styles for a Layer 

If a map layer has styles assigned to it, you can show or hide the list of styles for the layer. 
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To show the list of styles for a layer 

1. Select one or more layers in the legend. 

2. Right-click and choose Expand from the popup menu. 

To hide the list of styles for a layer 

1. Select one or more layers in the legend. 

2. Right-click and choose Collapse from the popup menu. 

Showing or Hiding a List of Theme Categories for a Layer 

If the map author created a theme for a layer, the categories for that theme appear below the layer name in 
the legend. You can choose whether or not to display the names of these theme categories in the legend by 
expanding or collapsing the list. 

To show or hide a layer's theme categories 

�� To expand a list, right-click the layer name in the legend and then choose Expand, or simply double-
click the layer name.  

The theme categories for the layer appear below their names in the legend. 

�� To compress a list, right-click the layer name in the legend and then choose Collapse, or simply double-
click the layer name.  

The theme categories for the layer disappear so that only the layer name is displayed in the legend. Note 
that although the list is collapsed, the theme categories are still active on the map. 

Viewing Reports 

Viewing a report provides information about selected map features or about a specified point. When you 
view a report, only information for the features you select appears in the report, so you get only the 
information you need. The reports available for the current map depend entirely on what reports the 
author of the map has set up and made available. For example, the author could set up a report that 
provides population and average household income, so that when you select cities and view the report, you 
will get the population and income information for those selected cities only. 

To view a report for selected map features 

1. Select the map features about which you want a report. 

2. Right-click in the map and then choose View > Report from the popup menu, or click the Report button 
on the toolbar to display the View Report dialog box.  
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3. Choose the report you want to view, and then click OK.  
 
By default, the report appears in a separate browser window.  

To view a report about a specific point 

1. Right-click in the map and then choose View > Report from the popup menu, or click the Report button 
on the toolbar to display the View Report dialog box. 

2. Choose the report you want to view. 

3. Click a point in the map.  
 
By default, the report displays in a separate browser window.  

Customizing the Display 

You can use the Preferences dialog box to customize the selection mode and the status bar. You can also use 
the Preferences dialog box to specify the selection mode (for more information, see Specifying the selection 
mode). 

The preferences you specify are stored with your copy of Autodesk MapGuide Viewer, so all maps you view 
will use these settings, and you do not need to set preferences for every map. Note, however, that some of 
these settings can be controlled by API methods, so an application developer may have changed one or 
more of these settings. If a map author created a map without a status bar, the status bar preferences you 
specified are ignored when you display that map. 

If the current map was published without a Help > Preferences command on the popup menu, you will not 
be able to set preferences while viewing this map. Instead, view a map that does contain the Help > 
Preferences command, and then set the preferences. 

To customize the display 

1. Right-click in the map, and then choose Help > Preferences from the popup menu to display the 
Preferences dialog box.  
 

   

2. In the Map Units box, choose USA Units to display distances and map widths in feet/miles, or choose 
Metric to display distances and map widths in meters/kilometers. 

3. To display the coordinates of the mouse pointer's position on the status bar as you move the mouse 
around on the map, select the Display Mouse Position check box, and then select the type of 
coordinates you want from the Units drop-down list. If you select "Mapping Coordinate System," the 
coordinates will be displayed in the units from the map's coordinate system.  
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Tip If there is not enough room on the status bar to display the mouse coordinates, clear the Display 
Map Scale check box and/or the Display Map Width check box to make more room.  

4. To display the map scale on the status bar, select the Display Map Scale check box. 

5. To display the map width on the status bar, select the Display Map Width check box. 

6. Click OK. 

Copying and Pasting Maps 

You can copy the current map view in Autodesk MapGuide Viewer and then paste it into another 
application. When you copy the map view, it is copied to the Windows Clipboard, so that you can then 
paste the map view into another Windows application. 

You can also copy the current view of the map as a URL. This is useful if you want to create a link from a 
Web page to this view of the map and you need to know the URL to link to. 

Note Copying the map view to the Clipboard is not supported in the Java Edition of Autodesk MapGuide 
Viewer, but copying the map view as a URL is supported. 

To copy and paste the map view 

1. Use the Zoom and Pan commands from the popup menu or from the toolbar to display only the 
portion of the map you want to see. For more information about zooming and panning, see Changing 
the Map View. 

2. Right-click in the map, and then choose Copy > Copy from the popup menu, or click the Copy button 
on the toolbar. The map view is now copied to the Clipboard.  
 
Note The Windows keyboard shortcuts for Copy and Cut are not available in Autodesk MapGuide 
Viewer for copying or cutting maps. 

3. Switch to the application in which you want to paste the map view. 

4. Choose Edit > Paste.  
 
The view of the map you copied now appears in the application. 

To copy the map view as a URL 

1. Use the Zoom and Pan commands from the popup menu or from the toolbar to display only the 
portion of the map you want to see. 

2. Right-click in the map, and then choose Copy > As URL from the popup menu.  
 
The URL describing the map view is now copied to the Clipboard. 

Improving Performance 

You can improve the performance of Autodesk MapGuide Viewer by improving processing speed, raster 
display quality, and buffer processing. 

�� Improving processing speed 

�� Improving raster display quality 

�� Improving buffer processing 
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Improving Processing Speed 

There are a number of factors that can affect speed, some of which are known issues with specific Web 
browsers. The best way to improve performance is to author your maps with performance in mind. See the 
Autodesk MapGuide User's Guide and online help for more information. 

Improving Raster Display Quality 

Raster images are pictures, such as photographs, that are made up of small pixels, or cells. Raster images 
display differently from the vector (line- and point-based) drawing data in the map, such as roads and 
cities. If a raster image displays poorly, do one of the following: 

To change the resolution of a raster image 

�� If a raster image appears to be at the wrong resolution, right-click the layer that contains the raster 
image, and then choose Rebuild from the legend popup menu. To rebuild multiple layers at one time, 
select the layers before choosing Rebuild. To rebuild all the layers in one or more layer groups, select the 
layer group or groups before choosing Rebuild. 

To change the colors in a raster image 

�� If the colors in a raster image do not display correctly, minimize your Web browser window and then 
maximize it again. If the colors still do not display properly, set your Windows color palette to the 
highest number of colors. If your graphics card does not support more than 16 colors, the colors in 
some raster images will not display properly. 

To change the color palette setting 

1. In Windows 95, Windows 98, Windows NT, or Windows 2000, click the Start button, click Settings, and 
then click Control Panel. 

2. Double-click the Display icon. 

3. Click the Settings tab, and then choose the highest color setting in the Color Palette box.  
 
In some cases, using True Color mode can cause intermittent problems with Netscape Navigator, so you 
should use the next highest setting instead. For details, see Known Issues. 

Note If you are using the Java Edition of Autodesk MapGuide Viewer, the quality of the colors displayed 
can vary depending on your system. 

Improving Buffer Processing 

When you use the Construct One Buffer For All Selected Map Features option when creating buffers, and 
the buffering process fails with a message indicating low memory, try decreasing the buffer offset distance. 
If that is not possible, try creating a large, single buffer. 

To create a large, single buffer 

1. Follow the steps for creating buffers, but in step 1, select only half of the features you originally 
selected. 

2. After creating the buffer for these features, select the remaining features that you want to buffer. 

3. Create a buffer around these features. 

4. Shift-click to select both buffers. 
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5. Create a new buffer around the two existing buffers. Use a very small value for the buffer offset 
distance, such as 0.01, to preserve the size of the two original buffers. 

Preparing to Print a Map 

When you print a map, you can include a title, a legend, the map's scale, a North arrow, the map's URL, 
and the current date and time. Also, you can specify the scale of the map you want to print, or you can 
have MapGuide automatically scale the map to fit the printed page. The following steps explain how to 
print the map when you use the Print > Print command from the popup menu in Autodesk MapGuide 
Viewer. If your map is embedded (if it appears within a Web page, rather than appearing in its own 
window), and you use your Web browser's print commands, the settings you specify in the following steps 
will not affect the way the map prints. 

Note  If you are using the Java Edition of Autodesk MapGuide Viewer, this dialog box will have some 
additional options you need to set. For more information, see About the Java Edition. If you are using the 
Java Edition of Autodesk MapGuide Viewer with Internet Explorer, and you click outside the Page Setup 
dialog box, the dialog box will go behind the Internet Explorer window. 

To prepare to print a map 

1. Right-click in the map, and then choose Print > Page Setup to display the Page Setup dialog box.  
 

  

2. To print a title at the top of the map, select the Title check box and type the title in the Title text box. 
You can enter multiple lines for the title by inserting "\n" where you want line breaks. 

3. To print the legend with the map, select the Legend check box.  
 
If you chose to print the legend, note that the printed legend includes only visible layers. If the layer 
names are too long, they may be truncated. 

4. To print a bar showing the scale of the map, select the Scale Bar check box. 

5. To print a North arrow on the map, select the North Arrow check box. If the map uses arbitrary XY 
coordinates, this option is cleared by default but is still available. 

6. To include the map's URL in the footer of the printed map, select the URL check box. 
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7. To include the current date and time in the footer of the printed map, select the Date And Time check 
box. 

8. To print the map at a specific map scale, click Specify Scale, and then select the scale you want from the 
Scale list. To scale the map to fit the printed page, click Fit To Page.  
 
No matter what scale you select, only the currently displayed map area prints. If the map is displayed at 
1:40,000, and you specify that it should print at 1:70,000, the printed map will not show the larger area 
that would display at 1:70,000. Instead, only the area that is displayed at 1:40,000 is printed, at the 
scale of 1:70,000. 

9. Click OK.  

You are now ready to print the map. 

Printing a Map 

You can use either of the following methods to print a map: 

�� Use the Print > Print command from the map window's popup menu in Autodesk MapGuide Viewer. 
When you use this command, the map prints according to the current Page Setup settings. Note that if 
the Autodesk MapGuide Viewer is embedded in a Web page, this command prints only the map, not 
the entire page. 

�� Use the File > Print command in your Web browser. Note that if the Plug-In version of Autodesk 
MapGuide Viewer is embedded in a Web page, this command prints only the map, not the entire page. 

To print the map 

1. Click in the map to ensure that the frame to be printed is active. 

2. Use the Zoom and Pan commands to adjust the view in the map window to the area you want to print, 
or go to an existing bookmark. 

3. Use one of the methods described above to activate the Print command. 

4. Specify the settings you want in the Print dialog box, and then click OK. If you are using the Java 
Edition of Autodesk MapGuide Viewer, you will first need to specify the page dimensions in the Page 
Setup dialog box. 
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Advanced Topics 

URL Parameters 

When you create a bookmark, you are simply saving the URL of the map with a set of parameters that 
indicate the map width, center point, and more. When you use a bookmark, Autodesk MapGuide Viewer 
reloads this URL with all the parameters that indicate exactly how to display the map. 

If you know the URL of the map you want to view, and you know some of the values you want to use for 
particular parameters, such as the latitude/longitude of the center of the map, you can type them directly 
into the URL box in your browser, rather than manually moving the map. For example, if you know that 
the map name is amap.mwf and is located on www.mapguide.com, and you know the center point, map 
width, and map units, you could type the following URL: 

http://www.mapguide.com/amap.mwf?Lat=-110.0&Lon=43.1&Width=100&Units=mi&ext=.mwf 

The format of the URL should always be the URL of the map, followed by a question (?) mark, followed by 
the parameters you want to use (each separated by "&"), and lastly followed by "&ext=.mwf". 

The following list shows all available URL parameters for Autodesk MapGuide Viewer. Default values are 
shown in bold. Parameters that include "Target" in their name accept reserved target names. See the 
Reserved Target Window Names table following the Parameter table. 

ParameterParameterParameterParameter    DescriptionDescriptionDescriptionDescription    

StatusBar Specifies whether to display the status bar. [On | Off] 

ToolBar Specifies whether to display the toolbar. [On | Big | Off] 

LayersViewWidth Specifies the width of the map layer legend in pixels. A value of zero completely hides 
the map layer legend. Default: 150 

Lat Latitude of the center of the area to display. Specify the value in decimal degrees. You 
must use a period (.) as the delimiter, for example, "25.333333". This parameter works 
only when used with the Lon and Scale parameters, or with Lon, Width, and Units. 

Lon Longitude of the center of the area to display. Specify the value in decimal degrees. You 
must use a period (.) as the delimiter, for example, "-45.888888".  This parameter works 
only when used with the Lat and Scale parameters, or with Lat, Width, and Units. 

Width The width of the area displayed in Autodesk MapGuide Viewer using the units defined 
by the Units parameter. This parameter only works when used with the Lat, Lon, and 
Units parameters. 

Scale Scale of the initial display, either a real or integer value. This parameter works only 
when used with the Lat and Lon parameters. If not specified, a scale that displays the 
entire map within the map window is selected automatically. This setting overrides the 
Width parameter, if specified. 

Units Units used to specify the width. This parameter works only when used with the Lat, 
Lon, and Width parameters. [MI | KM | M | FT]  

Selobjs Specifies a list of map features to select after Autodesk MapGuide Viewer is loaded and 
has displayed the map. The map features are identified by specifying the name of the 
layer that they are on, followed by their keys. Syntax: 
Selobjs=<MapLayer>,<Key_1>,...,<Key_N> See examples below. 
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DefaultTarget Specifies the name of the target window where Autodesk MapGuide Viewer will display 
HTML documents, as well as URLs referenced in the OpenUrl and OpenMap actions. 
These actions can be defined when customizing the popup menu in Autodesk 
MapGuide Author. Default: _blank 

ObjectLinkTarget Specifies the name of the target window where Autodesk MapGuide Viewer will display 
the URL associated with a map feature. Default: ObjectLink 

ReportTarget Specifies the name of the target window where Autodesk MapGuide Viewer will display 
reports returned from the View > Report popup menu command. Default: Report 

ErrorTarget Specifies the name of the target window where Autodesk MapGuide Viewer will display 
error messages. Default: Error 

URLList Specifies whether Autodesk MapGuide Viewer should generate an HTML document that 
lists the names and links of the selected map features. The HTML document is displayed 
in the URLListTarget window whenever the user selects map features that have URLs 
associated with them. [On | Off ] 

URLListTarget Specifies the name of the target window where Autodesk MapGuide Viewer will display 
its URLList. Default: ObjectLink 

AutoLinkLayers Specifies the name of a map layer that automatically displays map feature URL link 
information in the AutoLinkTarget window. The URLs are displayed in the 
AutoLinkTarget window.  

AutoLinkTarget Specifies the name of the target window where Autodesk MapGuide Viewer will display 
the URLs downloaded from the AutoLinkLayers. Default: ObjectLink 

AutoLinkDelay Specifies the number of seconds before the next URL associated with a map feature from 
an AutoLinkLayer will be displayed in the AutoLinkTarget window. Default value is 20. 
If 0 seconds is specified as the delay, the automatic timed update feature will be 
disabled, and the AutoLinkTarget window will be updated when the mouse passes over 
a map feature on an AutoLinkLayer. 

Reserved Target Window Names 

All of the target option parameters also accept the following reserved target window names: 

Target NameTarget NameTarget NameTarget Name    DescDescDescDescriptionriptionriptionription    

_blank Loads the link into a new blank browser window. The window has no name. 

_parent Loads the link into the immediate parent of the window in which the link was clicked.

_self Loads the link into the same window as the one in which the link was clicked. 

_top Loads the link into the full body of the window in which the link was clicked. 

Examples 

The following examples show map URLs with parameters added to them. 

�� http://www.mapguide.com/maps/usa.mwf?Selobjs=States,CA,TX&ext=.mwf 

�� http://www.mapguide.com/maps/world.mwf?Lat=50.0&Lon=43.1&Width=10000&Units=mi&ext=.mwf 

�� http://www.mapguide.com/maps/usa.mwf?Lat=39.86&Lon=-106.76&Scale=6000000.00&ext=.mwf 
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�� http://www.mapguide.com/amap.mwf?StatusBar=On&URLList=On&LayersViewWidth=0&DefaultTarge
t=MAINAREA &LAT=-110.0&Lon=43.1&Width=100&Units=mi&ext=.mwf  

�� http://www.mapguide.com/amap.mwf?StatusBar=On&URLList=On&AutoLinkLayers=Billboards&Layers
ViewWidth=1 
&DefaultTarget=MAINAREA&URLListTarget=WEBSITES&AutoLinkTarget=BILLBOARD&AutoLinkDelay=
10&LAT=-110.0 &Lon=43.1&Width=100&Units=mi&ext=.mwf 

Downloading and Installing the Autodesk MapGuide ActiveX Control 
Automatically 

When Web page authors add maps to their Web pages, they can also set up the pages so that the Autodesk 
MapGuide ActiveX Control is automatically downloaded and installed on your machine when you access 
those Web pages. If you use Microsoft Internet Explorer 5.x, the ActiveX Control will be installed in a folder 
named Downloaded Program Files under the Windows or Winnt folder.  

Removing the Autodesk MapGuide ActiveX Control 

Microsoft Internet Explorer 5.x provides an automated method for removing the Autodesk MapGuide 
ActiveX Control.  

To remove the Autodesk MapGuide ActiveX Control 

1. Use Windows Explorer to navigate to the Downloaded Program Files folder. 

2. Click the Autodesk MapGuide ActiveX Control item in the folder, and then right-click and choose Remove 
from the popup menu.  
 
This deletes the file and removes it from your Windows Registry. 

Updating the Autodesk MapGuide ActiveX Control 

If you are using Microsoft Internet Explorer 5.x, you can automatically update the Autodesk MapGuide 
ActiveX Control. 

To update the Autodesk MapGuide ActiveX Control 

�� In Windows Explorer, click the ActiveX Control, and then right-click and choose Update from the 
popup menu. The program then checks the site from which you downloaded the ActiveX Control to see 
if there is a later version. If there is, it downloads and installs it. 

Customizing Autodesk MapGuide Viewer 

Autodesk MapGuide Viewer exposes an API that allows you to develop highly specialized applications that 
can display and query maps for use on an intranet or the Internet. You can use JScript or VBScript to 
develop applications for Microsoft Internet Explorer, or use Java and JavaScript to develop applications for 
Netscape Navigator. 

The documentation for the API, Autodesk MapGuide Viewer API Help, provides all of the information you 
need to begin developing applications. It describes the different features, methods, properties, and events in 
the API and includes several sample applications that you can use to get a quick start. 
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Reference 

Toolbar Button Summary 

The following table shows each of the buttons on the toolbar, their accompanying popup menu 
commands, and a description of each. Note that some of these buttons may not appear if the map author 
removed the corresponding commands from the popup menu. 

ButtonButtonButtonButton    CommandCommandCommandCommand    DescriptionDescriptionDescriptionDescription    

  
Copy > Copy Copies the current map view to the Clipboard (not available in the Java 

Edition). 

  
Select Selects a feature in the map. 

  
Pan Moves the map around to display areas that are outside of the current 

view. 

  
Zoom > Zoom Zooms in by a magnification factor of two on the point that you click, or 

zoom in to the rectangular area you draw with the mouse. 

  
Zoom > ZoomOut Zooms out by a magnification factor of two from the point you click to 

display a larger area of the map. 

  
Zoom > Zoom Previous Returns to the previous zoom magnification and location. 

  
Zoom > Zoom Goto Zooms to a specified location or US street address. 

  
Zoom > Unzoom Zooms out to display the entire map. 

  
View > View Reports Generates a report for the selected map features. 

  
Stop Stops or interrupts the map display from updating and dynamic map 

layers from downloading. 

  
Help > Help Contents Opens the online Help to get information about viewing maps. If you do 

not have the Help installed on your computer, it will be opened from the 
Autodesk MapGuide Web site. 

 

Popup Menu Command Summary 

The following table describes the commands that may appear in the popup menu when you right-click in 
the map window. You may not always see all of these commands, or you may notice some custom 
commands not in this list; which popup menu commands appear depends on how the map author created 
the map. 

Underlined commands (links) in the table are linked to a help topic that provides more information about 
using that command. Click the link to view the associated topic. 

ComComComCommandmandmandmand    DescriptionDescriptionDescriptionDescription    
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Pan Moves the map around to display areas that are outside of the current view.

Reload Reloads the current map at the current zoom scale. 

Print > Page Setup Displays the Page Setup dialog box, where you can specify settings for 
printing the map.  

Print > Print Prints the map. 

Copy > Copy Copies the current map view to the Clipboard (not available in the Java 
Edition). 

Copy > Copy As URL Copies the current map location to the Clipboard as a URL. 

Zoom > Zoom Zooms in by a magnification factor of two on the point that you click, or 
zoom in to the rectangular area you draw with the mouse. 

Zoom > Zoom Goto Displays the Zoom Goto dialog box, where you specify the location or US 
street address you want to zoom to. The author of the map specifies the 
types of locations, so the types of locations in this dialog box vary. 

Zoom > Zoom Width Displays the Zoom Width dialog box, where you specify the width, in 
current units, of the area that you want to display in the map window. 

Zoom > Zoom Scale Displays the Zoom Scale dialog box, where you specify the scale at which 
you want to view the map. 

Zoom > Zoom Selected Zooms to display all of the selected features. 

Zoom > Zoom Previous Zooms to the previous zoom magnification and location. 

Zoom > Zoom Out Zooms out by a magnification factor of two from the point you click to 
display a larger area of the map. 

Zoom > Unzoom Zooms out to display the entire map. 

Bookmarks > Add Bookmark Displays the Add Bookmark dialog box, where you can specify a bookmark 
name for the current map view and save it as a bookmark.  

Bookmarks > Delete 
Bookmarks 

Displays the Delete Bookmarks dialog box, where you can choose a 
bookmark to delete. 

Bookmarks > (bookmark name) Adjusts the map view to display the area that was saved under this 
bookmark name. 

Select > Select Turns on Selection mode so that you can select one or more features in a 
map.  

Select > Select Map Features Displays the Select Map Features dialog box, where you select from a list of 
the map features.  

Select > Select Radius Selects the map features that fall within a circle with the radius you specify 
from a specific point. 

Select > Select Polygon Selects the map features that fall within a polygon you draw. 

Select > Select Within Selects the map features that fall within the selected map features. 
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Select > Select Clear Clears the currently selected map features. You can also press ESC to clear 
the selection. Note that pressing ESC does not work if you are using the 
Java Edition of the Viewer on an Apple Macintosh computer. 

View > View Reports Generates a report for the selected map features. 

View > View Buffer Creates buffers around the selected map features. 

View > View Distance Displays the distance between two points, as well as the cumulative 
distance of all measurements made. 

Help > Preferences Displays the Preferences dialog box, where you can specify the map units, 
selection mode, and status bar settings. 

Help > Help Contents Displays the Autodesk MapGuide Help or the Help created by the author of 
the map. If you do not have the Help installed on your computer, it will be 
opened from the Autodesk MapGuide Web site. 

Help > About Displays information about your version of Autodesk MapGuide Viewer. 

Stop Stops or interrupts the map display from updating and dynamic map layers 
from downloading. This command is available in the Map Window popup 
menu if you right-click in the map while the map is loading. 

Continue Continues updating the map display and downloading dynamic map 
layers. This command is available in the Map Window popup menu if you 
right-click in the map while the map is loading. 

The following table describes the commands that appear in the popup menu when you right-click a layer or 
a layer group in the legend: 

CommandCommandCommandCommand    DescriptionDescriptionDescriptionDescription    

Rebuild Rebuilds the selected layer or all the layers in a layer group. 

Expand (layer) Displays all of the styles for that layer. 

Expand (layer group) Displays the list of layers in the layer group. 

Collapse (layer) If a map layer listed in the legend shows all of the layer styles, collapses the list to 
show only the layer names. 

Collapse (layer 
group) 

Collapses the list of layers in the layer group, displaying only the layer group name. 

Expand Theme Displays the names of the theme categories for the layer. This command is available 
only when a single layer is selected. 

Collapse Theme Hides the list of theme categories for the layer. This command is available only when 
a single layer is selected. 

Turn On All Layers Available only for layer groups, turns on all the layers in a layer group. 

Turn Off All Layers Available only for layer groups, turns off all the layers in a layer group. 
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Release Notes 

Known Issues 

The following general notes include known problems or issues with using Autodesk MapGuide Viewer 
Release 6: 

�� Transparent portions of bitmap symbols don’t print properly on PostScript printers 

�� Selected polygons print in white on PostScript printers 

�� Dashed lines print as solid lines 

�� Displaying selected features under raster layers 

�� VBA not supported in Release 6 

�� Problems with HP LaserJet printers 

�� Printing problems with PCL printer drivers 

�� Viewing a report for multiple features 

�� Error message "Missing parameter 'ITEM'" 

�� Web browser window displaying behind other windows 

�� Map scale rounded up or down 

�� Legend width in Plug-In and Java Viewer 

�� ActiveX Control cannot open reports whose names contain double quotation Marks 

�� Issues with Microsoft Internet Explorer 

�� Issues with Netscape Navigator 

�� Issues with the Java Edition of the Viewer 

Transparent Portions of Bitmap Symbols Don’t Print Properly on PostScript Printers  

Print to a non-PostScript printer or install a driver for your PostScript printer that supports Hewlett-Packard 
Graphics Language (HPGL) or Printer Control Language (PCL). For example, if your printer is currently 
configured with an HP LaserJet 4M printer driver, choose Start > Settings > Control Panel > Printers and add 
a second printer that uses the HP LaserJet 5L PCL driver. 

Selected Polygons Print in White on PostScript Printers 

If you select polygons using the Autodesk MapGuide Viewer ActiveX Control or Plug-In, and then print to a 
PostScript printer, the selected polygon always prints with a white fill. To solve this problem, try using a 
different printer driver (such as PCL driver), or print to a non-PostScript printer. 

Dashed Lines Print as Solid Lines 

Some Hewlett Packard printers, such as the 5N model, print dashed lines as solid lines. To fix this problem, 
try any of the following:  

�� Check if there are printer settings you can change to adjust dithering behavior.  

�� Install a newer printer driver. 

�� Print to a color printer or a different type of one-color printer. 
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Displaying Selected Features Under Raster Layers 

If your graphics card supports only 256 colors or less, features selected under a raster layer may not be 
highlighted correctly. 

VBA Not Supported in Release 6 

Please note that VBA is not supported in Release 6 of Autodesk MapGuide, and using the ActiveX Control 
with VBA may result in erratic behavior. 

Problems with HP LaserJet Printers 

Some HP LaserJet printers require a specific Properties specification to support the ghosting feature. If you 
have trouble using this feature on your LaserJet, go to the Printer Properties screen (click the Properties 
button in any standard Print dialog box), click the Graphics tab, and then select Use Raster Graphics 
instead of Use Vector Graphics. 

Note The Graphics tab may not be available depending on your access rights to it. 

If you get a "Print Overrun Error" message on your printer, increase the Printer memory. (This setting is also 
in the Printer Properties dialog box.)  

Printing Problems with PCL Printer Drivers 

When printing a map from Autodesk MapGuide Viewer, some of the text labels and line breaks that are 
near the edge of the map may print outside of the map boundary and may not clip properly. Also, text may 
overprint other features in the map. These problems happen only on LaserJet printers that are using older 
Win95/WinNT PCL printer drivers.  

Viewing a Report for Multiple Features 

For each Web site and CGI gateway, there is a limit to the number of features that can be processed. If the 
CGI gateway does not process all selected features (that is, you failed to receive the report you requested for 
all selected features), you have selected too many features for the present Web site and gateway to handle.  

To remedy this problem, select fewer features, and then run the report again. 

Error Message "Missing parameter 'ITEM'" 

If you receive this error message, the Autodesk MapGuide Server that provides the data for the map you are 
viewing is probably using a slow connection. To remedy this problem, please inform the server 
administrator that you have received this error message and that Autodesk MapGuide Server needs to be 
reconfigured to use the NSAPI or ISAPI version of the map agent.  

Web Browser Window Displaying Behind Other Windows 

When Autodesk MapGuide Viewer asks your Web browser to display a URL in a window, it has little control 
over how the window is displayed. When a map is loaded, the Web browser window is sometimes displayed 
behind other windows, rather than in front as you would expect. This often happens when you minimize a 
window. This problem also occurs when Autodesk MapGuide displays an error message, because error 
messages display in a separate window. 

To remedy this problem, close all other browser windows. If no additional browser windows are open when 
Autodesk MapGuide Viewer creates a new window, the new window automatically appears in front of any 
other program and document windows that are open. 
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Map Scale Rounded Up or Down 

If are using a very small-scale map (such as 1:1,000,000), you may notice that the scale is not precisely what 
you specified. With very small-scale maps, Autodesk MapGuide Viewer sometimes rounds the scale to a 
higher or lower value. 

Legend Width in Plug-In and Java Viewer 

The legend width of the ActiveX control Viewer can be controlled from the API by using an existing 
property. The Plug-In and Java Edition do not have corresponding methods to change the Legend Width, 
so the Viewer legend width cannot be set for the Plug-In and Java Edition from the API. You can, however, 
use the LAYERSVIEWWIDTH URL parameter to set the legend width for the Plug-In and Java Edition 
Viewers. 

ActiveX Control Cannot Open Reports Whose Names Contain Double Quotation Marks 

If you are using the ActiveX Control Viewer, you will not be able to open reports whose names contain 
double quotation marks, for example "Server Report." You can, however, open reports whose names contain 
single quotation marks, for example 'Server Report.' Contact the author of the map if you have trouble 
opening reports. 

Issues with Microsoft Internet Explorer 

The following notes relate specifically to using Microsoft Internet Explorer. 

Setting High Security Disables the Viewer 

With Microsoft Internet Explorer 5.x, if you set security to High, you will not be able to view maps. 

To remedy this problem, in Microsoft Internet Explorer, choose View > Internet Options, and then set 
security to Medium. 

Help Files Not Uninstalled 

If you install multiple copies of Autodesk MapGuide Viewer ActiveX Control in different locations, and you 
uninstall one of the copies, the \help directory and all of its files for that copy are not uninstalled. To 
remove these files, you must delete them manually. 

Printing Problem 

If you try to print using Microsoft Internet Explorer's File > Print command, a blank space will appear on 
the printed page where the Autodesk MapGuide Viewer ActiveX Control resides.  

To remedy this problem, use the Print > Print command (if available) from the popup menu in Autodesk 
MapGuide Viewer.  

Print Preview Does Not Work 

The Microsoft Internet Explorer 5.5 Print Preview command does not work with Autodesk MapGuide 
Viewer. 

Stopping Microsoft Internet Explorer 

If you click the Stop button on the Microsoft Internet Explorer toolbar while the Autodesk MapGuide 
Viewer ActiveX Control is downloading map data, the download process will terminate. However, the 
ActiveX Control will continue to display the hourglass cursor. To remedy this, click the Stop button on the 
ActiveX Control toolbar to restore the normal cursor. 
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Browsing to an MWF Not Supported 

With Microsoft Internet Explorer 5.x, if you enter the path name of a map window file (MWF) in the 
address field (such as c:\maps\tutorial.mwf), or if you browse to it, the browser will not display the map. To 
work around this limitation, embed the MWF file in an HTML page, or add a link to the MWF file from an 
HTML page. 

Issues with Netscape Navigator 

The following notes relate specifically to using Netscape Navigator. 

Problems Using True Color Mode 

If you are running Windows NT 4 with Service Pack 3, and you are using Netscape Navigator 4.03 or 4.04 as 
your browser, you should not use True Color mode as your display color palette, as it can cause intermittent 
problems using Autodesk MapGuide Viewer. Instead, in Display Settings in the Control Panel, change your 
color palette mode to 65536 or any setting other than True Color mode. 

Issues with the Java Edition of the Viewer 

The following notes relate specifically to using the Java Edition of the Viewer. 

Problems Using Microsoft Internet Explorer 5.x with Mac OS 

The Java Edition of the Viewer does not run if you are using Microsoft Internet Explorer 5.x with Mac OS 
Runtime for Java (MRJ) 2.2. You need to upgrade to MRJ 2.2.4 or later. 

Problems Printing Zoomed Maps 

If you zoom in on a map and then print the map, the printed map will appear as if you had not zoomed in. 

Cursor Stays in Busy State (Hourglass) 

Using certain commands such as Zoom Goto in the Java Edition can cause the cursor to go into a perpetual 
busy state, displaying an hourglass when the cursor is over the map window. To remedy this problem, click 
the Select button on the toolbar. 

Java Viewer and Internet Explorer 

If you are using the Java Edition of Autodesk MapGuide Viewer with Internet Explorer and you click outside 
any Autodesk MapGuide Viewer dialog box, the dialog box will go behind the Internet Explorer window. 

Map Does Not Load in Java Edition in IE 5.x 

When using Microsoft Internet Explorer 5.x, you might have trouble loading maps in the Java Edition of 
Autodesk MapGuide Viewer. This can happen when your Web page uses percentages instead of fixed width 
and height values to display the Java Edition Viewer. You can prevent this problem by not using 
percentages. If you decide to use percentages and the problem does occur, try the following procedure until 
the problem is remedied: 

1. Click the Refresh button to reload the map. 

2. Press the Shift key while clicking the Refresh button to reload the page. 

3. Clear the browser's cache, and then reenter the URL to load the page again. 

4. Restart the computer. 

5. Uninstall and reinstall the Java Edition Viewer, restarting the computer if necessary. 
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Additionally, you should always wait for the map to load completely before exiting the browser, as this can 
cause the application to fail. 

Limited Cursors 

Unlike the Plug-In and ActiveX Control, the Java Edition Viewer does not display different cursors for many 
operations. The Java Edition Viewer uses only a selection cursor, a pan cursor, and a general cursor for all 
other operations. 

Regional Settings Not Recognized 

The Java Edition Viewer does not recognize changes you make using the Regional Settings Properties 
Control Panel. For example, if you change the date format or the decimal symbol, the Java Edition Viewer 
will not use the new settings. 

Refreshing Map from Browser Redraws Map at Current Scale 

If you zoom in on a map and then use the browser's Refresh or Reload command, the map is redrawn at the 
current scale rather than returning to the original scale. 

Error Messages Stay on Screen after Closing Browser 

If you receive an error message while using the Java Edition Viewer, be sure to close the error message 
before closing the browser. Although you can close the error message after closing an Internet Explorer 
browser, you cannot close the error message after closing a Netscape browser. If you inadvertently close a 
Netscape browser while an error message is on the screen, you will need to press CTRL+ALT+DEL and end 
the task. 

Printing Page Settings Are Not Saved 

When you set page setup options (such as changing the page orientation from Portrait to Landscape) and 
print a map in the Java Edition Viewer, the Page Setup options will be reset to their default state the next 
time you print the map. To print the map again with the same settings, you will need to specify the settings 
again before printing. 

Printing Using Browser's Print Command Does Not Work Properly 

If you use your browser's Print command in the Java Edition Viewer, you may get a blurry or blank 
printout. To avoid this problem, always use the Print command in the Viewer popup menu. 

Printing Problems from Netscape 4.x 

When printing polypolygons from Netscape 4.x using the Print command in the Java Edition Viewer popup 
menu, you may find connecting lines between the polypolygons on the printout. To avoid this problem, 
use a different browser. 

Layer Names Truncated When Printing from Mac OS 

If you print using the Java Edition Viewer from a Macintosh OS computer, you may notice that legend 
labels are cut off in the printed map.  

Java Viewer Reports 

The API call to View Reports does not work on the MacOS/MRJ 2.2 platform, but does work for the View 
Reports button and popup menu. Unlike Netscape and IE on the Windows platform, Apple's MRJ virtual 
machine uses the standard JDK 1.1 applet security mechanism. Unless the applet is signed or put into the 
Java Runtime library directory, the applet will run inside a sandbox and will not have access to the local file 
system. For more information, see Apple's MRJ Technotes TN 1175: Applet signing with MRJ and JavaKey. 
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Duplicate Commands Appear in Popup Menu 

If you are using the Java Edition Viewer with Microsoft Internet Explorer, you may notice the same 
commands appearing multiple times in the popup menu. If this happens, you may need to update your 
version of the Java Virtual Machine. Following are the versions of the Java Virtual Machine that are 
required for Internet Explorer: 

InterInterInterInternet Explorer Versionnet Explorer Versionnet Explorer Versionnet Explorer Version    Java Virtual Machine BuildJava Virtual Machine BuildJava Virtual Machine BuildJava Virtual Machine Build    

Internet Explorer 5 Build 3193 

Internet Explorer 5.01 Build 3240 

You can download the Java Virtual Machine builds from the Microsoft Web site.  

Revised: September 19, 2001 
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